[phone-app]*#06# does not report IMEI when no SIM present

Bug #1346837 reported by Jonathan Cave on 2014-07-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Olga Kemmet
dialer-app
Medium
Unassigned
dialer-app (Ubuntu)
Medium
Unassigned

Bug Description

1. Boot the phone with no SIM present. (No SIMs present for dual-sim)
2. Open the dialer.
(2a. Select one of the SIM slots)
3. Dial *#06#

Expected result:
   Dialog presented with the IMEI for the corresponding SIM slot.

Current result:
   Dialog is shown but the IMEI field is empty

This works when a SIM is present, but should not be dependent on this.

Related branches

lp:~tiagosh/dialer-app/sim-presence
Merged into lp:dialer-app at revision 230
Gustavo Pichorim Boiko: Approve on 2014-08-21
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-08-20
Changed in dialer-app:
status: New → Confirmed
summary: - *#06# does not report IMEI when no SIM present
+ [phone-app]*#06# does not report IMEI when no SIM present
Changed in ubuntu-ux:
assignee: nobody → Olga Kemmet (olga-kemmet)
status: New → Fix Committed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dialer-app (Ubuntu):
status: New → Confirmed
Bill Filler (bfiller) on 2014-07-30
Changed in dialer-app:
importance: Undecided → Medium
Changed in dialer-app (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
Tiago Salem Herrmann (tiagosh) wrote :

As per design, we should not display information about slots without sim cards, so this situation would never happen.
The fix for it is coming soon.

Changed in ubuntu-ux:
status: Fix Released → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers