Call length is 23 hours for all calls

Bug #1242772 reported by Sam Bull on 2013-10-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dialer-app
Critical
Gustavo Pichorim Boiko
dialer-app (Ubuntu)
Critical
Gustavo Pichorim Boiko

Bug Description

Calls in the call log are all listed as 23 hours. This is similar to an old bug that was supposed to be fixed in the new dialer-app, but unfortunately seems to have crept back in.

Related branches

tags: added: avengers

This has happened before and was fixed, so it's regressed again.

Pat McGowan (pat-mcgowan) wrote :

Seems to be fixed again

Changed in dialer-app:
status: New → Fix Released
Sam Bull (dreamsorcerer) wrote :

Still present on my phone, tried taking a screenshot, but it just says:
s@s-Air:~$ phablet-screenshot Desktop/23hours.png
I: surfaceflinger detected
I: Capturing screenshot with screencap ...

and hangs indefinitely.

Changed in dialer-app:
status: Fix Released → New
Pat McGowan (pat-mcgowan) wrote :

@sam will need some more info then
What image version, what device, how is your time and timezone set, etc

Sam Bull (dreamsorcerer) wrote :

Current version (r121 if I remember correctly), on mako. Timezone settings were set using whatever instructions were on the release notes page at the time. I've been using it since February just upgrading through the normal mechanisms.

Anything I can run to give you more information?

Gustavo Pichorim Boiko (boiko) wrote :

Is this still happening for new calls?
The ones that are already in the log are probably going to still have the wrong values, but new ones should be ok.

Changed in dialer-app:
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Sam Bull (dreamsorcerer) wrote :

Yes, my last call was the 18th, 2 days ago, still shows 23 hours.

Pat McGowan (pat-mcgowan) wrote :

I reproduced this
- changed my timezone to utc
- made a call, the call showed as 16 hrs (I am in EST)
The system date/time was changed but it did not seem to propagate to the shell/qt level as the indicator never adjusted)
- rebooted the phone, everything showed the new time, and all calls in the log were 23hrs, not just the recent call after the change

Changed in dialer-app:
importance: Undecided → Critical
status: New → Confirmed
Changed in dialer-app (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Pat McGowan (pat-mcgowan) wrote :

After resetting the timezone back to my real local time, the call log is fine again.

Pat McGowan (pat-mcgowan) wrote :

f the phone is set to automatic in date/time, then there is no 16 hr duration and no need to reboot the phone
(I had been playing with manual settings so the symptom was different)

Pat McGowan (pat-mcgowan) wrote :

Also noticing that the call time seems to be saved in the local time at the time of the call. When the timezone is adjusted calls are listed not in the actual order they were made.

I would suggest always storing the call time stamps in UTC but display relative to current local time.
Note that android avoids this by showing the call time relative to current time (2 hrs ago), and not an actual time (13:22)

Sam Bull (dreamsorcerer) wrote :

Interesting, I've had mine on automatic date/time for ages and still get the problem.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:dialer-app at revision 89, scheduled for release in dialer-app, milestone Unknown

Changed in dialer-app:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dialer-app - 0.1+14.04.20140130-0ubuntu1

---------------
dialer-app (0.1+14.04.20140130-0ubuntu1) trusty; urgency=low

  [ Bill Filler ]
  * o not pass the phone number as a parameter when pushing the live
    call view for an outgoing call. The correct value will be taken from
    the callManager. This fixes the problem of the header not updating
    when switching between multiple calls. Re-add try catch around
    autopilot test as the underlying mir/shell crash has not been fixed

  [ Martin Pitt ]
  * tests: Drop expected crash for LP#1240400, it's fixed now. (LP:
    #1240400)

  [ Gustavo Pichorim Boiko ]
  * Implement support for switching calls.
  * Fix a typo in the default avatar setting on history page.
  * Fix the call duration parsing by using Qt.formatTime() to split
    hours, minutes and seconds. (LP: #1242772)
  * o not pass the phone number as a parameter when pushing the live
    call view for an outgoing call. The correct value will be taken from
    the callManager. This fixes the problem of the header not updating
    when switching between multiple calls. Re-add try catch around
    autopilot test as the underlying mir/shell crash has not been fixed

  [ Omer Akram ]
  * Load testability driver if QT_LOAD_TESTABILITY is in the
    environment.

  [ Dimitri John Ledkov ]
  * Drop executing qmake, to query a variable, which is then not used.
    Adjust dependency on any:arch python, fixes cross-compilation.
    build-dependency installation.
 -- Ubuntu daily release <email address hidden> Thu, 30 Jan 2014 17:06:44 +0000

Changed in dialer-app (Ubuntu):
status: Confirmed → Fix Released
Sam Bull (dreamsorcerer) wrote :

Seems to have fixed it for me too. The entire call log is displaying correctly now, which means it's always been storing it correctly, it was only an issue with displaying.

Changed in dialer-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers