[dialer-app] You can quit the dialer app during active call

Bug #1227732 reported by Omer Akram on 2013-09-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Olga Kemmet
Unity 8
Fix Released
Undecided
Unassigned
dialer-app
High
Gustavo Pichorim Boiko
dialer-app (Ubuntu)
High
Gustavo Pichorim Boiko
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

this is the spec using the indicator https://docs.google.com/a/canonical.com/document/d/1BRy9-DEXr3A1D7PHkJaXmjbe7xbRmxKkzANXuu-F6lc/edit#heading=h.brylohrassdd

1. start a call
2. go to dash
3. close the phone app

What happens:
The call continues and there is no way to know if we really are in a call.

What should happen:
There should be an indicator in the top bar to show that the call is in progress with a way to directly switch to the call, as we see in Android.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: dialer-app 0.1+13.10.20130917-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.2-0ubuntu1
Architecture: armhf
Date: Thu Sep 19 15:11:11 2013
InstallationDate: Installed on 2013-09-18 (1 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20130918)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: dialer-app
UpgradeStatus: No upgrade log present (probably fresh install)

Omer Akram (om26er) wrote :
Changed in dialer-app (Ubuntu):
importance: Undecided → Medium
Changed in dialer-app:
importance: Undecided → Medium
tags: added: avengers qa-touch
description: updated
Changed in ubuntu-ux:
status: New → Fix Committed
assignee: nobody → Christina Li (christina-li)
importance: Undecided → High
Bill Filler (bfiller) on 2013-09-19
summary: - You can quit the dialer app with no way of knowing where the dialer is
+ You can quit the dialer app during active call
Changed in dialer-app (Ubuntu):
importance: Medium → High
Changed in dialer-app:
importance: Medium → High
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Changed in dialer-app (Ubuntu):
assignee: nobody → Gustavo Pichorim Boiko (boiko)

See the related bug lp:1227018 about having proper indicator support. However this is a different issue.

@boiko
I think we have two options here to consider
1) Exclude the dialer-app from the running apps list if it's on an active call
2) We should not allow the dialer-app to be closed from the shell during an active call
3) Or if it is killed through the shell hang up the call?

Note, that even if the app is killed and the call remains active, you can get back to the active call by relaunching the dialer and it does the right thing.

Changed in dialer-app (Ubuntu):
status: New → Confirmed
Changed in dialer-app:
status: New → Confirmed
Julien Funk (jaboing) on 2013-09-23
tags: added: jfunk
Julien Funk (jaboing) on 2013-09-24
tags: removed: jfunk
Omer Akram (om26er) on 2013-10-04
Changed in dialer-app:
status: Confirmed → Triaged
Changed in dialer-app (Ubuntu Saucy):
status: Confirmed → Triaged
Bill Filler (bfiller) wrote :

added a task for unity8
from the dialer's perspective, it can't control whether it's allowed to be killed from the shell. It will respond correctly if it is killed and reopened during an active call

no longer affects: dialer-app (Ubuntu Saucy)
Changed in dialer-app:
status: Triaged → Fix Released
status: Fix Released → Won't Fix
Changed in dialer-app (Ubuntu):
status: Triaged → Won't Fix
Michał Sawicz (saviq) wrote :

The desired solution has been implemented, there's an hint in the panel when there's a call in progress, and even if you close the dialer, you can get back to the call by tapping it.

Changed in unity8 (Ubuntu):
status: New → Fix Released
Changed in unity8:
status: New → Fix Released
Olga Kemmet (olga-kemmet) wrote :

Ubuntu-ux: marking as Fix Released because the communications hub spec is covering this use case and I can confirm that "the desired solution has been implemented, there's an hint in the panel when there's a call in progress, and even if you close the dialer, you can get back to the call by tapping it." (saviq)

Changed in ubuntu-ux:
assignee: Christina Li (christina-li) → Olga Kemmet (olga-kemmet)
status: Fix Committed → Fix Released
summary: - You can quit the dialer app during active call
+ [dialer-app] You can quit the dialer app during active call
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers