End call button doesn't work for shortcuts like t-mobile voicemail

Bug #1223303 reported by Dennis O'Flaherty on 2013-09-10
This bug affects 3 people
Affects Status Importance Assigned to Milestone
dialer-app (Ubuntu)
Gustavo Pichorim Boiko

Bug Description

When placing a call, pressing the button to end it is non-responsive. Pressing it should immediately end the call but I need to wait until the other person hangs up or shut the phone off.

Bill Filler (bfiller) wrote :

this was fixed. please provide information about what build, hardware, package versions etc so we know if it's an issue again

Changed in dialer-app:
status: New → Incomplete
importance: Undecided → High
Dennis O'Flaherty (doflah) wrote :

I'm on a Nexus 4 with the 20130916.3 build. I noticed this work the other day so I tried it again. I think I've isolated the problem to calling numbers from shortcuts. If I call T-Mobile voicemail from "123" the touchpad/hangup button are inoperative. If I call the full number that winds up in the call log afterwards, everything works as expected. I also observed this happen when I dialed 611 (customer service shortcut), but had no problems when dialing friends/family with full numbers.

tags: added: dialer-app-aug-2013
Pat McGowan (pat-mcgowan) wrote :

@Dennis can you verify this on the recent release - dialing 611 and hanging up seems to be working fine.

Dennis O'Flaherty (doflah) wrote :

Still not working on mako r121.

Changed in dialer-app (Ubuntu):
importance: Undecided → High
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Pat McGowan (pat-mcgowan) wrote :

from 1268999

I noticed today that after I added a voicemail contact for TMobile and dialed the contact from the contacts app (ie, pressed the phone icon to dial the contact), the dialer opens, but I can't hangup the call. Steps I used to reproduce:

1. open contacts-app
2. select 'Add from the toolbar
3. add VM1 for the first name, add '123' for the Mobile number, press Save (this is TMobile's voicemail). This add the contact to the contact list
4. Select VM1 from the contact list
5. press the phone icon to dial the number
6. the dialer opens. when the voicemail system asks for a password, immediately press the red hangup button.

At this point, the call should end, but it does not. Repeatedly pressing the red hangup button does not work. Closing the dialer and the contacts app does not help. Interestingly, if after the dialer opens, I swipe right to left to get back to the contacts app, and then right to left to get back to the dialer, the dialer is in the call log, not the screen that shows the red hangup button, yet the call is not terminated because I can hear the voicemail system asking me for a password. Also, if I close the call log (presumably closing the dialer), the call does not terminate (perhaps this is by design to not lose the call, however, there is no way to get back to the call).

I feel like there are other times when I've been unable to hangup the dialer, but the only one I could reproduce today is when calling TMobile voicemail.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dialer-app (Ubuntu):
status: New → Confirmed
summary: - End call button doesn't work
+ End call button doesn't work for shortcuts like t-mobile voicemail
Changed in dialer-app:
status: Incomplete → Confirmed
Pat McGowan (pat-mcgowan) wrote :

bumped priority since there is no good workaround for dogfooders

Changed in dialer-app (Ubuntu):
importance: High → Critical
tags: added: avengers

I discovered this on mako #153 for dialling a contact from my address book (which I'd synced from google). I can dial a number manually and hang up okay, but can't hang up if it's a contact from the address book.

Pat McGowan (pat-mcgowan) wrote :

@popey are you specifically talking about shortcuts? as calling contacts seems to work fine.

Jamie Strandboge (jdstrand) wrote :

I can still reproduce this. If I use the full '18056377243' tmobile voicemail number and follow Pat's procedure, I cannot reproduce. If I use '123' instead and follow Pat's procedure, I can.

# system-image-cli -i
current build number: 194
device name: mako
channel: trusty
last update: 2014-02-20 20:01:49
version version: 194
version ubuntu: 20140220
version device: 20140115.1

Tiago Salem Herrmann (tiagosh) wrote :

The root of this problem is the same as another one I reported last year.
ofono returns an error and no dbus object path when you dial numbers that will be somehow redirected to another number.
This makes it impossible for telepathy-ofono to track the call properly.
I will mark this bug as duplicate as this issue needs to be fixed in ofono.

Hi, Nexus 4 ota 9... I think this fall into the same root... into 123 dialer I cannot make call, the button is non-responsive. No matter which is the number I compose

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers