Dialer app for Ubuntu Touch

[Dialer app] When dialling extremely long number restrict number of digits input

Reported by Ana Vadillo on 2012-11-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
Medium
Christina Li
dialer-app
Medium
Gustavo Pichorim Boiko
dialer-app (Ubuntu)
Medium
Gustavo Pichorim Boiko
Saucy
Medium
Gustavo Pichorim Boiko

Bug Description

When dialling an extremely long number, should place a digit restriction on the number of digits it can accept on entry point in the dialer.

Design recommends up to 20 digits, which should include the international call with area code.

Related branches

lp:~boiko/dialer-app/fix_1082054
Merged into lp:dialer-app at revision 51
Tiago Salem Herrmann: Approve on 2013-10-01
PS Jenkins bot: Approve (continuous-integration) on 2013-10-01
Alan Pope ㋛ (popey) on 2013-05-08
information type: Proprietary → Public
affects: marumbi → phone-app
Gustavo Pichorim Boiko (boiko) wrote :

Christina, could you please comment on what the behavior for this should be?

affects: phone-app → dialer-app
Changed in dialer-app:
assignee: nobody → Christina Li (christina-li)
Changed in ubuntu-ux:
status: New → Triaged
status: Triaged → In Progress
assignee: nobody → Christina Li (christina-li)
importance: Undecided → Medium
summary: - When dialling extremely long number the size shall reduce
+ [Dialer app] When dialling extremely long number the size shall reduce

Gustavo, bug description has been updated with design input. However, worth checking with Tony to see if our recommendation is ok.

summary: - [Dialer app] When dialling extremely long number the size shall reduce
+ [Dialer app] When dialling extremely long number restrict the size of
+ digits input
description: updated
summary: - [Dialer app] When dialling extremely long number restrict the size of
+ [Dialer app] When dialling extremely long number restrict number of
digits input
Changed in dialer-app:
assignee: Christina Li (christina-li) → nobody
Changed in ubuntu-ux:
status: In Progress → Fix Committed
Bill Filler (bfiller) wrote :

restrict to 20 chars per design

Changed in dialer-app:
status: New → Confirmed
Changed in dialer-app (Ubuntu):
status: New → Confirmed
Changed in dialer-app:
importance: Undecided → Medium
Changed in dialer-app (Ubuntu):
importance: Undecided → Medium
Changed in dialer-app:
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Changed in dialer-app (Ubuntu):
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Changed in dialer-app:
status: Confirmed → In Progress
Changed in dialer-app (Ubuntu Saucy):
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:dialer-app at revision 51, scheduled for release in dialer-app, milestone Unknown

Changed in dialer-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dialer-app - 0.1+13.10.20131001.4-0ubuntu1

---------------
dialer-app (0.1+13.10.20131001.4-0ubuntu1) saucy; urgency=low

  [ Tiago Hillebrandt ]
  * Empty KeyPad entry after start call.

  [ Gustavo Pichorim Boiko ]
  * Update some icons to use the theme instead of the local assets. Also
    set the backspace icon to be white when there is text to erase. (LP:
    #1226157)
  * Make the text center aligned in the dialer input field. - Change the
    cursor delegate to use the correct color. (LP: #1229202, #1222902)
  * Limit the number of digits to 20 and scale the font down when the
    numbers don't fit on the screen. (LP: #1082054)

  [ Tiago Salem Herrmann ]
  * Push views to the pagestack even before the telepathy channel is
    created. (LP: #1218311)
  * Add support for expansive delegates on call log view.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 52
 -- Ubuntu daily release <email address hidden> Tue, 01 Oct 2013 21:20:44 +0000

Changed in dialer-app (Ubuntu Saucy):
status: In Progress → Fix Released
Nautilus (doneill-foxmoxie) wrote :

I hate to stir up an old bug, but as some user feedback Wind Mobile in Canada uses prepaid vouchers which depend on the ability to enter 25 digits. (By the way, what's the motivation behind this digit limitation? It confused the tech I was working with since it was the first time he's seen such a restriction.)

Changed in dialer-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers