Data Element Group Editor does not show any group members

Bug #363645 reported by Ola Hodne Titlestad on 2009-04-19
2
Affects Status Importance Assigned to Milestone
DHIS
High
Saptarshi

Bug Description

The Data Element Group Editor seems to be inactive somehow.
When I browse through the groups on the left side the members box in the middle remains empty. Furthermore, in the right side available data elements box all DE are greyed out.

I've checked the simple (one by one) Data Element Group list and opened edit windows there, and there are many groups with members there.

The Indicator Group Editor which is exactly the same works fine though.

UPDATE:
(debugging done on the online demo, www.hisp.info/demo/za build date is April 18, 2009.)
This bug is very weird:
When I write something in the Data Element Group filter and then click on a group everything works as expected.
BUT if I do not touch the filter and in stead select a group in the list then nothing happens..........

Related branches

description: updated
Saptarshi (sunbiz) wrote :

Rev-194, committed fix to resolve this issue which was a regression from rev-191. Reverting incomplete commit to dataElementGroupEditor.js file

Saptarshi (sunbiz) wrote :

Reverting incomplete commit to dataElementGroupEditor.js file

Changed in dhis2:
assignee: nobody → sunbiz
importance: Undecided → High
milestone: none → 2.0.1
status: New → Fix Committed
Saptarshi (sunbiz) on 2011-02-24
Changed in dhis2:
status: Fix Committed → Opinion
Changed in dhis2:
status: Opinion → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers