User filter in add/edit user group not working

Bug #1541131 reported by Lars Helge Øverland on 2016-02-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DHIS
Medium
Morten Olav Hansen

Bug Description

The user filter in add/edit user group not is working. There is a mismatch between what the client sends (name:eq:somename) and what the UserController expects (query).

Changed in dhis2:
assignee: nobody → Morten Olav Hansen (mortenoh)
importance: Undecided → Medium
milestone: none → 2.23
status: New → Confirmed
Morten Olav Hansen (mortenoh) wrote :

Fixed and backportet to 2.22. Caused by incorrect override of AbstractCrudController.getEntityList, only custom logic without calling proper query service to handle filters/orders.

Changed in dhis2:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers