Removing Axis settings not saved to favorite

Bug #1528891 reported by Timothy Harding on 2015-12-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DHIS
Medium
Jan Henrik Øverland

Bug Description

Hello Hello Devs!

Seeing in versions 2.20 and 2.21 (including the SL Demo)

Steps to reproduce
1. Create a datavisulizer favorite with a custom axis
2. Remove the custom axis values (to get the chart to reset to auto)
3. Overwrite the existing favorite
4. Reload the favorite, it will revert back to the last custom settings saved

The work around is just to create a new favorite without ever touching the custom axis or update the axis to include all the values (but this can change from day to day) as needed, because currently there is no way to just remove them.

Timothy Harding (tharding-8) wrote :
Changed in dhis2:
milestone: none → 2.22
assignee: nobody → Jan Henrik Øverland (janhenrik-overland)
importance: Undecided → High
importance: High → Critical
status: New → Confirmed
importance: Critical → Medium
Changed in dhis2:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments