Yes/No Value Type and data saving

Reported by Prosper BEHUMBIIZE on 2012-08-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DHIS
Critical
Lars Helge Øverland

Bug Description

With the update to 2.9, the data elements with the value type Yes/No dont save after data entry

Prosper and Dapo,

Thanks for reporting bugs.

I did test this just now on the apps.dhis2.org/dev server and it
worked to save new data values for Yes/No data elements.

Try to enter data for Sierra Leone and test dataset (will only be
available up to midnight Oslo time today) here:
http://apps.dhis2.org/dev/dhis-web-dataentry/index.action

This was for a newly created data element with ValueType Yes/No and
the values are saved.

Can you describe your problem in a little more detail please.

Ola
-----

----------------------------------
Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 9 August 2012 18:36, Prosper BEHUMBIIZE <email address hidden> wrote:
> Public bug reported:
>
> With the update to 2.9, the data elements with the value type Yes/No
> dont save after data entry
>
> ** Affects: dhis2
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of DHIS 2
> developers, which is subscribed to DHIS.
> https://bugs.launchpad.net/bugs/1034979
>
> Title:
> Yes/No Value Type and data saving
>
> Status in DHIS 2 - District Health Information Software:
> New
>
> Bug description:
> With the update to 2.9, the data elements with the value type Yes/No
> dont save after data entry
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dhis2/+bug/1034979/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~dhis2-devs
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~dhis2-devs
> More help : https://help.launchpad.net/ListHelp

Download full text (3.2 KiB)

Thanks Ola,
Data Elements created in earlier versions with Value Type Yes/No were deactivated from the corresponding datasets. When one tries to reactivate and save, it does save but the elements get deactivated almost immediately again.

......................................................................................................................................................

Regards,

Dapo Adejumo
+2348033683677
Skype : dapojorge

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Ola Hodne Titlestad
Sent: Friday, August 10, 2012 9:39 AM
To: <email address hidden>
Subject: Re: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and data saving

Prosper and Dapo,

Thanks for reporting bugs.

I did test this just now on the apps.dhis2.org/dev server and it worked to save new data values for Yes/No data elements.

Try to enter data for Sierra Leone and test dataset (will only be available up to midnight Oslo time today) here:
http://apps.dhis2.org/dev/dhis-web-dataentry/index.action

This was for a newly created data element with ValueType Yes/No and the values are saved.

Can you describe your problem in a little more detail please.

Ola
-----

----------------------------------
Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 9 August 2012 18:36, Prosper BEHUMBIIZE <email address hidden> wrote:
> Public bug reported:
>
> With the update to 2.9, the data elements with the value type Yes/No
> dont save after data entry
>
> ** Affects: dhis2
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of DHIS 2
> developers, which is subscribed to DHIS.
> https://bugs.launchpad.net/bugs/1034979
>
> Title:
> Yes/No Value Type and data saving
>
> Status in DHIS 2 - District Health Information Software:
> New
>
> Bug description:
> With the update to 2.9, the data elements with the value type Yes/No
> dont save after data entry
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dhis2/+bug/1034979/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~dhis2-devs
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~dhis2-devs
> More help : https://help.launchpad.net/ListHelp

--
You received this bug notification because you are a member of DHIS 2 developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1034979

Title:
  Yes/No Value Type and data saving

Status in DHIS 2 - District Health Information Software:
  New

Bug description:
  With the update to 2.9, the data elements with the value type Yes/No
  dont save after data entry

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1034979/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-devs
Post to : <email address hidden>
Unsubscri...

Read more...

Dapo Adejumo (dapo-adejumo) wrote :
Download full text (3.8 KiB)

There are presently no data elements allocated to the dataset on the demo site....I am guessing they have been deactivated like described.

......................................................................................................................................................

Regards,

Dapo Adejumo
+2348033683677
Skype : dapojorge

-----Original Message-----
From: Dapo Adejumo [mailto:<email address hidden>]
Sent: Friday, August 10, 2012 10:01 AM
To: 'Bug 1034979'; '<email address hidden>'
Subject: RE: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and data saving

Thanks Ola,
Data Elements created in earlier versions with Value Type Yes/No were deactivated from the corresponding datasets. When one tries to reactivate and save, it does save but the elements get deactivated almost immediately again.

......................................................................................................................................................

Regards,

Dapo Adejumo
+2348033683677
Skype : dapojorge

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Ola Hodne Titlestad
Sent: Friday, August 10, 2012 9:39 AM
To: <email address hidden>
Subject: Re: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and data saving

Prosper and Dapo,

Thanks for reporting bugs.

I did test this just now on the apps.dhis2.org/dev server and it worked to save new data values for Yes/No data elements.

Try to enter data for Sierra Leone and test dataset (will only be available up to midnight Oslo time today) here:
http://apps.dhis2.org/dev/dhis-web-dataentry/index.action

This was for a newly created data element with ValueType Yes/No and the values are saved.

Can you describe your problem in a little more detail please.

Ola
-----

----------------------------------
Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 9 August 2012 18:36, Prosper BEHUMBIIZE <email address hidden> wrote:
> Public bug reported:
>
> With the update to 2.9, the data elements with the value type Yes/No
> dont save after data entry
>
> ** Affects: dhis2
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of DHIS 2
> developers, which is subscribed to DHIS.
> https://bugs.launchpad.net/bugs/1034979
>
> Title:
> Yes/No Value Type and data saving
>
> Status in DHIS 2 - District Health Information Software:
> New
>
> Bug description:
> With the update to 2.9, the data elements with the value type Yes/No
> dont save after data entry
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dhis2/+bug/1034979/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~dhis2-devs
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~dhis2-devs
> More help : https://help.launchpad.net/ListHelp

--
You received this bug notification...

Read more...

Download full text (4.9 KiB)

Dapo,

I just tried the demo site again (using the link I gave) and it still
works. There's one data element in that dataset called "Test element"
and I can give it either Yes or No values and it saves (goes green and
stays when I switch the period back and forth).

Maybe this is a browser cache issue? Try to clear browser and
application cache, or try to test this is an Chrome Incognito window.

Ola
------

----------------------------------
Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 10 August 2012 11:35, Dapo Adejumo <email address hidden> wrote:
> There are presently no data elements allocated to the dataset on the demo site....I am guessing they have been deactivated like described.
>
>
> ......................................................................................................................................................
>
> Regards,
>
> Dapo Adejumo
> +2348033683677
> Skype : dapojorge
>
>
> -----Original Message-----
> From: Dapo Adejumo [mailto:<email address hidden>]
> Sent: Friday, August 10, 2012 10:01 AM
> To: 'Bug 1034979'; '<email address hidden>'
> Subject: RE: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and data saving
>
> Thanks Ola,
> Data Elements created in earlier versions with Value Type Yes/No were deactivated from the corresponding datasets. When one tries to reactivate and save, it does save but the elements get deactivated almost immediately again.
>
>
> ......................................................................................................................................................
>
> Regards,
>
> Dapo Adejumo
> +2348033683677
> Skype : dapojorge
>
> -----Original Message-----
> From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Ola Hodne Titlestad
> Sent: Friday, August 10, 2012 9:39 AM
> To: <email address hidden>
> Subject: Re: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and data saving
>
> Prosper and Dapo,
>
> Thanks for reporting bugs.
>
> I did test this just now on the apps.dhis2.org/dev server and it worked to save new data values for Yes/No data elements.
>
> Try to enter data for Sierra Leone and test dataset (will only be available up to midnight Oslo time today) here:
> http://apps.dhis2.org/dev/dhis-web-dataentry/index.action
>
> This was for a newly created data element with ValueType Yes/No and the values are saved.
>
> Can you describe your problem in a little more detail please.
>
> Ola
> -----
>
>
>
> ----------------------------------
> Ola Hodne Titlestad (Mr)
> HISP
> Department of Informatics
> University of Oslo
>
> Mobile: +47 48069736
> Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link
>
>
> On 9 August 2012 18:36, Prosper BEHUMBIIZE <email address hidden> wrote:
>> Public bug reported:
>>
>> With the update to 2.9, the data elements with the value type Yes/No
>> dont save after data entry
>>
>> ** Affects: dhis2
>> Importance: Undecided
>> Status: New
>>
>> --
>> You rec...

Read more...

Dapo Adejumo (dapo-adejumo) wrote :
Download full text (5.6 KiB)

Ok Ola.....I am not paranoid but I think the problem might be your own cache....If you go back to edit that particular dataset you will discover that particular element - "Test element" is no longer allocated to that dataset.
Thanks!

......................................................................................................................................................

Regards,

Dapo Adejumo
+2348033683677
Skype : dapojorge

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Ola Hodne Titlestad
Sent: Friday, August 10, 2012 11:15 AM
To: Dapo Adejumo
Cc: Bug 1034979; <email address hidden>
Subject: Re: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and data saving

Dapo,

I just tried the demo site again (using the link I gave) and it still works. There's one data element in that dataset called "Test element"
and I can give it either Yes or No values and it saves (goes green and stays when I switch the period back and forth).

Maybe this is a browser cache issue? Try to clear browser and application cache, or try to test this is an Chrome Incognito window.

Ola
------

----------------------------------
Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 10 August 2012 11:35, Dapo Adejumo <email address hidden> wrote:
> There are presently no data elements allocated to the dataset on the demo site....I am guessing they have been deactivated like described.
>
>
> ......................................................................................................................................................
>
> Regards,
>
> Dapo Adejumo
> +2348033683677
> Skype : dapojorge
>
>
> -----Original Message-----
> From: Dapo Adejumo [mailto:<email address hidden>]
> Sent: Friday, August 10, 2012 10:01 AM
> To: 'Bug 1034979'; '<email address hidden>'
> Subject: RE: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and
> data saving
>
> Thanks Ola,
> Data Elements created in earlier versions with Value Type Yes/No were deactivated from the corresponding datasets. When one tries to reactivate and save, it does save but the elements get deactivated almost immediately again.
>
>
> ......................................................................................................................................................
>
> Regards,
>
> Dapo Adejumo
> +2348033683677
> Skype : dapojorge
>
> -----Original Message-----
> From: <email address hidden>
> [mailto:<email address hidden>]
> On Behalf Of Ola Hodne Titlestad
> Sent: Friday, August 10, 2012 9:39 AM
> To: <email address hidden>
> Subject: Re: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and
> data saving
>
> Prosper and Dapo,
>
> Thanks for reporting bugs.
>
> I did test this just now on the apps.dhis2.org/dev server and it worked to save new data values for Yes/No data elements.
>
> Try to enter data for Sierra Leone and test dataset (will only be available up to midnight Oslo time today) here:
> htt...

Read more...

Ola Hodne Titlestad (olatitle) wrote :
Download full text (6.5 KiB)

Hi,

You are right that there is something funny here. When I tried again
now I can see that the values are not being saved. That did not
happen earlier.

But not sure I understand what you mean by "not allocated", because
the data element is still there in the data entry form, but the values
are being reset to "No Value", which I guess is what Prosper also
reported.

The devs will need to look at this.

Ola
--------

----------------------------------
Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 10 August 2012 12:22, Dapo Adejumo <email address hidden> wrote:
> Ok Ola.....I am not paranoid but I think the problem might be your own cache....If you go back to edit that particular dataset you will discover that particular element - "Test element" is no longer allocated to that dataset.
> Thanks!
>
>
> ......................................................................................................................................................
>
> Regards,
>
> Dapo Adejumo
> +2348033683677
> Skype : dapojorge
>
>
> -----Original Message-----
> From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Ola Hodne Titlestad
> Sent: Friday, August 10, 2012 11:15 AM
> To: Dapo Adejumo
> Cc: Bug 1034979; <email address hidden>
> Subject: Re: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and data saving
>
> Dapo,
>
> I just tried the demo site again (using the link I gave) and it still works. There's one data element in that dataset called "Test element"
> and I can give it either Yes or No values and it saves (goes green and stays when I switch the period back and forth).
>
> Maybe this is a browser cache issue? Try to clear browser and application cache, or try to test this is an Chrome Incognito window.
>
> Ola
> ------
>
>
> ----------------------------------
> Ola Hodne Titlestad (Mr)
> HISP
> Department of Informatics
> University of Oslo
>
> Mobile: +47 48069736
> Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link
>
>
> On 10 August 2012 11:35, Dapo Adejumo <email address hidden> wrote:
>> There are presently no data elements allocated to the dataset on the demo site....I am guessing they have been deactivated like described.
>>
>>
>> ......................................................................................................................................................
>>
>> Regards,
>>
>> Dapo Adejumo
>> +2348033683677
>> Skype : dapojorge
>>
>>
>> -----Original Message-----
>> From: Dapo Adejumo [mailto:<email address hidden>]
>> Sent: Friday, August 10, 2012 10:01 AM
>> To: 'Bug 1034979'; '<email address hidden>'
>> Subject: RE: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and
>> data saving
>>
>> Thanks Ola,
>> Data Elements created in earlier versions with Value Type Yes/No were deactivated from the corresponding datasets. When one tries to reactivate and save, it does save but the elements get deactivated almost immediately again.
>>
>>
>> ................................................................................................................

Read more...

Ola Hodne Titlestad (olatitle) wrote :
Download full text (7.0 KiB)

Now I also got the issue with the disappearing data element...

Ola
.........

----------------------------------
Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 10 August 2012 12:30, Ola Hodne Titlestad <email address hidden> wrote:
> Hi,
>
> You are right that there is something funny here. When I tried again
> now I can see that the values are not being saved. That did not
> happen earlier.
>
> But not sure I understand what you mean by "not allocated", because
> the data element is still there in the data entry form, but the values
> are being reset to "No Value", which I guess is what Prosper also
> reported.
>
> The devs will need to look at this.
>
> Ola
> --------
>
>
>
> ----------------------------------
> Ola Hodne Titlestad (Mr)
> HISP
> Department of Informatics
> University of Oslo
>
> Mobile: +47 48069736
> Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link
>
>
> On 10 August 2012 12:22, Dapo Adejumo <email address hidden> wrote:
>> Ok Ola.....I am not paranoid but I think the problem might be your own cache....If you go back to edit that particular dataset you will discover that particular element - "Test element" is no longer allocated to that dataset.
>> Thanks!
>>
>>
>> ......................................................................................................................................................
>>
>> Regards,
>>
>> Dapo Adejumo
>> +2348033683677
>> Skype : dapojorge
>>
>>
>> -----Original Message-----
>> From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Ola Hodne Titlestad
>> Sent: Friday, August 10, 2012 11:15 AM
>> To: Dapo Adejumo
>> Cc: Bug 1034979; <email address hidden>
>> Subject: Re: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and data saving
>>
>> Dapo,
>>
>> I just tried the demo site again (using the link I gave) and it still works. There's one data element in that dataset called "Test element"
>> and I can give it either Yes or No values and it saves (goes green and stays when I switch the period back and forth).
>>
>> Maybe this is a browser cache issue? Try to clear browser and application cache, or try to test this is an Chrome Incognito window.
>>
>> Ola
>> ------
>>
>>
>> ----------------------------------
>> Ola Hodne Titlestad (Mr)
>> HISP
>> Department of Informatics
>> University of Oslo
>>
>> Mobile: +47 48069736
>> Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link
>>
>>
>> On 10 August 2012 11:35, Dapo Adejumo <email address hidden> wrote:
>>> There are presently no data elements allocated to the dataset on the demo site....I am guessing they have been deactivated like described.
>>>
>>>
>>> ......................................................................................................................................................
>>>
>>> Regards,
>>>
>>> Dapo Adejumo
>>> +2348033683677
>>> Skype : dapojorge
>>>
>>>
>>> -----Original Message-----
>>> From: Dapo Adejumo [mailto:<email address hidden>]
>>> Sent: Friday, August 10, 2012 10:01 AM
>>> To: 'Bug 1034979'; '<email address hidden>...

Read more...

Dapo Adejumo (dapo-adejumo) wrote :
Download full text (7.3 KiB)

Glad you can finally see this! The element you are still seeing on the entry screen is only stored in your cache and not in the database. You can verify this by trying to edit the dataset " test data set" , you will see that no element is allocated to that particular dataset anymore.

......................................................................................................................................................

Regards,

Dapo Adejumo
+2348033683677
Skype : dapojorge

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Ola Hodne Titlestad
Sent: Friday, August 10, 2012 11:30 AM
To: Dapo Adejumo
Cc: Bug 1034979; <email address hidden>
Subject: Re: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and data saving

Hi,

You are right that there is something funny here. When I tried again now I can see that the values are not being saved. That did not happen earlier.

But not sure I understand what you mean by "not allocated", because the data element is still there in the data entry form, but the values are being reset to "No Value", which I guess is what Prosper also reported.

The devs will need to look at this.

Ola
--------

----------------------------------
Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 10 August 2012 12:22, Dapo Adejumo <email address hidden> wrote:
> Ok Ola.....I am not paranoid but I think the problem might be your own cache....If you go back to edit that particular dataset you will discover that particular element - "Test element" is no longer allocated to that dataset.
> Thanks!
>
>
> ......................................................................................................................................................
>
> Regards,
>
> Dapo Adejumo
> +2348033683677
> Skype : dapojorge
>
>
> -----Original Message-----
> From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Ola
> Hodne Titlestad
> Sent: Friday, August 10, 2012 11:15 AM
> To: Dapo Adejumo
> Cc: Bug 1034979; <email address hidden>
> Subject: Re: [Dhis2-devs] [Bug 1034979] [NEW] Yes/No Value Type and
> data saving
>
> Dapo,
>
> I just tried the demo site again (using the link I gave) and it still works. There's one data element in that dataset called "Test element"
> and I can give it either Yes or No values and it saves (goes green and stays when I switch the period back and forth).
>
> Maybe this is a browser cache issue? Try to clear browser and application cache, or try to test this is an Chrome Incognito window.
>
> Ola
> ------
>
>
> ----------------------------------
> Ola Hodne Titlestad (Mr)
> HISP
> Department of Informatics
> University of Oslo
>
> Mobile: +47 48069736
> Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link
>
>
> On 10 August 2012 11:35, Dapo Adejumo <email address hidden> wrote:
>> There are presently no data elements allocated to the dataset on the demo site....I am guessing they have been deactivated like described.
>>
>>
>> ................................................................

Read more...

Fixed and back-ported to 2.9 branch.

Changed in dhis2:
milestone: none → 2.9
assignee: nobody → Lars Helge Øverland (larshelge)
importance: Undecided → Critical
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers