libreoffice-writer needs libreoffice-base for form controls (libdbalo.so missing from libreoffice-base-core)

Bug #986205 reported by Franck on 2012-04-20
154
This bug affects 36 people
Affects Status Importance Assigned to Milestone
LibreOffice
Incomplete
Medium
libreoffice (Debian)
Fix Released
Unknown
libreoffice (Ubuntu)
High
Björn Michaelsen
Precise
Undecided
Unassigned
Quantal
High
Björn Michaelsen

Bug Description

LO in Ubuntu 12.04 fails to open an odt document that contains a checkbox.
Works fine in LO 3.4 on Ubuntu 11.10.

The problem occurs only when the package libreoffice-base is *not* installed and only for the Ubuntu package, i.e. either installing libreoffice-base or using libreoffice 3.5 from http://www.libreoffice.org/download/ allows to open the file.

[Test Case]
* Make sure libreoffice-base is not installed.
* Try to open https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/986205/+attachment/3095819/+files/test_lo_checkbox.odt
--> You receive a "Read-Error."

[Workaround]
Install the libreoffice-base package.

== Regression details ==
Discovered in version: 3.5.1-1ubuntu1
Last known good version: 3.4.4-0ubuntu1

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
Date: Fri Apr 20 16:06:09 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120307)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Franck (alci) wrote :

Created attachment 60394
Example document that fails

Problem description:
Fail to open an odt with a checkbox

Steps to reproduce:
1. create a file with a checkbox with lo3.4
2. try to open it with lo3.5

Current behavior: fails with Read-Error

Expected behavior: open the file

Platform (if different from the browser):

Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0

Franck (alci) wrote :

Opened a bug report on Libreoffice bugzilla see https://www.libreoffice.org/bugzilla/show_bug.cgi?id=48972

Not reproducible in Xubuntu 32-bit.

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/986205/+attachment/3095819/+files/test_lo_checkbox.odt && lowriter --nologo test_lo_checkbox.odt

 lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

 apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

tags: added: regression-release

I do not reproduce with LO 3.5.2 (TDF version) with FR langpack nor with
LibreOffice 3.5.4rc0+ (Version ID : 299387d-a73d29c-6845e52-f269e46-cd57e28) under Ubuntu 11.10 x86_64 (gnome-shell).

Please, who is your LO provider ? Ubuntu or TDF ? If you use an Ubuntu version, could you try again with TDF version from http://fr.libreoffice.org/telecharger/ or http://www.libreoffice.org/download/

Best regards. JBF

I can confirm this issue (for the file provided) on 64-Bit Ubuntu. I get the error message "Read-Error. Error reading file." I can open the file with abiword -- although I do not see any checkbox then (just the text "Test").

$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

$ LC_ALL=C apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://mirrors.ircam.fr/pub/ubuntu/archive/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Changed in libreoffice (Ubuntu):
status: New → Confirmed
summary: - Libreoffice fails to open odt document with a checkbox in it
+ [Upstream] Libreoffice fails to open odt document with a checkbox in it

I can reproduce the OP's error with Ubuntu's libreoffice version (3.5.2-2ubuntu1) on 64-Bit (another comment states that it is not reproducible on 32-Bit Xubuntu, though -- see the Ubuntu Bug Report: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/986205 ).

With Libreoffice from the TDF (i.e. installing all the .deb's in LibO_3.5.2rc2_Linux_x86-64_install-deb_en-US provided by http://www.libreoffice.org/download/) I can not reproduce it, so the problem seems to be Ubuntu (or Debian) specific.

I just tried the upstream LO version (i.e. installing all the .deb's in LibO_3.5.2rc2_Linux_x86-64_install-deb_en-US provided by
http://www.libreoffice.org/download/) and cannot reproduce the issue -- seems to be a Debian and/or Ubuntu problem.

Cannot reproduce on 3.5.2-2ubuntu1 on precise/amd64. Needs reproduction scenario => incomplete.

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete

see downstream: Not Ubuntu specific, cant reproduce with reporters version on precise/64Bit. Needs reproduction scenario.

This is odd... I just reproduced the issue again with a vanilla Ubuntu 12.04 beta image from ubuntu.com (ubuntu-12.04-beta2-desktop-amd64.iso): I started the ISO in a virtual machine, used "Try Ubuntu" mode and navigated to this bug report. On opening the attachment I got the "Read-Error". The beta still has 3.5.1-1ubuntu1, therefore I re-ran the ISO, this time doing a proper installation (English language, nothing fancy). The libreoffice packages have been automatically updated during the installation (i.e. they are now 3.5.2-2ubuntu1), but again -- "Read-Error" on the above file.

Alright, I did some more testing: The problem is reproducible if the libreoffice-base package is *not* installed. With libreoffice-base installed, the file opens and displays, without the package it shows the "Read-Error". This is only true for the Ubuntu Precise version, both the TDF as well as the Oneiric version can open the file without libreoffice-base.

Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed
description: updated

(again, see downstream:) The problem seems to be Ubuntu specific, after all. Ubuntu's LO 3.5.2 needs the libreoffice-base package installed to correctly open the file, with TDF's 3.5.2. (or earlier Ubuntu versions) this is not necessary.

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Incomplete

Probably the same problem, a simple document with a table and a couple of fields gives the read error on 12.04 32bit.

The document was created on OpenOffice 3.2.0 on Ubuntu 10.04.

Installing libreoffice-base fixed it.

I can attach the doc if it helps.

summary: - [Upstream] Libreoffice fails to open odt document with a checkbox in it
+ Libreoffice fails to open odt document with a checkbox in it
summary: - Libreoffice fails to open odt document with a checkbox in it
+ libreoffice-writer needs libreoffice-base for form controls

I had some further look into this and the problem seems to be inherited from Debian, the libreoffice versions in unstable and experimental both show the same behaviour as the Ubuntu version. I forwarded the bug to the Debian bugtracker: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=670350

summary: - libreoffice-writer needs libreoffice-base for form controls
+ libreoffice-writer needs libreoffice-base for form controls (libdbalo.so
+ missing from libreoffice-base-core)
Changed in libreoffice (Ubuntu):
milestone: none → precise-updates
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
importance: Undecided → High
status: Confirmed → In Progress

== SRU rationale ==
[Impact]
Writer will crash when opening documents needing -base-core components (e.g. form controls), causing possible data loss for all other opened documents.

[Development Fix]
The fix has been developed by Rene Engelhard at Debian, which is also affected by this.

[Stable Fix]
The fix has been reviewed and cherry-picked to the ubuntu-precise-3.5 branch by Bjoern Michaelsen.

[Test Case]
see description: Open test document.

[Regression Potential]
This is fixing a regression against oneiric.

Addition to impact: This Is more severe as in the default install -base-core is installed, but -base is not.

Changed in libreoffice (Debian):
status: Unknown → Fix Released

Hello Franck, or anyone else affected,

Accepted libreoffice into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libreoffice (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Franck (alci) wrote :

Hi,

just adding proposed and upgrading the packages didn't do the trick.

So here are my questions:
- should I install libreoffice package ? (it is not currently installed here, I seem to only have libreoffice-writer)
- what version of the package should I get ?

Franck (alci) wrote :

Installing libreoffice package does the trick, but it will install libreoffice-base...
Removing libreoffice and libreoffice-base, it breaks again.

So, what should I install at least that is supposed to work ?

The fixed packages haven't built yet, so you can't upgrade to a
-proposed version yet. This will still take a few hours.

for the progress, see https://launchpad.net/ubuntu/+source/libreoffice/1:3.5.2-2ubuntu3 in the section titled "builds"

Also triggered by File->New->Labels.

Changed in libreoffice (Ubuntu Quantal):
status: Fix Committed → In Progress
Mozaic (mozaic) wrote :

Open in 3.5.2-2ubuntu3 proposed ans it's work.

Gerv (gerv-launchpad) wrote :

This problem also occurs with a very simple spreadsheet (available on request) which just has numbers, dates, currencies and a few simple formulae. So it's not just text documents with form controls.

Installing libreoffice-base (which pulls in a load of Java) fixes it.

Gerv

tags: added: verification-done
removed: verification-needed

Hello Franck, or anyone else affected,

Accepted libreoffice into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Mozaic (mozaic) wrote :

I can open the file test with LibreOffice 3.5.3.2 Version ID : 350m1(Build:2) [3.5.3-0Ubuntu1] and i have no error message \o/
I test the files in duplicated Bug, no message too.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (7.3 KiB)

This bug was fixed in the package libreoffice - 1:3.5.3-0ubuntu1

---------------
libreoffice (1:3.5.3-0ubuntu1) precise-proposed; urgency=low

  * bump version to final, use debian tarballs

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa2) precise; urgency=low

  * reduce l10n set for ppa builds

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa1) precise; urgency=low

  * cherry-pick 496346c9e692b7ba8ec0aa78c78cac7b71d830a5 from
    debian (LP: #986205)
    - guard libdbalo.so mv with feq PACKAGE_BASE=y...
  * upstream bugfix release 3.5.3:
    - fix colorspace conversion for greyscale bitmaps fdo#34324 [Michael Meeks]
    - cache calls to mdds:mixed_type_matrix::size, related fdo#47299 [Markus Mohrhard]
    - clrContourCache for SwAnchoredDrawObjects fdo#45376 [Andreas Schierl]
    - copy column privileges into table privileges fdo#47937 [Lionel Elie Mamane]
    - cppcanvas: processEMFPlus: fix valgrind warning: fdo#42252 [Michael Stahl]
    - disable cairo canvas on Windows fdo#46532, fdo#46901, fdo#45584 [Michael Meeks]
    - do not increase height of checkboxes fdo#47963 [David Tardon]
    - do not play sound in presenter console fdo#33914 [David Tardon]
    - docx, no mso-fit-shape-to-text means the textbox size is fixed bnc#751573 [Cédric Bosdonnat]
    - export all style information to xls/xlsx, fdo#46738 [Markus Mohrhard]
    - fdo43752: PPTX import fix affected odp imports. bnc#719989, bnc#719997 [Muthu Subramanian]
    - find install location during help pack install fdo#48411 [Andras Timar]
    - fix - edge-case trans gradients came out empty fdo#33591 [Thorsten Behrens]
    - fix - use older ODF encryption by default fdo#47484 [Thorsten Behrens]
    - fix RTF import of \page in inner groups fdo#48104 [Miklos Vajna]
    - fix RTF import of all capitals char prop fdo#46955 [Miklos Vajna]
    - fix RTF import of character encoding in footnotes fdo#45182 [Miklos Vajna]
    - fix RTF import of custom fonts in substreams fdo#45394 [Miklos Vajna]
    - fix RTF import of mixed super/nonsuper text fdo#47326 [Miklos Vajna]
    - fix RTF import of multi-paragraph exact height textboxes fdo#47036 [Miklos Vajna]
    - fix RTF import of shapes inside text frames at the start of the doc fdo#47036 [Miklos Vajna]
    - fix RTF import of tables with empty first row fdo#45394 [Miklos Vajna]
    - fix RTL menu rendering on Windows fdo#42537 [Ivan Timofeev]
    - fix border printing: fdo#38635 [Michael Stahl]
    - fix crash on RTF import of shapes inside tables fdo#47802 [Miklos Vajna]
    - fix the fix so it doesn't crash lp#905355, fdo#43895 [Michael Stahl]
    - fix vcl alpha blending bnc#714787 [Thorsten Behrens]
    - fix vertical align when switching mode in multibar fdo#44140 [Noel Power]
    - fixed pdf export (of images). bnc#717947 [Muthu Subramanian]
    - handle various busted rtf docs without hanging fdo#48640 [Caolán McNamara]
    - improved label/BC wizard - set paper size fdo#44516 [Winfried Donkers]
    - increase nCol before next iteratation to prevent loop, fdo#46220 [Markus Mohrhard]
    - macros: Macro to set filter in Calc does not work with .StringValue fdo#46983 [Takeshi Abe]
    - make "Replace All" work with REs fdo#44861 [David Tardon]
    - ...

Read more...

Changed in libreoffice (Ubuntu Quantal):
status: In Progress → Fix Released
Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.