[Upstream] LibreOffice clears clipboard contents on exit

Bug #983449 reported by TenLeftFingers on 2012-04-16
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Medium

Bug Description

1) lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

1) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.3-0ubuntu1
  Candidate: 1:3.5.3-0ubuntu1
  Version table:
 *** 1:3.5.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

apt-cache policy gedit
gedit:
  Installed: 3.4.1-0ubuntu1
  Candidate: 3.4.1-0ubuntu1
  Version table:
 *** 3.4.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in a blank Writer document is type hello, copy, close Writer, and attempt to paste in gedit and it does. However, one may perform the same action in reverse successfully.

WORKAROUND: Copy and paste before closing LibreOffice.

WORKAROUND: https://wiki.ubuntu.com/ClipboardPersistence#Workaround:_Clipboard_Managers

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
NonfreeKernelModules: wl
ApportVersion: 2.0.1-0ubuntu1
Architecture: i386
Date: Mon Apr 16 21:18:14 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120328)
ProcEnviron:
 LANGUAGE=en_IE:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_IE.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Problem description: After copying some text, the application was exited by the user before opening another application to paste to. The content was no longer in the clipboard after closing lowriter.

Steps to reproduce:
1. Select and copy some text in LibreOffice Writer.
2. Close Writer as well as any other instances of LO.
3. Open any text editor and try to paste the content.

Expected Outcome: The text should paste and become visible.
Actual Outcome: Nothing happens & the "Paste" option in the menu may show the applications default appearance for no content, if any.

Platform (if different from the browser):
Ubuntu 12.04

Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0

Changed in libreoffice (Ubuntu):
status: New → Confirmed
TenLeftFingers (tenleftfingers) wrote :

Confirming given that I am reporting this on someones behalf and I could reproduce the issue exactly.

TenLeftFingers (tenleftfingers) wrote :

Note: the above information is incorrect:
Package: libreoffice (not installed) - Actualy, it *is* installed and running.

bj (bjforesthowell) wrote :

I can attest to this, because I just (not ten minutes ago) lost a paper. I cut the text out of the document, closed it, and tried to paste it into another open document and it was gone. Where is the libreoffice clipboard at?

Jarlath, thank you for reporting this and helping make Ubuntu better. While the phenomenon is reproducible, and certainly irritating, I do not know if this is a regression (did not happen in prior release), or a Wishlist. Do you know if what you desire occurred in a prior LO/OOo release?

description: updated
summary: - LibreOffice clears clipboard contents on exit
+ [Upstream] LibreOffice clears clipboard contents on exit
Changed in libreoffice (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Download full text (3.7 KiB)

Hi Christopher,

I can't say if this was different in a prior version so no, I don't know
what version if Amy this was possible in.

I know it affects windows version too.

Jarlath
On Jun 19, 2012 5:41 PM, "Christopher M. Penalver" <
<email address hidden>> wrote:

> Jarlath, thank you for reporting this and helping make Ubuntu better.
> While the phenomenon is reproducible, and certainly irritating, I do not
> know if this is a regression (did not happen in prior release), or a
> Wishlist. Do you know if what you desire occurred in a prior LO/OOo
> release?
>
> ** Description changed:
>
> - When LibreOffice is running, I can copy text and paste it to another
> - application, eg gEdit.
> + 1) lsb_release -rd
> + Description: Ubuntu 12.04 LTS
> + Release: 12.04
>
> - Problem Case:
> - 1) Select and copy some text in LibreOffice Writer
> - 2) Close LibreOffice (and any other instances that may be running)
> - 3) launch Text Editor and try to paste.
> + 1) apt-cache policy libreoffice-writer
> + libreoffice-writer:
> + Installed: 1:3.5.3-0ubuntu1
> + Candidate: 1:3.5.3-0ubuntu1
> + Version table:
> + *** 1:3.5.3-0ubuntu1 0
> + 500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main
> i386 Packages
> + 100 /var/lib/dpkg/status
> + 1:3.5.2-2ubuntu1 0
> + 500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386
> Packages
>
> - Expected outcome: The copied text should appear in Text Editor.
> - Actual outcome: The 'Paste' option is greyed out in the menu and it is
> not possible to paste. My data is lost.
> + apt-cache policy gedit
> + gedit:
> + Installed: 3.4.1-0ubuntu1
> + Candidate: 3.4.1-0ubuntu1
> + Version table:
> + *** 3.4.1-0ubuntu1 0
> + 500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386
> Packages
> + 100 /var/lib/dpkg/status
>
> - This might be best reported upstream but I'm not sure if the clipboard
> - 'system' in Ubuntu is to blame or not. Here is the upstream report I've
> - made.
> + 3) What is expected to happen in a blank Writer document is type hello,
> + copy, close Writer, and attempt to paste in gedit and it does. However,
> + one may perform the same action in reverse successfully.
>
> - Off-topic: I just put 12.04 on my girlfriends laptop and she is very
> - unhappy to have lost 900 words of a critique this way.
> + WORKAROUND: Copy and paste before closing LibreOffice.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: libreoffice (not installed)
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> Uname: Linux 3.2.0-23-generic-pae i686
> NonfreeKernelModules: wl
> ApportVersion: 2.0.1-0ubuntu1
> Architecture: i386
> Date: Mon Apr 16 21:18:14 2012
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386
> (20120328)
> ProcEnviron:
> - LANGUAGE=en_IE:en
> - TERM=xterm
> - PATH=(custom, no user)
> - LANG=en_IE.UTF-8
> - SHELL=/bin/bash
> + LANGUAGE=en_IE:en
> + TERM=xterm
> + PATH=(custom, no user)
> + LANG=en_IE.UTF-8
> + SHELL=/bin/bash
> SourcePackage: libreoffice
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> ** Summary changed:
>
> - LibreOffice clears cli...

Read more...

Jarlath, ok. I'll mark Triaged for now.

Changed in libreoffice (Ubuntu):
status: Incomplete → Triaged
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → New

Hello Jarlath, *,
I can confirm your observation with LO Version 3.6.2.2 (Build ID: da8c1e6) under Debian Testing x86 (but seem to remember to have this same behaviour observed on my PC with Debian Testing AMD64), but I am not sure, if it is a bug from LO and/or from the clipboard. I seem to remember, that it happened to me, when copying from other applications to the clipboard (say from firefox to konsole) in the past as well. So maybe it works "as expected" (by the developers, it means ... ;) ).

Just out of interest: Are you using the default WM/DE GNOME? And have you tested it with another one (like XFCE, KDE or the like)?
HTH
Thomas.

Hi Thomas,

Thanks for your reply. I can currently reproduce this on the Ubuntu
12.04 Unity desktop which I believe uses Gnome as it's backend. I
haven't tried this on any other linux environments. I did try the same
experiment with (copying from and closing) Firefox and (pasting to)
Gedit, it worked correctly in this case.

However on MacOS 10.8 (Mountain Lion) this issue is not reproducible.
The clipboard contents are preserved on exit.

By the way, were you using KDE to reproduce this?

On 09/29/2012 11:45 PM, <email address hidden> wrote:
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=48783#c1>
> on bug 48783 <https://bugs.freedesktop.org/show_bug.cgi?id=48783> from
> <email address hidden> <mailto:<email address hidden>> *
> Hello Jarlath, *,
> I can confirm your observation with LO Version 3.6.2.2 (Build ID: da8c1e6)
> under Debian Testing x86 (but seem to remember to have this same behaviour
> observed on my PC with Debian Testing AMD64), but I am not sure, if it is a bug
> from LO and/or from the clipboard. I seem to remember, that it happened to me,
> when copying from other applications to the clipboard (say from firefox to
> konsole) in the past as well. So maybe it works "as expected" (by the
> developers, it means ... ;) ).
>
> Just out of interest: Are you using the default WM/DE GNOME? And have you
> tested it with another one (like XFCE, KDE or the like)?
> HTH
> Thomas.
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
> * You reported the bug.
>

0gb.us (0gb-us) wrote :

I just lost a paper due to this bug as well. Why on Earth would the clipboard be cleard when you close the application?

Bjoern - your wiki link fails for me.

The X clipboard system relies on the app owning the selection to provide the data; if you close the app - that app isn't there; so it will fail.

There are various (varyingly expensive) hacks around this out there in various desktops; that try to serialise the clipboard at various points - I guess this could be done before exit.

Problems abound: eg. select 2^36 cells in a sheet, hit copy, exit LibreOffice - what happens ? ;-> but - that's always the way with big sheets I guess.

Are you certain this is an unexpected bug ? :-)

ups, copy paste fumble:
https://wiki.ubuntu.com/ClipboardPersistence

As for unexpectedness:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/983449/comments/8
so yes, I think this is expected -- esp. since more and more other apps are using the workaroud, we start to stick out. From a UX perspective it is likey better to have all apps use one of the workarounds -- or none.

description: updated
Changed in df-libreoffice:
status: New → Incomplete

Hi!

I'd like to fix this bug but could someone point to me which package to work on? Atleast hint me on how to search for that package name.

Thanking you

Regards
Shashank

libreoffice -- after all thats the source package this is filed against ;)

Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here:
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

I'm not sure why the NEEDINFO status is set, I have answered any questions asked. Unless you want me to write the patch :)

Please let me know what I can provide. Thanks & regards.

On 24 Sep 2013, at 02:59, <email address hidden> wrote:

>
> Comment # 6 on bug 48783 from QA Administrators
> Dear Bug Submitter,
>
> This bug has been in NEEDINFO status with no change for at least 6 months.
> Please provide the requested information as soon as possible and mark the bug
> as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in
> NEEDINFO status with no change in 30 days the QA team will close the bug as
> INVALID due to lack of needed information.
>
> For more information about our NEEDINFO policy please read the wiki located
> here:
> https://wiki.documentfoundation.org/QA/FDO/NEEDINFO
>
> If you have already provided the requested information, please mark the bug as
> UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.
>
>
> Thank you for helping us make LibreOffice even better for everyone!
>
>
> Warm Regards,
> QA Team
>
> You are receiving this mail because:
> You reported the bug.

Marking back to NEW unless there is a non-robo discussion/discourse to address.

Changed in df-libreoffice:
status: Incomplete → Confirmed
Adolfo Jayme (fitojb) on 2015-04-24
no longer affects: libreoffice (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.