LibreOffice Productivity Suite

[Upstream] .odt table shifts left saving to .docx

Reported by full name on 2011-10-25
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
Invalid
High
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.4.3-3ubuntu2
  Candidate: 1:3.4.3-3ubuntu2
  Version table:
 *** 1:3.4.3-3ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget -c https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/881485/+attachment/2572054/+files/17_Mike_DefendantsCROSS_TerryGlenn.odt -O example.odt && lowriter --nologo example.odt

Save as Microsoft Word 2007/2010 XML (.docx) close and open example.docx and it looks the same.

4) What happens instead is the table is shifted to the left.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libreoffice-core 1:3.3.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Oct 25 08:25:35 2011
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Created attachment 42876
MS Word docx with a wide table

I have a Word docx created with MS Office 2007, landscape, legal paper size.

I'm using latest version of LO. When I open the file with either Libre
Office or Open Office the table columns lose all width information.

I'm using Ubuntu 10.10, 64-bit.

To me this is a show-stopper from getting folks to use LO. It is also a surprise because I have had great results with OO in the past.

I have attached the docx file and the pdf generated from it with MS Word.

Created attachment 42877
Pdf file produced by MS Word so the original table column widths can be seen

one for cedric?

(In reply to comment #2)
> one for cedric?

Lubos, can you handle this one? I have my plate of bugs ATM :)

Only import seems to be broken, it reads NS_ooxml::LN_CT_TblGridBase_gridCol but doesn't seem to use it.

Lubos, any progress? This is still not solved in the current version of LibreOffice. Try making some tables in Office 2010, save as .doc or .docx. Export to PDF. Now open the file in OpenOffice/LibreOffice. Export to PDF. Tables are fucked. Lines look bad and height of rows is not preserved.

This is really pretty severe. LibreOffice should work with tables produced by other word processors.

can confirm with Win7-64

sorry, forgot to mention:
LibreOffice 3.3.2
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2

check with Vista 32 and Beta 4 still shows the same behaviour
LO 3.4.0
DEV300m103 (Build:4)

same behaviour with DEV300m103 (Build:5) and Win7-64

full name (rjp2) wrote :
full name (rjp2) wrote :

The problem is still present when saving with Libre Office docx format.

The problem goes away if I change the table width to "relative" (a percentage of page width) instead of using absolute values (which seem to be the default).

full name (rjp2) wrote :

Even when column width is set to 100% the problem returns, and the table selection
automatically goes back to normal (not relative.) 99% seems to work fine though and
the setting persists as expected.

In the problem documents, the tables also sometimes left align themselves outside the specified margin.
When I manually move that left line to inside the margin, save and reload, the problem returns again
(column width "set relative" is automatically unchecked, and the width become huge sending the table
off the right side of the page.

full name, thank you for reporting this and helping make Ubuntu better. Could you please attach a odt file, that when saved in docx, demonstrates this problem?

Changed in libreoffice (Ubuntu):
status: New → Incomplete
full name (rjp2) wrote :

This attached document seems to work fine in odt format, but when saved to docx, several things seem to happen:
  - column width is no longer relative, but static numbers
  - the column width numbers are very large (like 13" plus) which causes the table to go off the right of the page.

When you open in docx format, you can fix them in the document, but when you save again, this get screwy again.

Something seems to be wrong with how column widths are saved/stored in the docx format.

full name, the issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

description: updated
summary: - Column Table Widths don't persist
+ .odt table shifts left saving to .docx
tags: added: lo33
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in df-libreoffice:
status: New → Incomplete
Alan Pater (alan-pater) wrote :
Changed in df-libreoffice:
importance: Undecided → Unknown
status: Incomplete → Unknown
summary: - .odt table shifts left saving to .docx
+ [Upstream] .odt table shifts left saving to .docx
Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → Confirmed

Created attachment 57442
PHPWord generated document

PHPWord generated document containing multiple tables. When this file is opened in Word / Google Docs the column widths are set but in Libreoffice the widths are ignored.

This is still true in Libreoffice 3.5.0 on Mac OS X 10.6.8.

The test doc appears to be working for me now in Ubuntu 12.04 with LibreOffice 3.5.0 Build ID: 350m1(Build:13).

Tested on Ubuntu 12.04 with Libreoffice 3.6.1.2 (Build ID: e29a214)

Table width is rendered correctly with this version.

But the font is "Time 11.1" in the PDF, it is converted to "Times New Roman 12" in writer. So the text is to long for a few cell, and go to next line.
If I force all text to 11.1, the document matches exactly the PDF.

Still reproducible in:
lsb_release -rd
Description: Ubuntu 12.10
Release: 12.10

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.6.2~rc2-0ubuntu3
  Candidate: 1:3.6.2~rc2-0ubuntu3
  Version table:
 *** 1:3.6.2~rc2-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main i386 Packages
        100 /var/lib/dpkg/status

I am witnessing this same problem in 4.0.2.2 on Windows XP and 3.6x on LinuxMint 14

Checked with:
Version: 4.2.0.0.alpha0+
Build ID: 087a610fcd5c0c354a9ed6bfccd3451b667d62a3
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-08-04_21:41:24
Windows 8.1 Enterprise Preview 64 bit

Table looks the same in LibreOffice as in Word 2013.

WORKSFORME on OS X 10.8.4, LO 4.1.1.1 and Ubuntu 13.04 LO 4.1.0.3.

Please re-open if you disagree.

Changed in df-libreoffice:
status: Confirmed → Invalid

closing as per comment #25.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.