[Upstream] .odt exported to PDF by Writer with Courier 10 Pitch PDF/A-1a embedded font show dots in Adobe Reader

Bug #758676 reported by Alvin on 2011-04-12
82
This bug affects 16 people
Affects Status Importance Assigned to Milestone
LibreOffice
Incomplete
High
libreoffice (Debian)
Fix Released
Unknown
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libreoffice

1) lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu2
  Candidate: 1:3.3.2-1ubuntu2
  Version table:
 *** 1:3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0maverick1
  Candidate: 9.4.2-0maverick1
  Version table:
 *** 9.4.2-0maverick1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy evince
evince:
  Installed: 2.32.0-0ubuntu12
  Candidate: 2.32.0-0ubuntu12
  Version table:
 *** 2.32.0-0ubuntu12 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:3.3.2-1ubuntu2
  Candidate: 1:3.3.2-1ubuntu2
  Version table:
 *** 1:3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy libreoffice-pdfimport
libreoffice-pdfimport:
  Installed: 1.0.3+LibO3.3.2-1ubuntu2
  Candidate: 1.0.3+LibO3.3.2-1ubuntu2
  Version table:
     1.0.3+LibO3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages

3) What is expected to happen is when one performs at the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/758676/+attachment/2030473/+files/courier10pitch.odt && lowriter -nologo courier10pitch.odt

Notice the words:

This line is Courier 10 Pitch.

has font Courier 10 Pitch.

Click File -> Export as PDF... -> check the PDF/A-1a checkbox -> Export button -> Name: courier10pitch -> click Save button

Open via the Terminal:

acroread courier10pitch.pdf

and it should display correctly.

4) What happens instead is an Adobe Reader window pops up noting: "Cannot extract the embedded font 'Courier10PitchBT-Roman'. Some characters may not display or print correctly."

In place of the words are dots.

This pdf displays correctly opening with evince and via importing into LibreOffice Draw.

Unconfirmed Reporter Comments: Okular and xpdf display the file correctly.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libreoffice-writer 1:3.3.2-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Apr 12 13:19:10 2011
ProcEnviron:
 LANGUAGE=
 LANG=C
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Created attachment 44590
PDF from LibO that fails in Adobe Reader

I use LibreOffice on Debian Testing AMD64 to generate a PDF (attached).

My document uses the font Bitstream Charter, which is part of the base Debian system. I believe that it comes from X.Org, specifically the package xfonts-scalable.

Opening this PDF in Adobe Reader for Windows 9.4 or 10.0 produces an error message that the embedded font cannot be extracted, and all characters are replaced by dots.

The PDF works fine in the non-Adobe programs I've tried.

Choosing a different font avoids the problem.

It would be really great if LibreOffice can check for this problem, and maybe even apply a work-around. Or at least show a warning when the PDF is generated.

FTR, we also had this reported in bugs.debian.org/616117

Confirmed on openSUSE 11.4 with both LibreOffice 3.3.1 and 3.3.2.

also a problem on i686 builds too

Same issue confirmed on openSUSE 11.4 32-bit with OpenOffice 3.3.0.

Alvin (alvind) wrote :
Alvin (alvind) wrote :

Attaching example PDF.

Alvin (alvind) on 2011-04-12
description: updated

Alvin, thank you for reporting this bug and helping make Ubuntu better. Could you please attach the Writer file that when exported to PDF demonstrates this problem?

Changed in libreoffice (Ubuntu):
status: New → Incomplete

Alvin, this is confirmed in Adobe Reader via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/758676/+attachment/2023721/+files/courier10pitch.pdf && acroread courier10pitch.pdf

Adobe Reader window pops up noting: "Cannot extract the embedded font 'Courier10PitchBT-Roman'. Some characters may not display or print correctly."

The font is just a bunch of white dots.

However, open in Evince, instead of white dots one sees: "This line is Courier 10 Pitch."

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0maverick1
  Candidate: 9.4.2-0maverick1
  Version table:
 *** 9.4.2-0maverick1 0
        500 http://archive.canonical.com/ubuntu/ maverick/partner i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy evince
evince:
  Installed: 2.32.0-0ubuntu1.1
  Candidate: 2.32.0-0ubuntu1.1
  Version table:
 *** 2.32.0-0ubuntu1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ maverick-security/main i386 Packages
        100 /var/lib/dpkg/status
     2.32.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

Changed in acroread (Ubuntu):
status: New → Confirmed

Opened the PDF with LibreOffice Draw via the Terminal:

lodraw -nologo courier10pitch.pdf

The characters show correctly: "This line is Courier 10 Pitch."

apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:3.3.2-1ubuntu2~maverick1
  Candidate: 1:3.3.2-1ubuntu2~maverick1
  Version table:
 *** 1:3.3.2-1ubuntu2~maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

Sb (sb56637) wrote :

This is a confirmed upstream bug:
https://bugs.freedesktop.org/show_bug.cgi?id=35431

Also the same behavior on OpenOffice 3.3.0

Alvin (alvind) wrote :

Probably not needed anymore due to confirmation, but here is an .odt file with Courier 10 Pitch.

Alvin, while I was able to reproduce the error message in Adobe Reader exporting the attached courtier10pitch.odt file to PDF using LibreOffice Writer (please see attached screenshot.png), I was unable to reproduce the dots where the letters were as per your courier10pitch.pdf attachment displays.

Could you please provide detailed, step-by-step instructions on exactly how to create the PDF document so the dots show?

Procedure to reproduce the error message but not the dots:

Ubuntu 11.04 LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/758676/+attachment/2030473/+files/courier10pitch.odt && lowriter -nologo courier10pitch.odt

Notice the words:

This line is Courier 10 Pitch.

has font Courier 10 Pitch.

Click File -> Export as PDF... -> Name: courier10pitch2 -> click Save button

Open via the Terminal:

acroread courier10pitch2.pdf

Adobe Reader window pops up noting: "Cannot extract the embedded font 'Courier10PitchBT-Roman'. Some characters may not display or print correctly."

Despite this one may see the fonts fine. This pdf opens in evince fine and importing via Draw works fine as well.

lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu2
  Candidate: 1:3.3.2-1ubuntu2
  Version table:
 *** 1:3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0maverick1
  Candidate: 9.4.2-0maverick1
  Version table:
 *** 9.4.2-0maverick1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy evince
evince:
  Installed: 2.32.0-0ubuntu12
  Candidate: 2.32.0-0ubuntu12
  Version table:
 *** 2.32.0-0ubuntu12 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:3.3.2-1ubuntu2
  Candidate: 1:3.3.2-1ubuntu2
  Version table:
 *** 1:3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy libreoffice-pdfimport
libreoffice-pdfimport:
  Installed: 1.0.3+LibO3.3.2-1ubuntu2
  Candidate: 1.0.3+LibO3.3.2-1ubuntu2
  Version table:
     1.0.3+LibO3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages

Alvin (alvind) wrote :

Don't worry. Your PDF shows only dots when viewed with Adobe Reader 10.0.1 on Windows. My Natty machine is on a remote site and the kernel has panicked, so I can't reach it. I'll test tomorrow.

The difference between both PDF files is that I exported it with the PDF/A-1a option.

Alvin, confirmed using Ubuntu 11.04, LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/758676/+attachment/2030473/+files/courier10pitch.odt && lowriter -nologo courier10pitch.odt

Notice the words:

This line is Courier 10 Pitch.

has font Courier 10 Pitch.

Click File -> Export as PDF... -> check the PDF/A-1a checkbox -> Export button -> Name: courier10pitch -> click Save button

Open via the Terminal:

acroread courier10pitch.pdf

Adobe Reader window pops up noting: "Cannot extract the embedded font 'Courier10PitchBT-Roman'. Some characters may not display or print correctly."

In place of the words are dots. Both opening in evince and importing via Draw show the words.

lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu2
  Candidate: 1:3.3.2-1ubuntu2
  Version table:
 *** 1:3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0maverick1
  Candidate: 9.4.2-0maverick1
  Version table:
 *** 9.4.2-0maverick1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy evince
evince:
  Installed: 2.32.0-0ubuntu12
  Candidate: 2.32.0-0ubuntu12
  Version table:
 *** 2.32.0-0ubuntu12 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:3.3.2-1ubuntu2
  Candidate: 1:3.3.2-1ubuntu2
  Version table:
 *** 1:3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy libreoffice-pdfimport
libreoffice-pdfimport:
  Installed: 1.0.3+LibO3.3.2-1ubuntu2
  Candidate: 1.0.3+LibO3.3.2-1ubuntu2
  Version table:
     1.0.3+LibO3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages

Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed
description: updated
description: updated
summary: - Text in exported PDF files is not displayed correctly with
- Courier10PitchBT-Roman
+ .odt file with Courier 10 Pitch font exported to PDF by Writer shows
+ characters as dots in Adobe Reader

Alvin, since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

Created attachment 45587
courier10pitch.odt

Downstream bug may be found at:
https://bugs.launchpad.net/df-libreoffice/+bug/758676

1) lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu2
  Candidate: 1:3.3.2-1ubuntu2
  Version table:
 *** 1:3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0maverick1
  Candidate: 9.4.2-0maverick1
  Version table:
 *** 9.4.2-0maverick1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen is when one performs at the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/758676/+attachment/2030473/+files/courier10pitch.odt && lowriter -nologo courier10pitch.odt

Notice the words:

This line is Courier 10 Pitch.

has font Courier 10 Pitch.

Click File -> Export as PDF... -> check the PDF/A-1a checkbox -> Export button -> Name: courier10pitch -> click Save button

Open via the Terminal:

acroread courier10pitch.pdf

and it should display correctly.

4) What happens instead is an Adobe Reader window pops up noting: "Cannot extract the embedded font 'Courier10PitchBT-Roman'. Some characters may not display or print correctly."

In place of the words are dots.

Changed in libreoffice (Debian):
status: Unknown → Confirmed
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

I have back-traced this bug - it first appears in OpenOffice 3.3.0.

It was not present in the Ubuntu packaged OpenOffice 3.2.0.

To test this I installed a virtual machine with Ubuntu 10.04; created a test pdf with the font Bitstream Charter using OO3.2.0. I was able to view it without any problems on WinXP - Adobe 10.0.1

I uninstalled the OO3.2.0

I then installed the LibreOffice 3.3.0 deb package (http://download.documentfoundation.org/libreoffice/old/stable/3.3.0/deb/x86/LibO_3.3.0_Linux_x86_install-deb_en-US.tar.gz) and tried it, the bug was present (dots when viewed on Win XP - Adobe 10.0.1)

I then installed OpenOffice 3.3.0 deb package (http://download.services.openoffice.org/files/stable/3.3.0/OOo_3.3.0_Linux_x86_install-deb_en-US.tar.gz) and the bug was still present.

So maybe a diff between OO 3.3.0 and OO 3.2.0 might lead us in the right direction.

This bug may have been caused by the patch to open office bug 87968:
http://openoffice.org/bugzilla/show_bug.cgi?id=87968

This was the only bug in the 3.3 updates that seemed to deal with pdfs (http://www.openoffice.org/dev_docs/features/3.3/index.html)

Hi guys, can we please mark this bug as confirmed? It is a very dangerous bug. It has resulted in me sending critical PDFs to end users, only to receive emails that they couldn't read the file. It would be very easy to miss deadlines or create a flood of emails from frustrated users when they receive an incompatible PDF file. I personally don't use Adobe Reader very often, but almost 100% of the rest of the world does.

Thanks!

Changed in df-libreoffice:
importance: Medium → High
summary: - .odt file with Courier 10 Pitch font exported to PDF by Writer shows
- characters as dots in Adobe Reader
+ .odt exported to PDF by Writer with Courier 10 Pitch PDF/A-1a embedded
+ font show dots in Adobe Reader

This is definitely a problem. This doesn't just affect PDFs opened by Acrobat Reader, it also occurs on a book file that I uploaded to a printer's system (Lightning Source). The error they see is a corrupted embedded font file.

Looks fixed in LO Beta 3.4.0 beta 5. Marking Resolved Fixed.

LibreOffice 3.4.0 DEV300m103(Build:5)

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0maverick1
  Candidate: 9.4.2-0maverick1
  Version table:
 *** 9.4.2-0maverick1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status

Changed in df-libreoffice:
status: Confirmed → Fix Released

Confirmed fixed with 3.4.0 (official LibO RPMs) installed on openSUSE 11.4. Works with Bistream Charter fonts in a PDF exported by LibO and viewed on Adobe Reader for Linux.

Thanks so much!!

Here's a workaround to "repair" your PDF file before making it available to Windows users, without having to use LibreOffice 3.4:

sudo apt-get install ghostscript
ps2pdf file.pdf
mv file.pdf.pdf file.pdf

summary: - .odt exported to PDF by Writer with Courier 10 Pitch PDF/A-1a embedded
- font show dots in Adobe Reader
+ [Upstream] .odt exported to PDF by Writer with Courier 10 Pitch PDF/A-1a
+ embedded font show dots in Adobe Reader
Ric Flomag (ricflomag) wrote :

Fixed in LO 3.4.

Any chance to backport the patch to natty ?

Changed in libreoffice (Debian):
status: Confirmed → Fix Released
Changed in openoffice.org (Ubuntu):
status: New → Confirmed

*** Bug 33703 has been marked as a duplicate of this bug. ***

Also confirmed fixed with Nimbus Roman N°9L and LibO 3.4.2. Congratulations to Luboš! \o/

Alvin, I am closing the bug task for LibreOffice as it has been fixed in the latest development version of Ubuntu - Oneiric Ocelot.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

lsb_release -rd
 Description: Ubuntu oneiric (development branch)
 Release: 11.10

 apt-cache policy libreoffice-writer
 libreoffice-writer:
 Installed: 1:3.4.2-2ubuntu2
 Candidate: 1:3.4.2-2ubuntu2
 Version table:
 *** 1:3.4.2-2ubuntu2 0
 500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
 100 /var/lib/dpkg/status

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
Changed in acroread (Ubuntu):
status: Confirmed → Invalid

Inital test .odt exported w/ PDF/A still exhibits the original issue. I'll attach a PDF output.

LibreOffice 3.3.4
OOO330m19 (Build:401)
tag libreoffice-3.3.4.1
$ cat /opt/libreoffice/program/versionrc
[Version]
AllLanguages=en-US
buildid=330m19(Build:401)
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.3
ProductBuildid=401
ProductMajor=330
ProductMinor=19
ProductSource=OOO330
UpdateID=LibreOffice_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})

(linux - 32bit)

Steps to reproduce;

Opened courier10pitch.odt
Exported as PDF/A-1a
Opened the resulting PDF in Adobe Reader 9.4.2

Result: Cannot extract the embedded font 'Courier10PitchBT-Roman'. Some characters may not display or print correctly.

Dots are shown instead of characters.

I believe this bug is related to:
https://bugs.freedesktop.org/show_bug.cgi?id=38347
[Exported PDF/A files cannot be opened in acroreader]

Created attachment 50929
Resulting pdf from courier10pitch_334.pdf w/334

Changed in df-libreoffice:
status: Fix Released → Confirmed
Changed in openoffice.org (Ubuntu):
status: Confirmed → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

I'm having the exact same problem in LibO_3.4.3_Win_x86_install_multi.exe

This is a major problem... when/where is the fix?!

Hi guys,

Up until about a month ago, I had this exact same problem. I created a document in LibreOffice, and exported it as a pdf. The pdf would display fine on my Ubuntu machine, and also on an Apple. However, when sent to a Windows machine, it reported the same bug (see screengrab attached).

This was a huge hassle for me, as I had been sending my CV to various employers in pdf format (as this can look relatively impressive) only to be very embarassed when they contacted me back saying that they couldn't read it, but only got a series of dots.

Awesome work guys,

Ryan.

I cannot reproduce any problem on Linux with LibreOffice 3.4.4 and Acroread 9.4.6. Even 3.4.3 should have the fix, 3.3.x is too old though. Please check your version again, and you need to provide more details to reproduce the problem if it still persists for you.

Changed in df-libreoffice:
status: Confirmed → Incomplete
no longer affects: acroread (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.