Window has no close/minimize/unmaximize buttons when it opens maximized

Bug #750186 reported by Matthew Paul Thomas
226
This bug affects 42 people
Affects Status Importance Assigned to Milestone
LibreOffice
New
Undecided
Unassigned
Unity
Fix Released
High
Unassigned
unity-2d
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Fix Released
High
Unassigned

Bug Description

unity 3.8.2-0ubuntu1, Ubuntu Natty daily live 20110404

1. Open a window that opens maximized by default. For example, choose one of the results at <http://www.google.com/search?q=filetype%3Aodp> and choose "Open with LibreOffice Impress".
2. Try to close, minimize, or unmaximize the window.
3. Focus another window.
4. Return focus to the maximized window.

What happens:
2. The window has no close, minimize, or unmaximize buttons.
4. The missing buttons return.

What should happen:
2. The window has close, minimize, and unmaximize buttons.

(Other situations where the close, minimize, and unmaximize buttons go AWOL include bug 741603 and bug 741143.)

Tags: sniffles
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Florian Boucault (fboucault) wrote :

Does not affect Unity 2D.

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

I believe this is the bug that left a couple of people unable to close a window in the user test.

Revision history for this message
Deejay_TNT (idaho) wrote :

Same issue, just posted a comment in a duplicate bug (I think it is - 703278).

Revision history for this message
Deejay_TNT (idaho) wrote :

Just to note:
unity 3.8.10
Compiz 0.9.4.0

Revision history for this message
Jonathan Meek (shroudedcloud) wrote :

This is fixed in my up-to-date Natty install.

Revision history for this message
Moneta Funzionata (djmonkey1) wrote :

I am experiencing this issue on Ubuntu 11.10.

Revision history for this message
Simon (nowis74) wrote :

I also have this issue on Oneiric. The only application that does this, at least the only one I noticed, is Libreoffice Impress. When this happens to me, the window also displays the global menu of nautilus (for some reason) and the Impress icon disappear from the launcher.

Revision history for this message
ubuntista (rirag) wrote :

I may confirm this bug in 11.10 with Impress

Revision history for this message
Scott Palmer (skewty) wrote : Re: [Bug 750186] Re: Window has no close/minimize/unmaximize buttons when it opens maximized

My coworker and I both experienced this in Calc yesterday.
On Oct 20, 2011 10:55 PM, "ubuntista" <email address hidden> wrote:

> ** Also affects: df-libreoffice
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/750186
>
> Title:
> Window has no close/minimize/unmaximize buttons when it opens
> maximized
>
> Status in LibreOffice Productivity Suite:
> New
> Status in Unity:
> Confirmed
> Status in “unity” package in Ubuntu:
> Confirmed
>
> Bug description:
> unity 3.8.2-0ubuntu1, Ubuntu Natty daily live 20110404
>
> 1. Open a window that opens maximized by default. For example, choose one
> of the results at <http://www.google.com/search?q=filetype%3Aodp> and
> choose "Open with LibreOffice Impress".
> 2. Try to close, minimize, or unmaximize the window.
> 3. Focus another window.
> 4. Return focus to the maximized window.
>
> What happens:
> 2. The window has no close, minimize, or unmaximize buttons.
> 4. The missing buttons return.
>
> What should happen:
> 2. The window has close, minimize, and unmaximize buttons.
>
> (Other situations where the close, minimize, and unmaximize buttons go
> AWOL include bug 741603 and bug 741143.)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/df-libreoffice/+bug/750186/+subscriptions
>

Revision history for this message
benjou (benoit-kornmann) wrote :

Same problem on both my computer and my girlfriend's. Both clean installs of oneiric from a cd.

I found another program with same behavior: Ario - an MPD client

Revision history for this message
incoob (incoob) wrote :

This problem is very annoyed. Please fix it of provide workaround.
Thanks.

Omer Akram (om26er)
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Revision history for this message
Saurav (sauravzone1) wrote :

Also occurring with other LibreOffice programs on my Oneiric, including Writer, but currently it seems to be occurring only when opening a document by double-clicking in Nautilus. Starting the LibreOffice programs afresh without any document is working correctly and opening a document from the application's menu or toolbar is also working correctly. However, I have not installed lo-menubar. I had installed it earlier and when it was installed, even starting LO programs directly was causing the issue.

Revision history for this message
Saurav (sauravzone1) wrote :

Update to comment #12: after having run all the LibreOffice programs, the problem is always occurring now, including when starting LibreOffice programs directly. This needs urgent attention.

Revision history for this message
hase_olaf (franzi-gilbert) wrote :

the problem occures for me always (no matter how i start lobreoffice) in the writer.
and libreoffice doesn't show up when i change applications (alt-tab).

Revision history for this message
josiasmat (josiasmat) wrote :

For me this issue affects both Unity 2D and 3D, and LibreOffice with and without lo-menubar installed.
Also, the window buttons never appear on the first run of any LibreOffice app, and sometimes this occurs again on later run.

Revision history for this message
josiasmat (josiasmat) wrote :
Revision history for this message
Gerry Boland (gerboland) wrote :

If you Alt+Tab away from LibreOffice, and back again, do the window buttons appear then?

Revision history for this message
Charis Kouzinopoulos (charis) wrote :

Also confirming this bug with all Libreoffice programs using Ubuntu 11.10. I can provide further information if requested.

Revision history for this message
franciscoIR (francisco-ibanez-rioseco) wrote :

this is a very very serious bug, i'm not a coder but i want to help to this bug get fixed

Revision history for this message
Gerry Boland (gerboland) wrote :

Hey,
I'm not able to reproduce this bug. You have "lo-menubar" installed, yes?

To help with our debugging, could you please run the command "dbus-monitor" from a Terminal, and then run through the steps to reproduce this bug.

This command is very verbose, please keep the window-switching to a minimum. Thanks!
-Gerry

Revision history for this message
Gerry Boland (gerboland) wrote :

I believe this bug is related to bug:842566 as all the applications mentioned are LibreOffice apps.

Also I can reproduce it on my machine, using the steps mentioned in the above mentioned bug.

Revision history for this message
Omer Akram (om26er) wrote :

bug 842566 is quite new so that's a duplicate of this one ;-)

Revision history for this message
Saurav (sauravzone1) wrote :

This problem occurs when the font to be used at startup is different from the font that is default in LibreOffice. A different font can occur due to a default template or due to opening a document containing such a font. If the font used by default in LibreOffice is not modified (except in Writer through Tools, Options, LibreOffice Writer, Basic Fonts, which can be changed), the problem does not occur when starting a LibreOffice application afresh without any document.

Revision history for this message
ian (ianjw1) wrote :

- Had this issue (no minimize, max options on top, nor was the file name shown on top of window, LibreOffice Calc, ver 3.4.4 on Ubuntu 11.10, i386) In Calc - Tools - Options - Fonts - select apply replacement table. This did the trick.

Revision history for this message
incoob (incoob) wrote :

Any progress?

Revision history for this message
David Anthony Elston (drowz0r) wrote :

Any progress made would be good. I've confirmed this bug on five (5) different ubuntu 11.10 machines.

Causes quite a bit of trouble for our less experienced users. I'd hate to change to something else for such a small thing :(

Revision history for this message
eden6000 (eden6000) wrote :

I didn't try the font trick...as a workaround (until it's fixed by regular updates) I installed the bamfdaemon debs tham that Marco Trevisan links in his comment #73 in https://bugs.launchpad.net/unity/+bug/842566 and it worked.

Revision history for this message
eden6000 (eden6000) wrote :

tham is a typo...

Revision history for this message
eden6000 (eden6000) wrote :

Actually, I'm not sure wether it's enough to install that bamfdaemon or also the other 2 debs as in comment #68 of the same thread

Revision history for this message
Saurav (sauravzone1) wrote :

The solution given by eden6000 in comment #27 is working properly. Even the global menu installed through lo-menubar works now. Thanks.

Revision history for this message
Omer Akram (om26er) wrote :

I believe this issue is fixed in code (or atleast proposed code). so when the fix for bug 842566 is released this one will also get released.

Revision history for this message
Matteo Pentassuglia (matteox27) wrote :

I haven't this problem in Ubuntu 11.10..
But ther's another problem... The impress icon disappear from the Docky.
I don't know the cause of this problem!

Revision history for this message
Saurav (sauravzone1) wrote :

The update in https://bugs.launchpad.net/unity/+bug/842566 as mentioned by eden6000 in comment #27 resolves this bug. Its corrections ought to be integrated into Oneiric's bamfdaemon so that this bug can be fixed in an ordinary update.

Revision history for this message
Florian Boucault (fboucault) wrote :

@josiasmat: can you please attach a screenshot of the issue happening in Unity 2D? Thank you.

Changed in unity-2d:
status: New → Incomplete
Revision history for this message
Omer Akram (om26er) wrote :

This was a BAMF issue and is fixed in Precise, thanks for the bug report. closing.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-2d:
status: Incomplete → Fix Released
Revision history for this message
Saurav (sauravzone1) wrote :

Updates for Oneiric have also fixed the issue. Thanks.

Revision history for this message
guenter (g21k5) wrote :

I just encountered this problem on 12.04 (precise penguin). Shouldn't this be fixed already? Thank you.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers