Can not save files to NAS cifs - needs nobrl or disable locking

Bug #486443 reported by DaveHowes
100
This bug affects 22 people
Affects Status Importance Assigned to Milestone
LibreOffice
Incomplete
Undecided
Unassigned
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Fix Released
Undecided
Unassigned
Lucid
Invalid
Undecided
Unassigned
openoffice.org (Ubuntu)
Won't Fix
Low
Unassigned
Lucid
Won't Fix
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

Ubuntu Karmic - recent upgrade from Jaunty - also moved from Gnome to KDE

Open Office under KDE can't save files to my Maxtor NAS drive. If I navigate to a file, all the folder names are displayed as numbers rather than letters. If I try to create a new file on the the NAS drive, an empty file is created, and then Open Office displays a General IO error.

OpenOffice continues to work correctly if I switch the desktop to Gnome

--

A little more info - in the cases described above, I was connecting to the
NAS using the "Network / Samba Shares" option in the Open Office file
manager.

I also have the files system mounted using the following entry in fstab

/MAXTOR/GREENOCK /media/network/greenock cifs
credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777
0 0

If I access the files via the mount point, I can update an existing file,
but "SaveAs" gives a General Input/Ouput error, and creates an empty file
with the correct name

--

ccheney - note

This appears to be an issue with kernel cifs mounting possibly with mand option, versus when using gnome and gvfs-fuse which does not use regular cifs method to access files. This does not appear to be KDE specific. Try using the cifs nobrl option to see if this helps.

--

ProblemType: Bug
Architecture: amd64
Date: Sat Nov 21 21:44:02 2009
DistroRelease: Ubuntu 9.10
Package: openoffice.org-core 1:3.1.1-5ubuntu1 [modified: var/lib/openoffice/basis3.1/program/services.rdb]
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: openoffice.org
Uname: Linux 2.6.31-14-generic x86_64

Revision history for this message
DaveHowes (howesda) wrote :
Revision history for this message
Dan Buhrman (dan-buhrman) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Are you able to save the file somewhere on your local hard drive, and then copy the files over to your NAS afterwards? Or, is it any time you attempt to save files to your NAS?

Changed in openoffice.org (Ubuntu):
status: New → Incomplete
Revision history for this message
DaveHowes (howesda) wrote : Re: [Bug 486443] Re: Open Office Word Processor can not save files to NAS write

I can save to the desktop and then copy and paste to the NAS using dolphin

If I try to open a file using the file manager in OpenOffice I get a message
that says "You can only select local files"

Same thing seems to be happening if I create a new file on OpenOffice and
then try to save to the NAS - this isn't what was happening previously ....

Dave

2009/11/21 dvlchd3 <email address hidden>

> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. Are you able to save the file somewhere on your local
> hard drive, and then copy the files over to your NAS afterwards? Or, is
> it any time you attempt to save files to your NAS?
>
> ** Changed in: openoffice.org (Ubuntu)
> Status: New => Incomplete
>
> --
> Open Office Word Processor can not save files to NAS write
> https://bugs.launchpad.net/bugs/486443
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “openoffice.org” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: openoffice.org
>
> Ubuntu Karmic - recent upgrade from Jaunty - also moved from Gnome to KDE
>
> Open Office under KDE can't save files to my Maxtor NAS drive. If I
> navigate to a file, all the folder names are displayed as numbers rather
> than letters. If I try to create a new file on the the NAS drive, an empty
> file is created, and then Open Office displays a General IO error.
>
> OpenOffice continues to work correctly if I switch the desktop to Gnome
>
> ProblemType: Bug
> Architecture: amd64
> Date: Sat Nov 21 21:44:02 2009
> DistroRelease: Ubuntu 9.10
> Package: openoffice.org-core 1:3.1.1-5ubuntu1 [modified:
> var/lib/openoffice/basis3.1/program/services.rdb]
> ProcEnviron:
> LANGUAGE=
> PATH=(custom, user)
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
> SourcePackage: openoffice.org
> Uname: Linux 2.6.31-14-generic x86_64
>

Revision history for this message
DaveHowes (howesda) wrote :

A little more info - in the cases described above, I was connecting to the
NAS using the "Network / Samba Shares" option in the Open Office file
manager.

I also have the files system mounted using the following entry in fstab

/MAXTOR/GREENOCK /media/network/greenock cifs
credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777
0 0

If I access the files via the mount point, I can update an existing file,
but "SaveAs" gives a General Input/Ouput error, and creates an empty file
with the correct name

Dave

2009/11/21 Dave Howes <email address hidden>

> I can save to the desktop and then copy and paste to the NAS using dolphin
>
> If I try to open a file using the file manager in OpenOffice I get a
> message that says "You can only select local files"
>
> Same thing seems to be happening if I create a new file on OpenOffice and
> then try to save to the NAS - this isn't what was happening previously ....
>
> Dave
>
> 2009/11/21 dvlchd3 <email address hidden>
>
> Thank you for taking the time to report this bug and helping to make
>> Ubuntu better. Are you able to save the file somewhere on your local
>> hard drive, and then copy the files over to your NAS afterwards? Or, is
>> it any time you attempt to save files to your NAS?
>>
>> ** Changed in: openoffice.org (Ubuntu)
>> Status: New => Incomplete
>>
>> --
>> Open Office Word Processor can not save files to NAS write
>> https://bugs.launchpad.net/bugs/486443
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in “openoffice.org” package in Ubuntu: Incomplete
>>
>> Bug description:
>> Binary package hint: openoffice.org
>>
>> Ubuntu Karmic - recent upgrade from Jaunty - also moved from Gnome to KDE
>>
>> Open Office under KDE can't save files to my Maxtor NAS drive. If I
>> navigate to a file, all the folder names are displayed as numbers rather
>> than letters. If I try to create a new file on the the NAS drive, an empty
>> file is created, and then Open Office displays a General IO error.
>>
>> OpenOffice continues to work correctly if I switch the desktop to Gnome
>>
>> ProblemType: Bug
>> Architecture: amd64
>> Date: Sat Nov 21 21:44:02 2009
>> DistroRelease: Ubuntu 9.10
>> Package: openoffice.org-core 1:3.1.1-5ubuntu1 [modified:
>> var/lib/openoffice/basis3.1/program/services.rdb]
>> ProcEnviron:
>> LANGUAGE=
>> PATH=(custom, user)
>> LANG=en_GB.UTF-8
>> SHELL=/bin/bash
>> ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
>> SourcePackage: openoffice.org
>> Uname: Linux 2.6.31-14-generic x86_64
>>
>
>

Revision history for this message
Dan Buhrman (dan-buhrman) wrote : Re: Open Office Word Processor can not save files to NAS write
Changed in openoffice.org (Ubuntu):
status: Incomplete → Confirmed
Changed in openoffice:
status: Unknown → New
Changed in openoffice:
status: New → Confirmed
Chris Cheney (ccheney)
tags: added: karmic
Chris Cheney (ccheney)
Changed in openoffice.org (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
summary: - Open Office Word Processor can not save files to NAS write
+ [upstream] OOo can not save files to NAS write
summary: - [upstream] OOo can not save files to NAS write
+ [upstream] OOo can not save files to NAS cifs
Revision history for this message
Chris Cheney (ccheney) wrote : Re: [upstream] OOo can not save files to NAS cifs

Does using 'nomand' resolve this problem for anyone? I noticed most/all of the complaints were about using cifs with 'mand' which is 'Allow mandatory locks on this filesystem.' which may be somehow causing the problem. If it is that will probably help the developers to fix the problem.

Revision history for this message
Chris Cheney (ccheney) wrote :

Actually if that is the cause it is probably a bug in the cifs/kernel related bits not OOo.

From man 2 fcntl:

   Mandatory locking
       (Non-POSIX.) The above record locks may be either advisory or manda‐
       tory, and are advisory by default.

       Advisory locks are not enforced and are useful only between cooperating
       processes.

       Mandatory locks are enforced for all processes. If a process tries to
       perform an incompatible access (e.g., read(2) or write(2)) on a file
       region that has an incompatible mandatory lock, then the result depends
       upon whether the O_NONBLOCK flag is enabled for its open file descrip‐
       tion. If the O_NONBLOCK flag is not enabled, then system call is
       blocked until the lock is removed or converted to a mode that is com‐
       patible with the access. If the O_NONBLOCK flag is enabled, then the
       system call fails with the error EAGAIN.

       To make use of mandatory locks, mandatory locking must be enabled both
       on the file system that contains the file to be locked, and on the file
       itself. Mandatory locking is enabled on a file system using the "-o
       mand" option to mount(8), or the MS_MANDLOCK flag for mount(2). Manda‐
       tory locking is enabled on a file by disabling group execute permission
       on the file and enabling the set-group-ID permission bit (see chmod(1)
       and chmod(2)).

       The Linux implementation of mandatory locking is unreliable. See BUGS
       below.

Chris Cheney (ccheney)
description: updated
Revision history for this message
Chris Cheney (ccheney) wrote :

Does the cifs 'nobrl' option help anyone with this bug? I have heard early reports this might work.

description: updated
Revision history for this message
Chris Cheney (ccheney) wrote :

If setting nobrl works, then I think I know of a workaround that doesn't require using nobrl long term. There is a check in /usr/lib/openoffice/program/soffice to disable locking on network filesystems due to locking often breaking that doesn't currently check for cifs.

Changed in openoffice.org (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
milestone: none → ubuntu-10.04.1
Chris Cheney (ccheney)
Changed in openoffice.org (Ubuntu Lucid):
assignee: nobody → Chris Cheney (ccheney)
Chris Cheney (ccheney)
summary: - [upstream] OOo can not save files to NAS cifs
+ [upstream] OOo can not save files to NAS cifs - needs nobrl or disable
+ locking
Changed in openoffice.org (Ubuntu):
assignee: nobody → Chris Cheney (ccheney)
milestone: none → maverick-alpha-2
Revision history for this message
Piotr Kujawski (elektrownia) wrote : Re: [upstream] OOo can not save files to NAS cifs - needs nobrl or disable locking

The 'nobrl' option for cifs works for me on three wotkstations.

Revision history for this message
DSHR (s-heuer) wrote :

We are using nobrl in a production environment with 3k workstations.

This fixed also problems with CIFS clients on low bandwidth connections. There a kernel bug led to corrupted files by race conditions between application writes and the kernel flushing buffers in kernel mode - without looking at the locks by the application write (different writing processes).

Maybe that is fixed in newer kernels ...

Revision history for this message
Marco Giorgetti (midimarcus) wrote :

I've added nobrl options to cifs mount and it works for me, too.

Revision history for this message
PseHouri (psehouri) wrote :

It works for us too !!! thankx !!!

Martin Pitt (pitti)
Changed in openoffice.org (Ubuntu Lucid):
milestone: ubuntu-10.04.1 → ubuntu-10.04.2
Revision history for this message
bart (bart-wp) wrote :

The 'nobrl' option for cifs works for me, thank you.

Chris Cheney (ccheney)
Changed in openoffice.org (Ubuntu):
assignee: Chris Cheney (ccheney) → nobody
Changed in openoffice.org (Ubuntu Lucid):
assignee: Chris Cheney (ccheney) → nobody
Changed in openoffice.org (Ubuntu Lucid):
milestone: ubuntu-10.04.2 → ubuntu-10.04.3
Changed in openoffice.org (Ubuntu):
milestone: maverick-alpha-2 → maverick-updates
Colin Watson (cjwatson)
Changed in openoffice.org (Ubuntu Lucid):
milestone: ubuntu-10.04.3 → ubuntu-10.04.4
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

No new OOo releases in Ubuntu => Wont fix
Needs upstream bug reference in LibreOffice => Incomplete

Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix
Changed in openoffice.org (Ubuntu Lucid):
status: Triaged → Won't Fix
Changed in df-libreoffice:
status: New → Incomplete
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

DaveHowes, is this an issue for you in LibreOffice? If using Lucid or Maverick feel free to type at the Terminal:

sudo add-apt-repository ppa:libreoffice/ppa && sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y install libreoffice-writer

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Changed in openoffice.org (Ubuntu Lucid):
milestone: ubuntu-10.04.4 → none
Changed in openoffice.org (Ubuntu):
milestone: maverick-updates → none
Changed in openoffice.org (Ubuntu Lucid):
importance: Medium → Low
Changed in openoffice.org (Ubuntu):
importance: Medium → Low
summary: - [upstream] OOo can not save files to NAS cifs - needs nobrl or disable
+ [upstream] Can not save files to NAS cifs - needs nobrl or disable
locking
Revision history for this message
Michael Lueck (mlueck) wrote : Re: [upstream] Can not save files to NAS cifs - needs nobrl or disable locking

I tried following your steps to install LibreOffice on a recently loaded 10.04 system. I wanted to install the entire suite, not just writer so I tried selecting libreoffice in Aptitude. That results in the following error:

libreoffice:

 Depends: libreoffice-core but it is not going to be installed

 Depends: libreoffice-writer but it is not going to be installed

 Depends: libreoffice-calc but it is not going to be installed

 Depends: libreoffice-impress but it is not going to be installed

 Depends: libreoffice-draw but it is not going to be installed

 Depends: libreoffice-math but it is not going to be installed

 Depends: libreoffice-base but it is not going to be installed

 Depends: libreoffice-report-builder-bin but it is not going to be installed

 Depends: libreoffice-filter-mobiledev but it is not going to be installed

 Depends: libreoffice-java-common but it is not going to be installed

This is after it comes up with an additional changes dialog stating that OpenOffice related packages will be removed.

So, that must not be complete steps to transition form OO to LO. Could you please elaborate further? Thanks!

Revision history for this message
Michael Lueck (mlueck) wrote :

Never mind about the install problems, others please find the instructions here:

"Install libreoffice in ubuntu 11.04/10.10/10.04 using PPA"
http://www.ubuntugeek.com/install-libreoffice-in-ubuntu-11-0410-1010-04-using-ppa.html

Off to testing the existing OO bugs I know of...

Revision history for this message
Michael Lueck (mlueck) wrote :

This bug was originally for me:

Lucid Impress crashes when opening a file located on a Samba smbfs mount
Bug #586438
https://bugs.launchpad.net/bugs/586438

I removed the nobrl option from my mount commands

I logged off all mounts / logged back on

I can open files on the Samba server successfully, I can SaveAs creating new copies of files, and I can successfully open the new copies.

I think this one is confirmed fixed with 10.04 Lucid and LibraOffice installed via the instructions in #18

summary: - [upstream] Can not save files to NAS cifs - needs nobrl or disable
- locking
+ Can not save files to NAS cifs - needs nobrl or disable locking
Changed in libreoffice (Ubuntu Lucid):
status: New → Incomplete
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

closing as fix released as per comment 19

Changed in libreoffice (Ubuntu):
status: Incomplete → Fix Released
Changed in libreoffice (Ubuntu Lucid):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.