[upstream] can't remove new line after table in writer

Bug #254655 reported by Robert Persson on 2008-08-04
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Wishlist
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Wishlist
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org
Binary package hint: LibreOffice

1)
LibreOffice:
lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

OOo:
Hardy

2)
LibreOffice:
apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu2
  Candidate: 1:3.3.2-1ubuntu2
  Version table:
 *** 1:3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

OOo:
OpenOffice Writer 2.4.1

3) What is expected to happen is when one performs at the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/254655/+attachment/2010494/+files/example.odt && lowriter -nologo example.odt

one may delete page 2 by going to the end of the page 1 table and clicking Delete on the keyboard.

4) What happens instead is that the table insists on being followed by a new line. This means that you cannot get rid of new line characters between tables. It also means that you cannot get rid of a new line character when it follows a table at the end of a document. This latter case can mean that you need to reduce the size of the bottom page margin just to make sure then new line character doesn't get printed on a new page. What ought to happen is that there should be no new line of text after a table unless you actually want one.

WORKAROUND: Secondary click the table -> primary click Table... -> click the Borders tab -> in the Spacing to contents area, the four fields are 0.04" by default with the Synchronize checkbox checked. Change all 4 fields to 0 -> click the OK button. Change the font size of the space to 1 and notice the second page disappears with the cursor immediately below the table on the first page.
WORKAROUND: Go to end of paragraph in right bottom cell -> Ctrl+Shift+Delete.

Find other useful shortcut keys in the help in part "Shortcut Keys for Tables in OpenOffice.org Writer" in chapter "Shortcut Keys for OpenOffice.org Writer.

Charlie Kravetz (charlie-tca) wrote :

I have found this true. To add to this, if you create more than one table, and try to move the tables as close together as possible, the new line moves with the table, and will not allow the two tables to be placed any closer together than the line height as determined by the font size.

Charlie Kravetz (charlie-tca) wrote :

Although I can now push two tables together, I still can not have a table at the bottom of the document without changing the bottom margin.

Changed in openoffice.org:
status: New → Confirmed
Charlie Kravetz (charlie-tca) wrote :

------- Additional comments from <email address hidden> Sat Oct 11 17:22:33 +0000 2008 -------
Go to end of paragraph in left bottom cell.
Ctrl+Shift+Delete.

Find other useful shortcut keys in the help in part "Shortcut Keys for Tables
in OpenOffice.org Writer" in chapter "Shortcut Keys for OpenOffice.org Writer."

Thanks for helping

Changed in openoffice.org:
status: Confirmed → Fix Released
C de-Avillez (hggdh2) wrote :

Adjusting final status to Invalid, from Fix Released: this is not a bug.

Changed in openoffice.org:
status: Fix Released → Invalid
description: updated
i22yb (israel.b) wrote :

The Control+Shift+Delete trick does seem to partially work; however, if I save the file and re-open it then the line break comes back!

I'm making a single page 10 up business card template with a table and don't want any line-breaks after it. Unfortunately, this bug causes a line / page break at the end of my document leaving an extra blank page.

I'm using OOo 3.0.0

Changed in openoffice:
status: Unknown → Invalid
Chris Cheney (ccheney) on 2009-01-14
Changed in openoffice.org:
importance: Undecided → Low
status: Invalid → Triaged
Changed in openoffice:
status: Invalid → Confirmed
description: updated

Created attachment 42623
Example.odt

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/254655

When a new table is created it creates an unnecessary space at the bottom of it (please see attached Example.odt).

A workaround for this is Secondary click the table -> primary click Table... -> click the Borders tab -> in the Spacing to contents area, the four fields are 0.04" by default with the Synchronize checkbox checked. Change all 4 fields to 0 -> click the OK button. However, it is more convenient if the default install had this workaround already committed.

Occurs in Ubuntu 10.10 with libreoffice-writer. WORKAROUND: Secondary click the table -> primary click Table... -> click the Borders tab -> in the Spacing to contents area, the four fields are 0.04" by default with the Synchronize checkbox checked. Change all 4 fields to 0 -> click the OK button.

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.0-1maverick1
  Candidate: 1:3.3.0-1maverick1
  Version table:
 *** 1:3.3.0-1maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

tags: added: lo33

Well, this is by design... how could you add text after the table otherwise?

See the downstream conclusion... which is completely accurate:

--- Snip ---
RESOLUTION:

Not a Bug.

Go to end of paragraph in right bottom cell.
Ctrl+Shift+Delete.

Find other useful shortcut keys in the help in part "Shortcut Keys for Tables
in OpenOffice.org Writer" in chapter "Shortcut Keys for OpenOffice.org Writer.
--- Snip ---

Changed in libreoffice:
status: Unknown → Confirmed

Cédric Bosdonnat:

Thank you for responding quickly to this bug.

I also noted the same thing as downstream and agree looking at it from the experienced user/developer perspective, not a bug.

Looking at it from the new(er) user, it is a big issue. I personally went through months of creating one page documents with tables at the end and making sure one line was left at the end because how to remove it was not known. I got fed up and finally made a bug ( https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/691296 ). Other people have also experienced this same issue and addressing this is one less thing a new user has to deal with to ease the transition from a competing suite to LibreOffice.

I (naively) searched the source code for Contents to spacing area via Places -> Search for Files to edit it and recompile, did not find it. Any suggestions?

Your understanding is appreciated.

(In reply to comment #2)
> Looking at it from the new(er) user, it is a big issue. I personally went
> through months of creating one page documents with tables at the end and making
> sure one line was left at the end because how to remove it was not known. I got
> fed up and finally made a bug (
> https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/691296 ). Other
> people have also experienced this same issue and addressing this is one less
> thing a new user has to deal with to ease the transition from a competing suite
> to LibreOffice.

Then this is an enhancement, not a bug.

> I (naively) searched the source code for Contents to spacing area via Places ->
> Search for Files to edit it and recompile, did not find it. Any suggestions?
>
> Your understanding is appreciated.

Sorry, but this goes far beyond the simple spacings... I fear this is no easy hack.

summary: - [upstream] can't remove new line after table in openoffice writer
+ [upstream] can't remove new line after table in writer
Changed in libreoffice:
importance: Unknown → Wishlist
affects: libreoffice → df-libreoffice
Changed in libreoffice (Ubuntu):
status: New → Triaged
description: updated
Changed in libreoffice (Ubuntu):
importance: Undecided → Wishlist
description: updated
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

This is:
- a clearcut upstream issue
- wishlist/feature request unlikely to be fixable with a simple patch
- wont be fixed in libreoffice packaging
Resolving as WONTFIX in libreoffice packaging. This does not mean the issue will not be cared about, but if it is cared about (even by Ubuntu/Canonical contributors), it is done upstream at LibreOffice.

Libreoffice (Ubuntu) => WONTFIX

Changed in libreoffice (Ubuntu):
status: Triaged → Won't Fix

Using LibreOffice 4.0.2.2 (Windows 7) I can't delete the empty line following the table by using "Shift+Ctrl+Del" as suggested in comment 1 (and as specified by https://help.libreoffice.org/Writer/Shortcut_Keys_for_Writer#Shortcut_Keys_for_Tables_in_LibreOffice_Writer).

So I'd call this a BUG, not an enhancement.

I confirm that the shortcut ctrl+shift+del doesn't do anything in LO 4.0.3.3 (Ubuntu 13.04).

Created attachment 98352
document of one page with a table and no line after the table

(In reply to comment #5)
> I confirm that the shortcut ctrl+shift+del doesn't do anything in LO 4.0.3.3
> (Ubuntu 13.04).

Help says: "If no whole cell is selected and the cursor is at the end of the table, the paragraph following the table will be deleted, unless it is the last paragraph in the document."

In current stable version, this shortcut works as designed.
You can't remove the last paragraph of the document, but you can have a table covering the entire page without a line after the table. For example by inserting the table in a frame. See attachment.

Best regards. JBF

Rocko (rockorequin) wrote :

This comment in the upstream bug, https://bugs.freedesktop.org/show_bug.cgi?id=33631#c6, says to put the table into a frame, and this seems to work (I'm currently on libreoffice-writer 1:4.3.2~rc2-0ubuntu1~trusty2).

You have to be careful to not make the frame bigger than the table, or it will overwrite the footer (even if fill type is set to none).

NEW is appropriate status, not REOPENED.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.