Tab names unreadable in GTK3 in Ubuntu

Bug #1527053 reported by Luke on 2015-12-17
96
This bug affects 18 people
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Medium
libreoffice (Ubuntu)
High
Björn Michaelsen
Yakkety
High
Björn Michaelsen
Zesty
High
Unassigned

Bug Description

Steps to reproduce:
1. On Ubuntu 15.4 or 15.10, install or build libreoffice 5.1
2. Open a tabbed dialog box such Format->Paragraph

Note the text is white on light gray, which is very hard to read. In Fedora or Debian, when you select a "dark" theme, the tabs are rendered as white text on a black background. In Ubuntu other UI elements such as the toolbar and context menus are rendered the same as Debian's dark theme(white text on black).

Steps to reproduce:

1. With a recent build of LO 5.1 launch it with $ SAL_USE_VCLPLUGIN=gtk soffice
2. Open a tabbed Dialog box such Format->Paragraph
3. Do the same with $ SAL_USE_VCLPLUGIN=gtk3 soffice

Note the text in gtk3 is white on light gray, which is very hard to read.

Created attachment 117266
gtk2 vs gtk3 in Ubuntu 15.4

I can confirm reverting
http://cgit.freedesktop.org/libreoffice/core/commit/?id=031a347668e56c1b38c0539d30e9a1cbb808ca02
resolves this issue. With GTK3 the tabs are using the theme's font color but not background color.

Caolán,
Would it be possible to use the background color too? If not, reverting to the none-themed tabs would be better than the current situation.

regression is misleading in this context

Björn,
If this doesn't get fixed before 5.1 makes it into Ubuntu, you'll want to force GTK2.

Maxim is working on theme consistency issues. See Bug 93558

This is not a dark theme/light theme issue. Both Ubuntu's dark theme Ambiance and light theme Radiance have the same issue. In Debian Jessie, when you use the tweak-tool to change to a dark theme, it correctly changes the tab color in LibreOffice.

Another difference between Debian's Dark theme and Ubuntu's, is that the dark them in Debian also changes the sidebar. However unlike the tabs, the sidebar uses the correct uses black text.

Maxim or Björn,
It seems that Ubuntu's theme information is incomplete. Should a launchpad bug be filed? In any case, we need to emulate the sidebar's fall-back behavior. If you can't read the background color, don't change the font color.

Luke (lukebenes) wrote :

This may be related to https://bugs.launchpad.net/ubuntu/+source/ubuntu-themes/+bug/1478173. If the tab backgrounds were black, there wouldn't be an issue.

Luke (lukebenes) on 2015-12-20
affects: libreoffice (Ubuntu) → df-libreoffice
Changed in df-libreoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

*** Bug 96715 has been marked as a duplicate of this bug. ***

*** Bug 97793 has been marked as a duplicate of this bug. ***

Adolfo Jayme (fitojb) on 2016-02-13
Changed in ubuntu-themes (Ubuntu):
status: New → Invalid
Luke (lukebenes) wrote :

@ Adolfo Jayme
Why did you set this to Invalid with no explanation? It is not an issue for Debian or Fedora and may people are reporting this issue with Ubuntu.

Adolfo Jayme (fitojb) wrote :

It is Invalid only for the ubuntu-themes package, of course.

tags: removed: gtk3 libreoffice
Changed in libreoffice (Ubuntu):
status: New → Triaged
importance: Undecided → Low

There are two more issues on Ubuntu associated with gtk2-vs-gtk3 behavior.
First is missing global menu and HUD in gtk3. Nonoperability of the global menu is clearly seen in the screenshot attached to this bug report.
The other is broken scrollbars. It is not seen on the screenshot, but the current state is that the slider within the modern gtk3-style scrollbars fills the area of the scrollbar with its color as it moves just like a paint brush.
I don't know if these issues can be considered as part of this bug or should be considered as separate bugs?

Ubuntu 15.10 x64
LibreOffice 5.1.1.2 (1:5.1.1~rc2-0ubuntu1~wily0) installed from ppa:libreoffice/ppa

Doctor Rover,
Thank you for your input, but please do not treat the bug tracker like a discussion forum. See

https://wiki.documentfoundation.org/QA/BugReport#One_Report.2C_Five_Bugs

"One report should only have a single bug in it. Developers are unlikely to take on a bug that has multiple issues listed." Please do not add noise here. If you want to help, file clear concise bug reports and link them with the "See Also".

tags: added: gtk3
tags: removed: gtk3
Changed in libreoffice (Ubuntu):
importance: Low → High
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Changed in libreoffice (Ubuntu):
status: Triaged → Fix Committed
Martin Pitt (pitti) on 2016-10-11
no longer affects: ubuntu-themes (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu Zesty):
importance: Undecided → High

Smoketested build 1:5.2.2-0ubuntu2 from yakkety-proposed, tab texts are readable there.

tags: added: verification-done
Mark Cocker (mark-earth) wrote :

Can you also test the high contrast Ubuntu theme. It showed up as white text on white background.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:5.2.2-0ubuntu2

---------------
libreoffice (1:5.2.2-0ubuntu2) yakkety; urgency=medium

  * make notebook tab text readable w/ libreoffice-gtk3 (LP: #1527053)

 -- Bjoern Michaelsen <email address hidden> Mon, 10 Oct 2016 19:46:56 +0200

Changed in libreoffice (Ubuntu Zesty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:5.2.2-0ubuntu2

---------------
libreoffice (1:5.2.2-0ubuntu2) yakkety; urgency=medium

  * make notebook tab text readable w/ libreoffice-gtk3 (LP: #1527053)

 -- Bjoern Michaelsen <email address hidden> Mon, 10 Oct 2016 19:46:56 +0200

Changed in libreoffice (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libreoffice has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in libreoffice (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Turbo (axelhc) wrote :
Turbo (axelhc) wrote :

Good evening.

I just updated LibreOffice a couple of minutes ago but, so far, no dice. If you look at the attached image will see the problem exactly as described.

I have Ubuntu MATE 16.10, LO 5.2.2.2, compilation ID 1:5.2.2-0ubuntu2.

Regards.

@Turbo: 1:5.2.2-0ubuntu2 only explicitly hotfixed Ambiance and Radiance. Other themes will need to wait for http://cgit.freedesktop.org/libreoffice/core/commit/?id=69c9acd4b8dcd7ec8a5c3c380ad5cd8b797661ea http://cgit.freedesktop.org/libreoffice/core/commit/?id=570669631359021a8ad420753c87bcf4419d06cd to land in the distro.

Mark Cocker (mark-earth) wrote :

I am still getting this issue in Ubuntu 16.10 with Radiance and Ambiance themes, LO 5.2.3.2 (Build ID: 1:5.2.3~rc2-0ubuntu1~yakkety1).

For example, if I close LO, switch themes from and then back to Radiance, start LO the text color in the tabs are black (which is good). In Impress I then select a line > right mouse > Line..., the text in the tabs switch to white.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.