Use the correct python version in the "uwsgi" configuration files

Bug #2017519 reported by Rodolfo Alonso
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
devstack
In Progress
Undecided
Rodolfo Alonso

Bug Description

In order to define a specific Python version, we should be able to set that in the "uwsgi" files.

For example: https://28afbbbeb395c38b77eb-80e67ec01f194d5b25d665df26ee3378.ssl.cf1.rackcdn.com/881354/1/check/neutron-tempest-plugin-ovn/66cc9e9/controller/logs/screen-keystone.txt

  Python version: 3.8.10 (default, Mar 13 2023, 10:26:41) [GCC 9.4.0]

The config file:
  [uwsgi]
  plugins = http,python3

This is related to https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/881354. We need to use Python3.9 instead of the default Python3.8 version installed in Ubuntu Focal.

description: updated
Changed in devstack:
assignee: nobody → Rodolfo Alonso (rodolfo-alonso-hernandez)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to devstack (master)

Fix proposed to branch: master
Review: https://review.opendev.org/c/openstack/devstack/+/881363

Changed in devstack:
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on devstack (master)

Change abandoned by "Rodolfo Alonso <email address hidden>" on branch: master
Review: https://review.opendev.org/c/openstack/devstack/+/881363

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.