Wrong endpoints config with configure_auth_token_middleware

Bug #1834849 reported by Slawek Kaplonski on 2019-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
devstack
Undecided
Unassigned
neutron
Critical
Slawek Kaplonski

Bug Description

It looks that after https://review.opendev.org/#/c/628651/ this deprecated function configure_auth_token_middleware is doing something wrong. And that cause problems e.g. in neutron-tempest-plugin-designate-scenario job, like in http://logs.openstack.org/16/661916/7/check/neutron-tempest-plugin-designate-scenario/eeb242b/controller/logs/screen-q-svc.txt.gz?level=ERROR#_Jul_01_11_07_05_759996

Changed in neutron:
status: New → Confirmed
importance: Undecided → Critical

Fix proposed to branch: master
Review: https://review.opendev.org/668447

Changed in neutron:
assignee: nobody → Slawek Kaplonski (slaweq)
status: Confirmed → In Progress

Reviewed: https://review.opendev.org/668447
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=538e663f0da6f0d630fc47a7cf738b188caa660b
Submitter: Zuul
Branch: master

commit 538e663f0da6f0d630fc47a7cf738b188caa660b
Author: Slawek Kaplonski <email address hidden>
Date: Mon Jul 1 13:50:33 2019 +0200

    Switch to use configure_keystone_authtoken_middleware in devstack plugin

    Function "configure_auth_token_middleware" was deprecated in devstack
    in [1].
    Patch [1] also introduced regression which cause failures in neutron's
    neutron-tempest-plugin-designate-scenario job.

    New function configure_keystone_authtoken_middleware should be used
    instead.
    This patch switches to use this new function to solve problem
    caused by patch [1] when old function is used.

    [1] https://review.opendev.org/#/c/628651/

    Change-Id: I96d69bc7a1489377b5e95965e95dc3d3f2f3a933
    Closes-Bug: #1834849

Changed in neutron:
status: In Progress → Fix Released
Changed in devstack:
status: New → Invalid
tags: added: neutron-proactive-backport-potential

This issue was fixed in the openstack/neutron 15.0.0.0b1 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers