devstack pike: Error: No sql_connection parameter is established

Bug #1734510 reported by lakshmipathi on 2017-11-26
This bug affects 2 people
Affects Status Importance Assigned to Milestone

Bug Description

After clone devstack pike repo on Ubuntu-16.04
git clone -b stable/pike openstack

While trying to launch instance from dashboard, it shows
[Error: No sql_connection parameter is established].

Tried using Nova cli even here same error message.

lakshmipathi (lakshmipathi-g) wrote :

If anyone wants to access this environment, I can share the details. So that you can check the details. thanks!

Dr. Jens Harbott (j-harbott) wrote :

I think this would be a duplicate of

Changed in devstack:
status: New → Incomplete
Dr. Jens Harbott (j-harbott) wrote :

In order to allow finding the root cause for this issue, please attach a log showing the output of "sudo journalctl -u devstack@n-cpu".

lakshmipathi (lakshmipathi-g) wrote :

Okay let me try this again during this weekend and upload the logs.


I am also having the same issue. I attached the log for sudo journalctl -u devstack@n-cpu.

Many thanks!

Launchpad Janitor (janitor) wrote :

[Expired for devstack because there has been no activity for 60 days.]

Changed in devstack:
status: Incomplete → Expired
kirandevraaj (kirandevraaj) wrote :

our tests are also affected with this issue. Running tests with openstack rally with 16 iterations, of which 4 failed while booting servers with exception "No sql_connection parameter is established"

Theodotos Andreou (theodotos) wrote :

This affects ne also when trying to bootstrap devstack with stable/pike.

Here's the output of `sudo journalctl <email address hidden>`

Dr. Jens Harbott (j-harbott) wrote :

This bug is expired, please create a new bug for your issue. But stable/pike is also close to getting EOLd, so I doubt you will still receive much support for it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments