devstack with etcd3 enabled not working on s390x

Bug #1693192 reported by Andreas Scheuring on 2017-05-24
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
devstack
Undecided
Andreas Scheuring

Bug Description

Patch [1] enabled etcd3 by default in devstack. Patch [2] adds the ability to disable etcd3 - this gets s390x devstack working again when the following line is in local.conf

  disable_service etcd3

But this is just a circumvention. The root cause is NOT that etcd3 is not working on s390x (it is working!! [5]), but that devstack downloads the (architecture dependent) binaries directly from github.com, e.g. [3]. But etcd does not provide binaries for s390x on github.
Devstack does so, as most distros do not yet have the etcd3.x version available (e.g. with ubutnu 16 it's 2.x).

I opened an issue against etcd to figure out what would need to be done to get that going [4].

Alternatively the following approaches are thinkable:

- Enhance devstack to download the binary and compile it
- Enhance devstack to check whether etcd3 is already installed and use it - otherwise fail for s390x

See also the discussion on the ML [6]

[1] https://github.com/openstack-dev/devstack/commit/546656fc0543ec2bc5b422fd9eee17f1b8122758
[2] https://review.openstack.org/467597
[3] https://github.com/coreos/etcd/releases/tag/v3.2.0-rc.1
[4] https://github.com/coreos/etcd/issues/7978
[5] https://github.com/linux-on-ibm-z/docs/wiki/Building-etcd?cm_mc_uid=&cm_mc_sid_50200000=1490870911
[6] http://lists.openstack.org/pipermail/openstack-dev/2017-May/117373.html

description: updated
Changed in devstack:
assignee: nobody → Andreas Scheuring (andreas-scheuring)
status: New → In Progress

FYI: There's a patch out that makes the URL in devtack gate configurable

https://review.openstack.org/#/c/467437

Reviewed: https://review.openstack.org/467597
Committed: https://git.openstack.org/cgit/openstack-dev/devstack/commit/?id=94b9fae4e9f43eb1329384cbeb1977baac60846e
Submitter: Jenkins
Branch: master

commit 94b9fae4e9f43eb1329384cbeb1977baac60846e
Author: Andreas Scheuring <email address hidden>
Date: Wed May 24 13:31:13 2017 +0200

    Allow disabling etcd3

    Etcd3 was enabled recently as new service in devstack [1]. But there's
    no way to disable etcd3. This is required on architectures where no etcd
    binaries are available (e.g. s390x). The long term goal of course should
    be to have those binaries available. The short term circumvention is to
    allow disabling the service in local.conf:

       disable_service etcd3

    [1] https://github.com/openstack-dev/devstack/commit/546656fc0543ec2bc5b422fd9eee17f1b8122758
    Change-Id: I6184ed193482dad9643ccb2b97133d4957485408
    Partial-Bug: #1693192

Sean Dague (sdague) wrote :

No open reviews found in this bug, unassigning. Please add a comment with active reviews before assigning an individual, or tag the bug in the gerrit review, which will do that automatically. We try not to assign bugs without patches as that discourages other folks from looking into bugs.

Changed in devstack:
assignee: Andreas Scheuring (andreas-scheuring) → nobody
status: In Progress → New

Fix proposed to branch: master
Review: https://review.openstack.org/502513

Changed in devstack:
assignee: nobody → Andreas Scheuring (andreas-scheuring)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/502514

Change abandoned by Andreas Scheuring (<email address hidden>) on branch: master
Review: https://review.openstack.org/502513
Reason: abandon in favor of https://review.openstack.org/#/c/502514/

Reviewed: https://review.openstack.org/502514
Committed: https://git.openstack.org/cgit/openstack-dev/devstack/commit/?id=941940a92cd5424bbe5125569b083f1059569bdb
Submitter: Jenkins
Branch: master

commit 941940a92cd5424bbe5125569b083f1059569bdb
Author: Andreas Scheuring <email address hidden>
Date: Wed Sep 13 00:24:02 2017 +0200

    Add etcd3 support for s390x

    Since [1] devstack is failing on s390x with "Distro not supported".
    The reason for this is the missing etcd3 support. It worked before
    [1] as we were able to disable etcd3 via local.conf. But as etcd3 is
    a base service, we might not be able to rely on this workarond in
    the future anymore.

    As there is no etcd3 binary hosted on github like it is for other
    architectures, the user needs to specify an alternative download
    URL via local.conf. Otherwise devstack will exit with an appropriate
    error message.

      ETCD_DOWNLOAD_URL=<custom-download-url>

    [1] https://github.com/openstack-dev/devstack/commit/d8bb220606737719bcdf7c5b4f54906f2974c71c

    Change-Id: I1c378a0456dcf2e94d79a02de9d3e16753d946d6
    Partial-Bug: #1693192

Dr. Jens Harbott (j-harbott) wrote :

https://review.openstack.org/502514 has been merged so I'm considering this to be fixed.

Changed in devstack:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers