devstack failed when installing SQLAlchemy-Utils===0.31.6

Bug #1548591 reported by Sam Wan
56
This bug affects 13 people
Affects Status Importance Assigned to Milestone
devstack
Invalid
Undecided
Unassigned

Bug Description

devstack failed with below errors
===
2016-02-23 02:14:19.427 | Collecting SQLAlchemy-Utils===0.31.6 (from -c /opt/stack/new/requirements/upper-constraints.txt (line 23))
2016-02-23 02:14:19.645 | Downloading SQLAlchemy-Utils-0.31.6.tar.gz (112kB)
2016-02-23 02:14:20.832 | Complete output from command python setup.py egg_info:
2016-02-23 02:14:20.832 | error in SQLAlchemy-Utils setup command: 'extras_require' must be a dictionary whose values are strings or lists of strings containing valid project/version requirement specifiers.
2016-02-23 02:14:20.832 |
2016-02-23 02:14:20.832 | ----------------------------------------
2016-02-23 02:14:20.861 | Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-TVl01d/SQLAlchemy-Utils
2016-02-23 02:14:21.133 | + /opt/stack/new/devstack/inc/python:pip_install:L1: exit_trap
2016-02-23 02:14:21.133 | + ./stack.sh:exit_trap:L474: local r=1
2016-02-23 02:14:21.133 | ++ ./stack.sh:exit_trap:L475: jobs -p
2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L475: jobs=
2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L478: [[ -n '' ]]
2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L484: kill_spinner
2016-02-23 02:14:21.134 | + ./stack.sh:kill_spinner:L370: '[' '!' -z '' ']'
2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L486: [[ 1 -ne 0 ]]
2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L487: echo 'Error on exit'
2016-02-23 02:14:21.134 | Error on exit
2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L488: generate-subunit 1456193466 195 fail
===

Revision history for this message
Christopher H. Laco (claco) wrote :

Interestingly, Googling this error led me here. In the last 3 hours we've seen the same pip errors for this package using the openstack-ansible code, so this isn't just a DevStack thing.

http://jenkins.propter.net/job/RPC-AIO/1810/console

Someone else also started a thread on the openstack-dev mailing list. Something is afoot.

http://lists.openstack.org/pipermail/openstack-dev/2016-February/087486.html

Revision history for this message
Sam Wan (sam-wan) wrote :

sorry seems I logged 2 bugs for this issue.
===

we found that setuptools==20.2 does not work.
 but seems this version has been withdrawn.
 there's no 20.2 in pypi althought change history still shows this version
 --
https://pythonhosted.org/setuptools/history.html
 --

In case you have this issue, check if setuptools is 20.2.
 If it is, uninstall it and install 20.1.1

Revision history for this message
Yang Hongyang (hongyang-yang) wrote :

The problem exists on Fedora 23, change:
'password': ['passlib >= 1.6, < 2.0'],
to
'password': ['passlib >= 1.6, < 2.0'],
in SQLAlchemy-Utils/setup.py solve the problem.

Revision history for this message
Yang Hongyang (hongyang-yang) wrote :

Sorry, change to:
'password': ['passlib>=1.6,<2.0'],

Revision history for this message
Christopher H. Laco (claco) wrote :

I just say this with a different setuptools and with SQLAlchemy-Utils-0.31.4

Revision history for this message
Xu Ao (xuao) wrote :

Run these two command to install the setuptools-20.1.1:
        pip uninstall setuptools && pip install 'setuptools < 20.2'
        in the devstack/tools/install_pip.sh
Then comment the line 135(pip_install -U setuptools) in devstack/tools/install_pip.sh
It works!

Revision history for this message
Chung Chih, Hung (lyanchih) wrote :

The version string of password library in extras_require dict is not compatible with setuptools version above 20.1.1. Maybe we could add setupttools to upper-constarints before SQLAlchemy-Uitls had fixed this problem.

Revision history for this message
Sam Wan (sam-wan) wrote : RE: [Bug 1548591] Re: devstack failed when installing SQLAlchemy-Utils===0.31.6

That's what we did.
pip install setuptools==20.1.1

Thanks and regards.

--------------------------------------------------------------------------
Shan Wan (Sam)
e2e Validation Lab (E-LAB) | Engineering Operations, Services & Solutions (EOS2)
w: 28.8296.6713 | c: 139.8068.1947 | <email address hidden> | 8F, C12, Tianfu Software Park, Chengdu, SC. China
--------------------------------------------------------------------------

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Chung Chih, Hung
Sent: Thursday, February 25, 2016 5:10 PM
To: Wan, Sam
Subject: [Bug 1548591] Re: devstack failed when installing SQLAlchemy-Utils===0.31.6

The version string of password library in extras_require dict is not compatible with setuptools version above 20.1.1. Maybe we could add setupttools to upper-constarints before SQLAlchemy-Uitls had fixed this problem.

--
You received this bug notification because you are subscribed to the bug report.
https://bugs.launchpad.net/bugs/1548591

Title:
  devstack failed when installing SQLAlchemy-Utils===0.31.6

Status in devstack:
  New

Bug description:
  devstack failed with below errors
  ===
  2016-02-23 02:14:19.427 | Collecting SQLAlchemy-Utils===0.31.6 (from -c /opt/stack/new/requirements/upper-constraints.txt (line 23))
  2016-02-23 02:14:19.645 | Downloading SQLAlchemy-Utils-0.31.6.tar.gz (112kB)
  2016-02-23 02:14:20.832 | Complete output from command python setup.py egg_info:
  2016-02-23 02:14:20.832 | error in SQLAlchemy-Utils setup command: 'extras_require' must be a dictionary whose values are strings or lists of strings containing valid project/version requirement specifiers.
  2016-02-23 02:14:20.832 |
  2016-02-23 02:14:20.832 | ----------------------------------------
  2016-02-23 02:14:20.861 | Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-TVl01d/SQLAlchemy-Utils
  2016-02-23 02:14:21.133 | + /opt/stack/new/devstack/inc/python:pip_install:L1: exit_trap
  2016-02-23 02:14:21.133 | + ./stack.sh:exit_trap:L474: local r=1
  2016-02-23 02:14:21.133 | ++ ./stack.sh:exit_trap:L475: jobs -p
  2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L475: jobs=
  2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L478: [[ -n '' ]]
  2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L484: kill_spinner
  2016-02-23 02:14:21.134 | + ./stack.sh:kill_spinner:L370: '[' '!' -z '' ']'
  2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L486: [[ 1 -ne 0 ]]
  2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L487: echo 'Error on exit'
  2016-02-23 02:14:21.134 | Error on exit
  2016-02-23 02:14:21.134 | + ./stack.sh:exit_trap:L488: generate-subunit 1456193466 195 fail
  ===

To manage notifications about this bug go to:
https://bugs.launchpad.net/devstack/+bug/1548591/+subscriptions

Revision history for this message
Kairat Kushaev (kkushaev) wrote :

the same error applies for ryu when installing devstack with neutron.

Revision history for this message
Jesse Pretorius (jesse-pretorius) wrote :
Revision history for this message
Dale Wright (diverdale) wrote :

Also ran into this error but was due to proxy issue. https works fine

changed:
GIT_BASE=${GIT_BASE:-git://git.openstack.org}
to:
GIT_BASE=${GIT_BASE:-https://git.openstack.org}

in devstack/stackrc file line 181

Hope this helps someone

Dale

Revision history for this message
Sean Dague (sdague) wrote :

This devstack bug was last updated over 180 days ago, as devstack
is a fast moving project and we'd like to get the tracker down to
currently actionable bugs, this is getting marked as Invalid. If the
issue still exists, please feel free to reopen it.

Changed in devstack:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers