GnomeKeyring errors when installing devstack

Bug #1193164 reported by Terri Yu on 2013-06-20
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
devstack
Undecided
Unassigned

Bug Description

When I try to install devstack on a fresh virtual machine using stack.sh, I get 75 mentions of the error

ERROR:root:Could not find any typelib for GnomeKeyring

(for full output from stack.sh, see attached file)

It doesn't appear to be a major error because stack.sh completes successfully. This error was confirmed by another OpenStack contributor akuno (launchpad id).

I also see the same error

ERROR:root:Could not find any typelib for GnomeKeyring

when I run `$ nova image-list`

If I run `$ pip uninstall keyring` as suggested in https://github.com/rackspace/pyrax/issues/92 , then run `$ nova image-list` again, the error goes away. If subsequently run `$ ./stack.sh`, then the error appears again because stack.sh installs Python keyring.

I speculate that this Launchpad Openstack bug report might be related:

https://bugs.launchpad.net/python-novaclient/+bug/1020238

My local machine is running Ubuntu 12.04 and I'm installing devstack on a Vagrant/VirtualBox VM also running Ubuntu 12.04.

TengHao (rainjacy) wrote :

I meet the same issue too.

xiaohanyu (xiaohanyu1988) wrote :

same problem here.

also have a openrc source problem here:
---
$ source openrc
/home/vagrant/devstack/functions:905: parse error near `&&'
$ nova list
ERROR:root:Could not find any typelib for GnomeKeyring
+--------------------------------------+------+--------+------------+-------------+------------------+
| ID | Name | Status | Task State | Power State | Networks |
+--------------------------------------+------+--------+------------+-------------+------------------+
| 23afc1eb-a6a4-42d2-a651-84963eda846b | 11 | ACTIVE | None | Running | private=10.0.0.3 |
+--------------------------------------+------+--------+------------+-------------+------------------+
----

I'm not sure whether or not this two issues are related to each other.

Steven Wright (2-launchpad-r) wrote :

I'm having the same problem as well.

I'm running devstack on a clean Ubuntu 12.04 install - running on hardware (not in a vm). I've wiped the drive and reinstalled everything from scratch about three times now. Same thing every time.

I haven't tracked down the root cause yet.

Simon Pasquier (simon-pasquier) wrote :

I have the same issue. As described in [1], the installation of gir1.2-gnomekeyring-1.0 removes the error message.

[1] https://bugs.launchpad.net/ubuntu/+source/gnome-keyring/+bug/1197988

xiaohanyu (xiaohanyu1988) wrote :

Thanks @Simon, This workaround works, but I still don't know why.

Pavel Sedlák (psedlak) wrote :

It was already fixed as noted in the bug 1197988 Simon pointed to, in version 1.6-1 of python-keyring.

In global-requirements [1] there is keyring>=1.6.1 specified, so it should not be an issue for master branches, but still it's not in the stable, where this causes issues - see bug 1213912.

[1] https://github.com/openstack/requirements/blob/5ed3935f8414905a67ecaefa2016396741c9d2cb/global-requirements.txt#L103

Pavel Sedlák (psedlak) wrote :

For tempest/stable/grizzly I've proposed to skip two tests which are failing because of this - https://review.openstack.org/#/c/43424/.

In my opinion, real solution for stable/grizzly could be:
- add keyring>=1.6.1 to python-keystoneclient requirements (if it's the key-cli who uses it) if following is ok:
- 1) keyring>=1.6.1 is in global requirements so it would not change anything for master branches
- 2) key-cli (always master) can work with that version on master so it can work also with stable/grizzly?
- 3) wouldn't it affect too much existing distributions of OS when they will be trying to use newer client?
- install that gir*gnomekeyring (or other sufficient) package by devstack (or as test-dependancy)?
- do something similar to what is mentioned in nova/keystoneclient bug #1020238 mentioned in description?
- can we silent this 'warning' in any other way?
- any other/better idea?

Dolph Mathews (dolph) wrote :

I'd actually suggest that keyring be removed from stable/grizzly altogether -- it's an optional test requirement for keystoneclient, and an optional dependency for end users. Further, I can't think of any benefit to having it installed in a tempest run (especially if it's a broken install).

Dolph Mathews (dolph) wrote :

This might also be avoidable (at least in stable/grizzly) by pinning to keyring < 2.0.

keyring 2.0 was released on August 18, 2013 (around the time this issue cropped up):

  https://pypi.python.org/pypi/keyring/

Dolph Mathews (dolph) wrote :

In a fresh ubuntu 12.04 install... 1.6 succeeds and 2.0 fails as described above.

# pip install -U 'keyring<2.0' && python -c "import keyring"
Downloading/unpacking keyring<2.0
  Downloading keyring-1.6.1.zip (80Kb): 80Kb downloaded
  Running setup.py egg_info for package keyring

    warning: no previously-included files found matching '.hg/last-message.txt'
Installing collected packages: keyring
  Found existing installation: keyring 0.9.2
    Uninstalling keyring:
      Successfully uninstalled keyring
  Running setup.py install for keyring

    warning: no previously-included files found matching '.hg/last-message.txt'
    Installing keyring script to /usr/local/bin
Successfully installed keyring
Cleaning up...

root@keyring:~# pip install -U 'keyring>=2.0' && python -c "import keyring"
Downloading/unpacking keyring>=2.0
  Downloading keyring-2.0.zip (81Kb): 81Kb downloaded
  Running setup.py egg_info for package keyring

    warning: no previously-included files found matching '.hg/last-message.txt'
Installing collected packages: keyring
  Found existing installation: keyring 1.6.1
    Uninstalling keyring:
      Successfully uninstalled keyring
  Running setup.py install for keyring

    warning: no previously-included files found matching '.hg/last-message.txt'
    Installing keyring script to /usr/local/bin
Successfully installed keyring
Cleaning up...
ERROR:root:Could not find any typelib for GnomeKeyring

Dolph Mathews (dolph) on 2013-08-24
Changed in devstack:
status: New → Confirmed
Dolph Mathews (dolph) wrote :

suggest pinning keyring < 0.2.0 on stable/grizzly https://review.openstack.org/#/c/43564/

Dolph Mathews (dolph) wrote :

Xavier: that appears to be the same backtrace as reported in bug 1217159. The issue described here should be fixed in master by a forward port of the patch in comment #12: https://review.openstack.org/#/c/43690/

Dolph Mathews (dolph) wrote :

Hrm, the above patches merged to openstack/requirements - can this be marked as fix committed/released?

Changed in devstack:
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Joe Gordon (jogo) wrote :

This hasn't been seen in over a few weeks, marking as commited

Changed in devstack:
status: Confirmed → Fix Committed
Dean Troyer (dtroyer) on 2013-10-22
Changed in devstack:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers