Apache configuration not working with 2.4 ("Forbidden")

Bug #1158416 reported by Julie Pichon on 2013-03-21
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
devstack
Undecided
Unassigned

Bug Description

The Apache configuration shipped with devstack isn't compatible with Apache 2.4, and therefore doesn't work by default on Fedora 18.

Changing a couple of lines in horizon.conf resolved this:

    <Directory /opt/stack/horizon/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

to

    <Directory /opt/stack/horizon/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Require all granted
    </Directory>

(From http://httpd.apache.org/docs/trunk/upgrading.html)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers