stack.sh should install missing dependency python-netaddr

Bug #1097667 reported by Gavin B on 2013-01-09
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
devstack
Undecided
Mate Lakat

Bug Description

On a brand new Ubuntu Precise system :

ubuntu@devstackvm:~/devstack$ ./stack.sh
Traceback (most recent call last):
  File "<string>", line 2, in <module>
ImportError: No module named netaddr
Traceback (most recent call last):
  File "<string>", line 2, in <module>
ImportError: No module named netaddr

installing python-netaddr fixes this - should stack.sh not check and install dependencies ?

Gavin B (gavin-brebner-orange) wrote :

only matters the first time as python-netaddr is installed by stack.sh if needed later on. Cosmetic issue.

Sean Dague (sdague) on 2013-02-10
Changed in devstack:
status: New → Fix Released
Christian Berendt (berendt) wrote :

Hmm. The issue is still there..? Installed a fresh Ubuntu and after cloning and running stack.sh I got the following error:

stack@devstack001:~/devstack$ ./stack.sh
Traceback (most recent call last):
  File "<string>", line 2, in <module>
ImportError: No module named netaddr
Traceback (most recent call last):
  File "<string>", line 2, in <module>
ImportError: No module named netaddr

Mate Lakat (mate-lakat) wrote :

I just installed a fresh XenServer machine, It's still there, reopening the bug.

Changed in devstack:
assignee: nobody → Mate Lakat (mate-lakat)
Mate Lakat (mate-lakat) wrote :

I can't reopen the bug.

Mate Lakat (mate-lakat) on 2013-07-12
tags: added: xenserver

Reviewed: https://review.openstack.org/36855
Committed: http://github.com/openstack-dev/devstack/commit/f34cb8513505c47723f2192c77a0068bdcc20218
Submitter: Jenkins
Branch: master

commit f34cb8513505c47723f2192c77a0068bdcc20218
Author: Mate Lakat <email address hidden>
Date: Fri Jul 12 17:11:07 2013 +0100

    xenapi: preinstall python netaddr

    On our CI system, the devstack instance was reporting errors, that are
    related to devstack's address_in_net function - that requires the python
    netaddr library to be installed. This patch preinstalls this python
    package.

    Fixes bug 1097667

    Change-Id: I8af199427f06cfdf0a68d96d87fe3e541199dca7

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers