Devstack stop supporting Tempest deprecated cred options

Bug #1531049 reported by Ghanshyam Mann on 2016-01-05
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Designate
Critical
Endre Karlson
Magnum
In Progress
Undecided
yuanying
Mistral
Undecided
Hardik Parekh
Monasca
Fix Committed
Undecided
Ghanshyam Mann
OpenStack Shared File Systems Service (Manila)
Critical
Valeriy Ponomaryov
devstack-plugin-glusterfs
Critical
Ramana Raja
devstack-plugin-hdfs
Undecided
Ramana Raja

Bug Description

Tempest provides three different credential providers for tests:
- dynamic credentials, which is what is used in all gate jobs
- preprovisioned credentials, which is used in experimental and
  periodic jobs, not yet in the gate because of bug 1524717
- legacy credentials, which relies on deprecated configuration
  options, and which is itself deprecated.

More details-
http://docs.openstack.org/developer/tempest/configuration.html#credential-provider-mechanisms

Many projects used deprecated credentials which is now failing on gate job as devstack does not set those cred options in conf.
 - I65b56ff681d6c27094380693c953fbc3664eceb0

Projects either using get_configured_credentials with cred type 'user', 'alt_user' or directly using LegacyCredentialProvider which depends on deprecated options.

Project should use dynamic cred to get right cred as mentioned above.

Changed in monasca:
assignee: nobody → Ghanshyam Mann (ghanshyammann)
Changed in manila:
assignee: nobody → Ghanshyam Mann (ghanshyammann)
yuanying (yuanying) on 2016-01-05
Changed in magnum:
assignee: nobody → yuanying (ootsuka)
Changed in manila:
assignee: Ghanshyam Mann (ghanshyammann) → nobody
Changed in mistral:
assignee: nobody → hardik (hardik-parekh047)
Changed in mistral:
status: New → In Progress
Changed in manila:
assignee: nobody → Valeriy Ponomaryov (vponomaryov)
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to manila (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/263664

Revision history for this message
Valeriy Ponomaryov (vponomaryov) wrote : Re: Devstack stop supporting Temepst deprecated cred options

Manila project requires possibility to use "preconfigured" creds and forced to use workaround setting legacy opts manually: https://review.openstack.org/263664 until bug 1524717 is fixed. Only after this bug gets fixed, Manila can use "proper" way of getting creds in Tempest.

summary: - Devstack stop supporting Temepst deprecated cred options
+ Devstack stop supporting Tempest deprecated cred options
Changed in manila:
importance: Undecided → Critical
Changed in designate:
importance: Undecided → Critical
assignee: nobody → Endre Karlson (endre-karlson)
milestone: none → mitaka-2
Ramana Raja (rraja) on 2016-01-06
Changed in devstack-plugin-glusterfs:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Ramana Raja (rraja)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to devstack-plugin-glusterfs (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/264242

Ramana Raja (rraja) on 2016-01-06
Changed in devstack-plugin-hdfs:
status: New → In Progress
assignee: nobody → Ramana Raja (rraja)
Revision history for this message
Matt Riedemann (mriedem) wrote :

Any of the devstack plugin jobs that are using preconfigured hard-coded credentials should not be running in parallel, they should be running serially otherwise there is a risk of over quota type failures in the tempest tests. This is why we test with tenant isolation in the integrated gate and concurrent test workers.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to devstack-plugin-hdfs (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/264277

Revision history for this message
Valeriy Ponomaryov (vponomaryov) wrote :

Matt,

the problem is in impossibility to run several classes using same creds, even serially, with latest tempest and devstack. It is use case of Manila.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to designate (master)

Reviewed: https://review.openstack.org/263797
Committed: https://git.openstack.org/cgit/openstack/designate/commit/?id=84bb7226cef5a2066ab2c534498a2e7d240239f3
Submitter: Jenkins
Branch: master

commit 84bb7226cef5a2066ab2c534498a2e7d240239f3
Author: Endre Karlson <email address hidden>
Date: Tue Jan 5 17:27:22 2016 +0100

    Fix CI Tempest jobs

    After merge of change [1] to devstack project, preconfigured creds for
    Tempest cannot be used anymore. But Manila requires such.
    For the moment, latest Tempest interfaces cannot allow us to use
    preconfigured creds because of bug #1524717.
    So, until this bug fixed, we should workaround Devstack changes and
    set legacy opts explicitly.

    [1] I65b56ff681d6c27094380693c953fbc3664eceb0

    Related-Bug: #1531049
    Closes-Bug: #1531189
    Change-Id: I4dc266713ec06bc6e98616a1277c8ae6cadf199d

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to manila (master)

Reviewed: https://review.openstack.org/263664
Committed: https://git.openstack.org/cgit/openstack/manila/commit/?id=f4a00c59655ec3b7d65cec79b6e88bee8a5d601d
Submitter: Jenkins
Branch: master

commit f4a00c59655ec3b7d65cec79b6e88bee8a5d601d
Author: vponomaryov <email address hidden>
Date: Tue Jan 5 12:29:31 2016 +0200

    Fix CI Tempest jobs

    After merge of change [1] to devstack project, preconfigured creds for
    Tempest cannot be used anymore. But Manila requires such.
    For the moment, latest Tempest interfaces cannot allow us to use
    preconfigured creds because of bug #1524717.
    So, until this bug fixed, we should workaround Devstack changes and
    set legacy opts explicitly.

    Also, redefine new Nutron option 'dnsmasq_local_resolv' to 'False' value,
    that is 'True' by default and was added in change [2].
    Default value causes Nova operations initiated by Manila be very slow.
    That leads to breakage of CI.

    [1] I65b56ff681d6c27094380693c953fbc3664eceb0
    [2] I17a884f467d307432a06f67a9dd93ed2fa6081a3

    Change-Id: I516a6c9ab4396b14e3984d5f810210e4fcf7ec85
    Related-Bug: #1531049
    Closes-Bug: #1530847

Changed in manila:
status: In Progress → Fix Committed
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to devstack-plugin-glusterfs (master)

Reviewed: https://review.openstack.org/264242
Committed: https://git.openstack.org/cgit/openstack/devstack-plugin-glusterfs/commit/?id=2cfbc1db6111622eb291ada9c709ae2453efe415
Submitter: Jenkins
Branch: master

commit 2cfbc1db6111622eb291ada9c709ae2453efe415
Author: Ramana Raja <email address hidden>
Date: Wed Jan 6 21:10:07 2016 +0530

    Fix Manila CI Tempest authentication issue

    With the change [1] to DevStack project, preconfigured creds for Tempest,
    required by Manila, cannot be used anymore. And for now, latest Tempest
    interfaces do not allow use of preconfigured creds due to bug #1524717.
    So, until this bug is fixed, workaround Devstack changes by setting legacy
    options explicitly.

    This workaround fix was carried over from the change [2] in the Manila
    project.

    [1] I65b56ff681d6c27094380693c953fbc3664eceb0
    [2] I516a6c9ab4396b14e3984d5f810210e4fcf7ec85

    Change-Id: I09df56aa611ba755c282c575f712261c48385fe9
    Related-Bug: #1531049

Kiall Mac Innes (kiall) on 2016-01-07
Changed in designate:
status: New → Fix Committed
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to mistral (master)

Reviewed: https://review.openstack.org/263593
Committed: https://git.openstack.org/cgit/openstack/mistral/commit/?id=2e133aa556922a41bc13d4ded097dc31e78f01c5
Submitter: Jenkins
Branch: master

commit 2e133aa556922a41bc13d4ded097dc31e78f01c5
Author: hparekh <email address hidden>
Date: Tue Jan 5 15:57:32 2016 +0900

    Updated dynamic credential support for funtional test.

    Now devstack does not setup the deprecated configured cred on Tempest
    which is being used here. - https://review.openstack.org/#/c/256164/

    get_configured_credential use the deprecated cred and these tests use
    that for initiating Manager.

    Change-Id: I89713806cb98abaca29b24de585a77f75602bcd7
    Closes-bug: #1531049

Changed in mistral:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to devstack-plugin-hdfs (master)

Reviewed: https://review.openstack.org/264277
Committed: https://git.openstack.org/cgit/openstack/devstack-plugin-hdfs/commit/?id=50f41a43f82ea303db2c2633499504c6032dab22
Submitter: Jenkins
Branch: master

commit 50f41a43f82ea303db2c2633499504c6032dab22
Author: Ramana Raja <email address hidden>
Date: Wed Jan 6 22:42:19 2016 +0530

    Fix Manila CI Tempest authentication issue

    With the change [1] to DevStack project, preconfigured creds for Tempest,
    required by Manila, cannot be used anymore. And for now, latest Tempest
    interfaces do not allow use of preconfigured creds due to bug #1524717.
    So, until this bug is fixed, workaround Devstack changes by setting legacy
    options explicitly.

    [1] I65b56ff681d6c27094380693c953fbc3664eceb0

    Related-Bug: #1531049

    Change-Id: If86b9ba11eed9412794468cc4787d0f43fc52571

BassT (mt104b) on 2016-04-06
Changed in magnum:
status: New → In Progress
Changed in monasca:
status: New → Fix Committed
Changed in designate:
status: Fix Committed → Fix Released
Revision history for this message
Dustin Schoenbrun (dschoenb) wrote :

For Manila, the Launchpad bug that was referenced above was fixed in December of last year. We need to make sure to finish this up as we do our Tempest updates in the Queens cycle.

Tom Barron (tpb) on 2017-10-18
Changed in devstack-plugin-glusterfs:
status: In Progress → Fix Released
Changed in devstack-plugin-hdfs:
status: In Progress → Fix Released
Changed in manila:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers