nova-ceph-multistore job fails permanently with: Cannot uninstall 'logutils'

Bug #1954427 reported by Balazs Gibizer
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Fix Released
Critical
Unassigned
devstack
Invalid
Undecided
Unassigned
devstack-plugin-ceph
Fix Released
Undecided
Unassigned

Bug Description

The last 4 run[2] failed with the same issue[1]:

2021-12-10 10:42:59.793429 | controller | Attempting uninstall: logutils

2021-12-10 10:42:59.793490 | controller | Found existing installation: logutils 0.3.3

2021-12-10 10:42:59.793500 | controller | ERROR: Cannot uninstall 'logutils'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

2021-12-10 10:43:00.083297 | controller | + inc/python:pip_install:1 : exit_trap

[1] https://zuul.opendev.org/t/openstack/build/722c6caf8e454849b897a43bcf617dd2/log/job-output.txt#9419
[2] https://zuul.opendev.org/t/openstack/builds?job_name=nova-ceph-multistore&project=openstack/nova

Tags: gate-failure
tags: added: gate-failure
Changed in nova:
importance: Undecided → Critical
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on devstack (master)

Change abandoned by "sean mooney <email address hidden>" on branch: master
Review: https://review.opendev.org/c/openstack/devstack/+/821394
Reason: this need to be fixed in the ceph plugin instead https://review.opendev.org/c/openstack/devstack-plugin-ceph/+/821396

Changed in devstack:
status: New → Invalid
Changed in devstack-plugin-ceph:
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to devstack-plugin-ceph (master)

Reviewed: https://review.opendev.org/c/openstack/devstack-plugin-ceph/+/821396
Committed: https://opendev.org/openstack/devstack-plugin-ceph/commit/4d9f4b22354f6d894585b627bf54be005a7e1c9b
Submitter: "Zuul (22348)"
Branch: master

commit 4d9f4b22354f6d894585b627bf54be005a7e1c9b
Author: Sean Mooney <email address hidden>
Date: Fri Dec 10 11:48:14 2021 +0000

    remove python3-logutils

    this change ensure that python3-logutils is removed so that
    that it can be installed by pip later.

    Before today in passing build, there were no python3-logutils pulled by neutron deps so
    it was not installed or tried to uninstall so all good
    - https://zuul.openstack.org/build/590c5996ca1b402486bfe1c7e1d08535/log/job-output.txt

    But from today (10th Dec), python3-logutils pulled by neutron deps and failure started
    - https://zuul.opendev.org/t/openstack/build/722c6caf8e454849b897a43bcf617dd2/log/job-output.txt#9419

    The root cause of why this issue started happening today is not known. May be its
    pecan===1.4.1 ? I8ee467bbb363f428a005f92554812bfdae95881a making it install but there
    is no change for logutils as deps in pecan previous version 1.3.3 also[1]). Or it may
    be cpeh/ubuntu packaging.

    But it is clear that python3-logutils is coming from somewhere and causing gate blocker
    in Nova gate, let's remove it and later we can find the root cause if anyone need this
    package for their ceph job.

    [1] https://github.com/pecan/pecan/blob/1.3.3/requirements.txt#L5

    Closes-bug: #1954427

    Change-Id: Icb63649b252fd6eb229adeae454b5ec3c6b79cad

Changed in devstack-plugin-ceph:
status: In Progress → Fix Released
Revision history for this message
Balazs Gibizer (balazs-gibizer) wrote :

Since the fix merged we had seen successful job runs. So I close this for Nova too.

Changed in nova:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers