ceph-based jobs failing in stable/ocata due to missing python3 packages

Bug #1724249 reported by Matt Riedemann on 2017-10-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
devstack-plugin-ceph
Undecided
Matt Riedemann

Bug Description

Seen here:

http://logs.openstack.org/06/512406/1/check/legacy-tempest-dsvm-multinode-live-migration/95adf30/job-output.txt.gz#_2017-10-17_01_35_01_267462

That's against a stable/ocata change and the python3 packages aren't available until the Pike UCA.

The problem is due to this change https://review.openstack.org/#/c/509917/ to always try and install python3-rados and python3-rbd. Since devstack-plugin-ceph is branchless any changes to the master branch are reflected in the stable branch jobs, and those won't always work.

Matt Riedemann (mriedem) wrote :
Changed in devstack-plugin-ceph:
assignee: nobody → Matt Riedemann (mriedem)
status: New → In Progress

Reviewed: https://review.openstack.org/512622
Committed: https://git.openstack.org/cgit/openstack/devstack-plugin-ceph/commit/?id=9f1f729d6053b2f9fd92e3ff28aa6df3ec6678fe
Submitter: Zuul
Branch: master

commit 9f1f729d6053b2f9fd92e3ff28aa6df3ec6678fe
Author: Matt Riedemann <email address hidden>
Date: Tue Oct 17 09:43:46 2017 -0400

    Conditionally install python3 packages

    We should only attempt to install the python3 packages
    if we're running in a python3 environment.

    Change-Id: Ic5e3046917a51d884091b449a433259c049ac016
    Closes-Bug: #1724249

Changed in devstack-plugin-ceph:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers