No published rules for rejecting applications

Bug #873443 reported by Matthew Paul Thomas on 2011-10-13
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Developer Portal

Bug Description

As far as I can tell, nowhere on is there any way for a developer to tell whether an application they submitted would be rejected.

For example, if:
- we have good reason to believe it infringes someone else's copyright
- we have good reason to believe it infringes someone else's trademark
- it crashes during testing
- it degrades any part of the OS
- it doesn't do anything useful or entertaining
- it doesn't do what the description says it does.

There should be a simple and easy-to-find page of rules on the site.

Scott Ritchie (scottritchie) wrote :

Some of the reasons for rejection may include automated tests. Part of this should include extending Lintian to have a profile and series of checks specifically for commercial App packages, which we can then point to.

There are guidelines on the wiki, scattered across several pages:


But these only apply to open-source apps.

Changed in ubuntudeveloperportal:
status: New → Confirmed
Daniel Holbach (dholbach) wrote : links to which is also shown during the process of signing up to myapps.

Changed in ubuntudeveloperportal:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers