The release number is not clear

Bug #1381981 reported by XiaoGuo, Liu on 2014-10-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Developer Portal
Medium
Unassigned

Bug Description

"Development Release APIs" and "Current Release APIs" are not so clear to know the revision number of the release. it is good to put the exact number there.

Reported from: http://developer.ubuntu.com/apps/qml/api/

Daniel Holbach (dholbach) wrote :

Yes, I think that'd make sense.

Changed in developer-ubuntu-com:
importance: Undecided → Medium
status: New → Triaged
Changed in developer-ubuntu-com:
assignee: nobody → Daniel Holbach (dholbach)
status: Triaged → Fix Released
XiaoGuo, Liu (liu-xiao-guo) wrote :

But the URL still shows:

https://developer.ubuntu.com/api/apps/qml/sdk-15.04/

on the page:

QML Apps for SDK 15.04

The is for the development one.

Daniel Holbach (dholbach) wrote :

I don't understand. Can you elaborate?

Would you like "15.04" to be always replaced with "15.04 (stable)" and "15.10" with "15.10 (development)"?

David Callé (davidc3) wrote :

I think the issue is that the importer is somehow confused here : both namespaces (/current/ and /development/) link to 15.04.

https://developer.ubuntu.com/api/apps/qml/sdk-15.10/ doesn't exist.

XiaoGuo, Liu (liu-xiao-guo) wrote :

The point is:

on the page: https://developer.ubuntu.com/en/apps/qml/api/

it says:

Development snapshot
(15.10) APIs ›

Once the link is clicked, it comes to the page:

https://developer.ubuntu.com/api/apps/qml/development/

One the page:

It shows:
APIs ›Apps ›QML ›SDK 15.04

and "QML Apps for SDK 15.04"

Which still show 15.04 instead of "15.10".

Best regards,
XiaoGuo

Daniel Holbach (dholbach) wrote :

This looks like it needs to be fixed in the importer?

Changed in developer-ubuntu-com:
status: Fix Released → Confirmed
assignee: Daniel Holbach (dholbach) → nobody
tags: added: site-dev
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers