DeVeDe does not use standard buttons on main screen

Bug #484420 reported by Rory McCann on 2009-11-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DeVeDe
Undecided
auto-raster
devede (Ubuntu)
Wishlist
Alessio Treglia

Bug Description

Binary package hint: devede

The main / first screen of DeVeDe has several buttons for adding, editing and positioning both Titles and Films. However these do not look like buttons, they instead look like text. When the mouse is hovered over them, they 'pop out slightly'. They can be clicked and act the same as buttons. This 'look' is inconsistant with the rest of the desktop.

If the buttons looked like buttons, they would have high discoverability and consistancy. If the buttons used the standard "Add", "Remove", etc. icons, they would be much more consistant and familiar.

Attached is a screenshot of the buttons in question.

ProblemType: Bug
Architecture: i386
Date: Tue Nov 17 20:17:54 2009
DistroRelease: Ubuntu 9.10
Package: devede 3.14.0-0ubuntu5
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_IE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: devede
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:2026): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2026): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:2221): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:2237): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

Related branches

Rory McCann (rorymcc) wrote :
Alessio Treglia (quadrispro) wrote :

Forwarded to upstream's author.

Changed in devede (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged

Is a bug in Ubuntu 9.10. For a misterious reason, it removed the icons from the buttons. To recover them, just open a terminal, type "gconf-editor" (without quotes) and, when it appears, activate the entry Desktop->Gnome->Interface->buttons_have_icons . This will make return all the icons in all the pygtk apps.

And if you want the icons in the System menu to return, just activate the entry Desktop->Gnome->Interface->menus_have_icons , which is disabled by default too.

Here, a capture with the entry.

Rory McCann (rorymcc) wrote :

I can confirm that changing that gconf entry will make the buttons have icons. I never changed that value in gconf.

With that value off (the Ubuntu default it seems) there are other applications (e.g.: Deluge, a bittorrent client) that show icons in toolbar, and buttons.

However the buttons still don't look like buttons. They are inconsistant with all other buttons and applications. They don't 'pop out'.

I'm the author of Devede. I fixed the problem with the buttons and I'll upload it ASAP.

Changed in devede (Ubuntu):
assignee: nobody → Raster (raster)
status: Triaged → Fix Committed
Changed in devede:
status: New → Fix Committed
Changed in devede (Ubuntu):
status: Fix Committed → Triaged

I changed the shape of the buttons to have 3D look, but I dislike the final appearance. I attach two captures, the first one with non-homogeneous buttons, which looks quite ugly because each one has a different width, and the second one with homogeneous buttons, which makes the interface too wide.

The original reason to remove the pop-up was to make them look like a button box (which didn't have that popping up effect in old themes).

This is the capture with homogeneus buttons (bugzilla only allows for one attach per message). As I comment in the previous comment, this arrangement looks excesively wide.

Finally, here is a capture with the current layout, with icons but without popping-up buttons. I really like it...

Finally, here is a capture with the current layout, with icons but without popping-up buttons.

Alessio Treglia (quadrispro) wrote :

So, should we mark this as "Won't fix"?

In fact, I was asking your opinion to decide what to do... I personally prefer to keep the buttons without the popping-up, but in the other hand, HIG compliance is important...

Alessio Treglia (quadrispro) wrote :

I agree with Rory, I think that the current view is inconsistant with the rest of the desktop and your first screenshot seems the right solution.

But, anyway, you are "upstream", so feel free to decide whether or not to change the current GUI look.

I made some adjusts and I think now it has a good appearance, and with pop-up buttons. This weekend I'll upload the new version with this and other bugfixes.

On Thu, Mar 18, 2010 at 1:41 AM, Raster <email address hidden> wrote:
> I made some adjusts and I think now it has a good appearance, and with
> pop-up buttons. This weekend I'll upload the new version with this and
> other bugfixes.
>

Great, thanks!

--
Alessio Treglia <email address hidden>
Ubuntu MOTU Developer | Homepage: http://www.alessiotreglia.com
0FEC 59A5 E18E E04F 6D40 593B 45D4 8C7C DCFC 3FD0

I'm the author of Devede. I launched today the new version 2.16.6, which fixes this. It's available in the official homepage (http://www.rastersoft.com/programas/devede.html)

Changed in devede (Ubuntu):
status: Triaged → Fix Released
Changed in devede:
status: Fix Committed → Fix Released
Changed in devede (Ubuntu):
assignee: Raster (raster) → Alessio Treglia (quadrispro)
status: Fix Released → In Progress
Alessio Treglia (quadrispro) wrote :

Uploaded, sitting in the queue.

Changed in devede (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package devede - 3.16.6-0ubuntu1

---------------
devede (3.16.6-0ubuntu1) lucid; urgency=low

  * New upstream bugfix release:
    - Buttons in main window now have a border, like all other
      ones (LP: #484420)
    - Desktop launcher now shows a more HIG-compliant description (LP: #371229)
    - Pressing RETURN key in Title properties and Create disc dialogs works like
      clicking the Accept button (LP: #496740).
  * debian/patches/02-setup_py.patch:
    - Bump upstream version.
  * debian/patches/01-fix_building.patch:
    - Refresh.
 -- Alessio Treglia <email address hidden> Fri, 19 Mar 2010 01:38:07 +0100

Changed in devede (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.