Futon/Basic HTTP auth broken for couchdb-bin 0.11

Bug #599745 reported by Chad Miller on 2010-06-29
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
desktopcouch
Critical
Chad Miller
desktopcouch (Ubuntu)
Undecided
Unassigned

Bug Description

0.11 of couchdb-bin breaks the bookmark and HTTP Basic auth to desktopcouch DB.

Related branches

Chad Miller (cmiller) on 2010-06-29
Changed in desktopcouch:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Chad Miller (cmiller)
summary: - Futon/Basic HTTP auth broken for 0.11
+ Futon/Basic HTTP auth broken for couchdb-bin 0.11
Chad Miller (cmiller) on 2010-07-12
Changed in desktopcouch:
status: Confirmed → In Progress
Changed in desktopcouch (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktopcouch - 0.6.6-0ubuntu3

---------------
desktopcouch (0.6.6-0ubuntu3) maverick; urgency=low

  * debian/patches/lp_599745.patch
    - Support new Basic auth for HTTP that our bookmark file
      requires. (LP: #599745)
 -- Ken VanDine <email address hidden> Tue, 20 Jul 2010 15:28:06 +0200

Changed in desktopcouch (Ubuntu):
status: New → Fix Released
Ken VanDine (ken-vandine) wrote :

This is only a partial fix, it requires recreating the .ini file to get the fix.

Chad Miller (cmiller) on 2010-07-26
Changed in desktopcouch (Ubuntu):
status: Fix Released → Confirmed
Chad Miller (cmiller) on 2010-07-27
Changed in desktopcouch:
status: In Progress → Fix Committed
Changed in desktopcouch (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Colin Watson (cjwatson) wrote :

desktopcouch (0.6.8-0ubuntu1) maverick; urgency=low

  * Add Ubuntu One pairing to desktopcouch, the code looks for
    credentials at start time and will listen to them while the dbus
    service is running.
  * On couchdb failure, reconnect with logic that starts up the
    couchdb server again and uses the new port. Instead of giving
    python-couchdb view objects to the user, give an object we own
    that implements reconnecting to the server on errors, and proxies
    commands otherwise. (LP: #522538)
  * Support new Basic auth for HTTP that our bookmark file
    requires. Make Basic-auth part of compulsory INI file. (LP:
    #599745)
  * When a stored record exists and is marked as deleted, and a user
    tries to store a new record with the same ID, do some ugly work to
    make the user's record be the deleted-record's successor. (LP:
    #462245)
  * Removed debian/patches/lp_599745.patch since it was included in
    upstream.
  * Fix errors in parameters in new code. (LP: #634396 #634784)

 -- Eric Casteleijn <email address hidden> Fri, 10 Sep 2010 10:44:04 -0400

Changed in desktopcouch (Ubuntu):
status: Confirmed → Fix Released
Chad Miller (cmiller) on 2010-10-08
Changed in desktopcouch:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers