Syncing experience on slow connections noticeable.

Bug #520687 reported by Jorge Castro on 2010-02-11
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Ryan Paul
desktopcouch
High
Ubuntu One Client Engineering team
gwibber (Ubuntu)
Undecided
Unassigned

Bug Description

A friend of mine started using gwibber with the couch backend and he can notice when the machine replicates every 10 minutes due to the syncing of couchdb's with ubuntuone on his slow DSL line.

I don't know if this bug should be "Doesn't obey bandwidth restrictions a user sets in the U1 capplet" or "Couch is syncing too much stuff". Bandwidth graph is attached.

Jorge Castro (jorge) wrote :
Elliot Murphy (statik) wrote :

thanks for reporting this!

couchdb sync definitely is not using the same bandwidth restricter as file sync, they are largely independent connections.

any idea what size the couchdb databases are locally? i'd love to get this reproduced so we can figure out whether to go after reducing the size of the DB or throttling the connection first.

Craig Maloney (craig-decafbad) wrote :

Hi. I'm said friend. :) What's the location of the couchdb databases?

Craig Maloney (craig-decafbad) wrote :

Got the location from Jorge:

craig@lister:~/.local/share/desktop-couch$ ls -al
total 12392
drwx------ 6 craig craig 4096 2010-02-02 15:31 .
drwxr-xr-x 24 craig craig 4096 2009-12-21 17:42 ..
-rw-r--r-- 1 craig craig 8283 2010-02-11 08:18 contacts.couch
-rw-r--r-- 1 craig craig 1368 2010-02-11 17:19 couchdb.html
-rw-r--r-- 1 craig craig 45147 2010-02-11 08:18 gwibber_accounts.couch
drwxr-xr-x 2 craig craig 4096 2010-02-02 15:30 .gwibber_accounts_design
-rw-r--r-- 1 craig craig 12431460 2010-02-11 16:42 gwibber_messages.couch
drwxr-xr-x 2 craig craig 4096 2010-02-09 17:47 .gwibber_messages_design
-rw-r--r-- 1 craig craig 118875 2010-02-11 16:17 gwibber_preferences.couch
drwxr-xr-x 2 craig craig 4096 2010-02-02 15:30 .gwibber_preferences_design
-rw-r--r-- 1 craig craig 8281 2009-11-02 07:59 management.couch
drwxr-xr-x 2 craig craig 4096 2009-11-02 07:59 .management_design
-rw-r--r-- 1 craig craig 8283 2010-02-11 08:18 notes.couch
-rw-r--r-- 1 craig craig 79 2009-10-22 23:29 users.couch

Craig Maloney (craig-decafbad) wrote :

Also:

37M .gwibber_messages_design

Ryan Paul (segphault) wrote :

In Futon, my gwibber_messages database is reported to be 90MB with roughly 12,000 messages. When I compact it, the size drops to about 20MB. Periodically compacting the db would certainly help.

Jorge Castro (jorge) on 2010-02-20
Changed in desktopcouch:
status: New → Confirmed
Rick McBride (rmcbride) on 2010-02-23
Changed in desktopcouch:
importance: Undecided → High
Rick McBride (rmcbride) on 2010-02-23
Changed in desktopcouch:
assignee: nobody → Ubuntu One Foundations+ team (ubuntuone-foundations+)
Changed in gwibber:
assignee: nobody → Ryan Paul (segphault)
importance: Undecided → High
milestone: none → 2.30.0
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.29.92-0ubuntu1

---------------
gwibber (2.29.92-0ubuntu1) lucid; urgency=low

  * new upstream release 2.29.92
    - Raise errors for auth failures
    - don't sync the gwibber_messages to ubuntuone (LP: #520687)
    - use dbus names to check for existing service (LP: #534922)
  * debian/gwibber.install
    - Added files needs for raising error dialogs
 -- Ken VanDine <email address hidden> Thu, 11 Mar 2010 12:20:52 -0500

Changed in gwibber (Ubuntu):
status: New → Fix Released
Omer Akram (om26er) on 2010-04-08
Changed in gwibber:
status: Confirmed → Fix Released
Changed in desktopcouch:
assignee: Ubuntu One Foundations+ team (ubuntuone-foundations+) → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Eric Casteleijn (thisfred) wrote :

In reply to:

"37M .gwibber_messages_design"

and:

"In Futon, my gwibber_messages database is reported to be 90MB with roughly 12,000 messages. When I compact it, the size drops to about 20MB. Periodically compacting the db would certainly help."

What couchdb-replication sends over the wire, are individual documents, and not the entire db. Compaction has no impact on replication traffic, as it gets rid of old versions of documents, which are never replicated. (What's being sent is any documents with changes since the last successful replication.)

.gwibber_messages_design contains stored view indexes, which are (re)computed on each node when they are called, and so also never sent over the wire.

So, while periodic compaction is a very good idea to save disk space, it will not have an effect on repliction.

Tom Goh (tomgohj) wrote :

4.2GB and growing on 10.04 and I hardly even use it. It should keep a maximum of 1 week of data.

Version: 2.30.3-0ubuntu1

I don't think this is fixed.

Tom Goh (tomgohj) wrote :

hrmm, 7GB + with some other couchDB stuff. I don't think I am using any other couchDB apps. Gwibber being the only one I know of.

Arthur Lutz (arthur-lutz) wrote :

I have a 2G file and a 520M file in ~/.local/share/desktop-couch/.gwibber_messages_design

and am using version : 2.30.3-0ubuntu1 ...

JACQUELINE (ijdisabest) on 2015-01-30
Changed in desktopcouch:
status: Confirmed → Fix Released
Tom Haddon (mthaddon) on 2015-01-30
Changed in desktopcouch:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers