some python modules have a shebang line

Bug #486797 reported by Thomas Vander Stichele on 2009-11-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
desktopcouch
Low
Chad Miller

Bug Description

python-desktopcouch.noarch: E: non-executable-script /usr/lib/python2.6/site-packages/desktopcouch/stop_local_couchdb.py 0644 /usr/bin/python
python-desktopcouch.noarch: E: non-executable-script /usr/lib/python2.6/site-packages/desktopcouch/local_files.py 0644 /usr/bin/python
python-desktopcouch.noarch: E: non-executable-script /usr/lib/python2.6/site-packages/desktopcouch/start_local_couchdb.py 0644 /usr/bin/python

Related branches

These files should have the shebang line removed, or moved somewhere else outside of the python package dir.

Chad Miller (cmiller) wrote :

I think that is a bogus test. It isn't an error, and it's useful to have these as scripts before installation.

Changed in desktopcouch:
assignee: nobody → Chad Miller (cmiller)

I understand your argument. Following it through logically to its conclusion however you'd have to strip the shebang line at install time. I think we both agree that it's pointless to have shebanglines in 0644 files after installation.

I don't necessarily disagree with your opinion, however in my projects I've gone to following that guideline and only put shebang lines in things that will end up being scripts in the end. It seems most upstreams are following suit on this too.

In the end it's up to you to decide whether to change it :) If not I guess I'll have to maintain a patch set just for that for the rpm packages.

On Mon, 2009-11-23 at 18:13 +0000, Chad Miller wrote:
> I think that is a bogus test. It isn't an error, and it's useful to
> have these as scripts before installation.

Debian does the check too; the reasoning is that if things are scripts,
they should be in /usr/bin or in a /usr/lib/package/ dir. If they aren't
scripts, they don't need shebangs.

-Rob

Chad Miller (cmiller) on 2009-11-24
Changed in desktopcouch:
importance: Undecided → Low
status: New → Confirmed
Chad Miller (cmiller) on 2009-12-14
Changed in desktopcouch:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers