dbus code calls None, reference lost?

Bug #440072 reported by Guillermo Gonzalez on 2009-10-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
desktopcouch
High
Chad Miller
desktopcouch (Ubuntu)
Undecided
Unassigned

Bug Description

Just after the last step in the pairing desktopcouch-service crashed with:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 576, in msg_reply_handler
    reply_handler(*message.get_args_list(**get_args_opts))
  File "/usr/lib/python2.6/dist-packages/desktopcouch/pair/couchdb_pairing/dbus_io.py", line 238, in handle_resolved
    host, port, text.get("version", None))
TypeError: 'NoneType' object is not callable
2009-10-01 13:25:32,053 - Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/pair/couchdb_pairing/dbus_io.py", line 223, in remove_item_handler
    del_commport_name_cb(name)
TypeError: 'NoneType' object is not callable

Related branches

Guillermo Gonzalez (verterok) wrote :
Chad Miller (cmiller) on 2009-10-01
Changed in desktopcouch:
status: New → In Progress
assignee: nobody → Chad Miller (cmiller)
importance: Undecided → High
summary: - Error during pairing
+ dbus code calls None, reference lost?
Chad Miller (cmiller) on 2009-10-01
Changed in desktopcouch:
status: In Progress → Fix Committed
milestone: none → w25-karmic-finalfreeze
Matt Griffin (mattgriffin) wrote :

Chad - Is this the cause of desktopcouch crashing on me so much lately (running latest 9.10)?

Matt Griffin (mattgriffin) wrote :

sorry... meant 'desktopcouch-service' ... closed unexpectedly.

Chad Miller (cmiller) on 2009-10-19
Changed in desktopcouch:
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2009-10-23
Changed in desktopcouch (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktopcouch - 0.5-0ubuntu1

---------------
desktopcouch (0.5-0ubuntu1) karmic; urgency=low

  * New upstream release.
    + Fix remote-db-listing bug for SSL/HTTPS services. (LP: #458540)
    + Fix OAuth signatures for SSL urls.
    + Avoid couchdb bug where users' PID files are incorrectly interpreted as
      valid by couchdb, and so after slightly different boot, desktopcouch can
      never start couchdb, causing desktopcouch to quit. (LP: #442120)
    + For dbus, do not resolve data for events signaling a service disappears,
      and use explicit veriable-passing / references. (LP: #440072)
    + Flip push/pull logic in replication information.
    + When pulling from remote DB, do not try to access remote management DB.
    + Use meaningful names for keyring access. (LP: #451333)

 -- Chad MILLER <email address hidden> Thu, 22 Oct 2009 17:15:57 -0400

Changed in desktopcouch (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers