Cannot view a zone in dashboard - 404 errors

Bug #1715417 reported by James McCarthy
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Designate Dashboard
Undecided
Dr. Jens Harbott
Ubuntu Cloud Archive
Undecided
Unassigned
Pike
Medium
Unassigned
designate-dashboard (Ubuntu)
Undecided
Unassigned
Artful
Medium
Unassigned

Bug Description

[Impact]
See original bug description.

[Test Case]
See original bug description.

[Regression Potential]
This bug is fixed in a stable upstream point release and therefore should have minimal regression potential.

[Original Bug Description]

In horizon, with the dashboard enabled, attempts to view a defined zone fail with a 404 not found error. (The zone is there/working via cli and is itself working fine)

To reproduce:

Define a zone:
$ openstack zone create --email <email address hidden> sample.openstack.org.
+----------------+--------------------------------------+
| Field | Value |
+----------------+--------------------------------------+
| action | CREATE |
| attributes | |
| created_at | 2017-09-06T14:51:13.000000 |
| description | None |
| email | <email address hidden> |
| id | abc4daf4-0d3c-47c9-a902-4e58edc83754 |
| masters | |
| name | sample.openstack.org. |
| pool_id | c723bae4-c5de-46ea-9ff4-bc0d634cb9c5 |
| project_id | be99d8a5af314b89a664e263cef2876e |
| serial | 1504709472 |
| status | PENDING |
| transferred_at | None |
| ttl | 3600 |
| type | PRIMARY |
| updated_at | None |
| version | 1 |
+----------------+--------------------------------------+
$

$ openstack zone list
+--------------------------------------+-----------------------+---------+------------+--------+--------+
| id | name | type | serial | status | action |
+--------------------------------------+-----------------------+---------+------------+--------+--------+
| abc4daf4-0d3c-47c9-a902-4e58edc83754 | sample.openstack.org. | PRIMARY | 1504709472 | ACTIVE | NONE |
+--------------------------------------+-----------------------+---------+------------+--------+--------+
$

In horizon:

login and navigate to Project --> DNS --> Zones --> sample.openstack.org.

Brings you here: http://10.196.222.50/project/ngdetails/OS::Designate::Zone/abc4daf4-0d3c-47c9-a902-4e58edc83754

The resulting 404 error page is like so:

Page not found (404)
Request Method: GET
Request URL: http://10.196.222.50/project/ngdetails/OS::Designate::Zone/abc4daf4-0d3c-47c9-a902-4e58edc83754

Using the URLconf defined in openstack_dashboard.urls, Django tried these URL patterns, in this order:

    ^$ [name='splash']
    ^api/
    ^home/$ [name='user_home']
    ^i18n/js/(?P<packages>\S+?)/$ [name='jsi18n']
    ^i18n/setlang/$ [name='set_language']
    ^i18n/
    ^jasmine-legacy/$ [name='jasmine_tests']
    ^jasmine/.*?$
    ^admin/
    ^settings/
    ^app-catalog/
    ^identity/
    ^project/ ^cgroups/
    ^project/ ^stacks/template_versions/
    ^project/ ^routers/
    ^project/ ^images/
    ^project/ ^api_access/
    ^project/ ^containers/
    ^project/ ^networks/
    ^project/ ^snapshots/
    ^project/ ^dnszones/
    ^project/ ^volumes/
    ^project/ ^stacks/
    ^project/ ^cg_snapshots/
    ^project/ ^reverse_dns/
    ^project/ ^network_topology/
    ^project/ ^trunks/
    ^project/ ^security_groups/
    ^project/ ^network_qos/
    ^project/ ^key_pairs/
    ^project/ ^instances/
    ^project/ ^floating_ips/
    ^project/ ^backups/
    ^project/ ^stacks/resource_types/
    ^project/ ^$ [name='index']
    ^project/ ^warning$ [name='warning']
    ^auth/
    ^static\/(?P<path>.*)$
    ^media\/(?P<path>.*)$
    ^500/$

The current path, project/ngdetails/OS::Designate::Zone/abc4daf4-0d3c-47c9-a902-4e58edc83754, didn't match any of these.

You're seeing this error because you have DEBUG = True in your Django settings file. Change that to False, and Django will display a standard 404 page.

Revision history for this message
Dr. Jens Harbott (j-harbott) wrote :

Fixed by https://review.openstack.org/502481 , not sure why this bug didn't get updated automatically.

Changed in designate-dashboard:
assignee: nobody → Dr. Jens Harbott (j-harbott)
status: New → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/designate-dashboard 6.0.0.0b1

This issue was fixed in the openstack/designate-dashboard 6.0.0.0b1 development milestone.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/designate-dashboard 5.0.1

This issue was fixed in the openstack/designate-dashboard 5.0.1 release.

Revision history for this message
Dan Nica (ndanl) wrote :

when is it going to be available for pike on ubuntu xenial ?

Changed in cloud-archive:
status: New → Triaged
Changed in designate-dashboard (Ubuntu):
status: New → Triaged
Changed in cloud-archive:
importance: Undecided → Medium
Changed in designate-dashboard (Ubuntu):
importance: Undecided → Medium
Changed in designate-dashboard (Ubuntu Artful):
status: New → Triaged
Changed in designate-dashboard (Ubuntu):
status: Triaged → Invalid
Changed in cloud-archive:
status: Triaged → Invalid
Changed in designate-dashboard (Ubuntu Artful):
importance: Undecided → Medium
Changed in designate-dashboard (Ubuntu):
importance: Medium → Undecided
Changed in cloud-archive:
importance: Medium → Undecided
Revision history for this message
Corey Bryant (corey.bryant) wrote :

Ubuntu SRU details:

[Impact]
See bug description.

[Test Case]
See bug description.

[Regression Potential]
This bug is fixed in a stable upstream point release and therefore should have minimal regression potential.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

I've uploaded version 5.0.1 of designate-dashboard to the Artful (Pike) unapproved queue where it is awaiting Ubuntu stable release team review: https://launchpad.net/ubuntu/artful/+queue?queue_state=1&queue_text=

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello James, or anyone else affected,

Accepted designate-dashboard into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/designate-dashboard/5.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in designate-dashboard (Ubuntu Artful):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-artful
Revision history for this message
Corey Bryant (corey.bryant) wrote :

Hello James, or anyone else affected,

Accepted designate-dashboard into pike-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:pike-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-pike-needed to verification-pike-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-pike-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-pike-needed
Revision history for this message
Mitchell Kennedy (alphatech1) wrote :

This fixed worked for me using 5.0.1, thank you.

tags: added: verification-done-artful
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package designate-dashboard - 5.0.1-0ubuntu1

---------------
designate-dashboard (5.0.1-0ubuntu1) artful; urgency=medium

  * d/gbp.conf: Create stable/pike branch.
  * New stable point release for OpenStack Pike (LP: #1715417).

 -- Corey Bryant <email address hidden> Fri, 12 Jan 2018 10:07:26 -0500

Changed in designate-dashboard (Ubuntu Artful):
status: Fix Committed → Fix Released
Revision history for this message
Dr. Jens Harbott (j-harbott) wrote :

Verified on Pike deployment.

tags: added: verification-done verification-pike-done
removed: verification-needed verification-needed-artful verification-pike-needed
Revision history for this message
James Page (james-page) wrote : Update Released

The verification of the Stable Release Update for designate-dashboard has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
James Page (james-page) wrote :

This bug was fixed in the package designate-dashboard - 5.0.1-0ubuntu1~cloud0
---------------

 designate-dashboard (5.0.1-0ubuntu1~cloud0) xenial-pike; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 designate-dashboard (5.0.1-0ubuntu1) artful; urgency=medium
 .
   * d/gbp.conf: Create stable/pike branch.
   * New stable point release for OpenStack Pike (LP: #1715417).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers