[Dell Inc. Latitude E5470] suspend/resume failure

Bug #1661741 reported by Jonathan Ganc on 2017-02-03
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Dell Sputnik
High
Unassigned

Bug Description

To generate the crash:
1) Suspend the system (e.g. choose suspend from the top menu).
2) At any point, unplug the cord (the bug happens if I unplug at any point after suspend, even if I then replug before I resume)
3) Try to resume (pressing power button). Computer reboots.

What should happen: Regular resume from suspend.

(If I leave the computer plugged in, resume works fine.)

I have performed the tests at https://wiki.ubuntu.com/DebuggingKernelSuspend and included the results. Note that the computer never crashes during any of the tests except when /sys/power/pm_test is 'none'.

This appears the same/similar to #bug #1645758 but I dont't know how to add to the apport info to that bug instead of filing my own.

ProblemType: KernelOops
DistroRelease: Ubuntu 16.10
Package: linux-image-4.8.0-37-generic 4.8.0-37.39
ProcVersionSignature: Ubuntu 4.8.0-37.39-generic 4.8.16
Uname: Linux 4.8.0-37-generic x86_64
Annotation: This occurred during a previous suspend, and prevented the system from resuming properly.
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ganc 2892 F.... pulseaudio
Date: Thu Dec 22 07:09:27 2016
DuplicateSignature: suspend/resume:Dell Inc. Latitude E5470:1.11.4
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: suspend/resume
HibernationDevice: RESUME=UUID=a7e5c256-744c-41e6-823b-befb5f5c63f6
InstallationDate: Installed on 2017-01-31 (-39 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
InterpreterPath: /usr/bin/python3.5
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 002: ID 8087:0a2b Intel Corp.
 Bus 001 Device 004: ID 0bda:5686 Realtek Semiconductor Corp.
 Bus 001 Device 003: ID 0a5c:5832 Broadcom Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Latitude E5470
ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-37-generic.efi.signed root=UUID=1eb743a3-00e0-430e-be35-9748390e53f3 ro quiet splash vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-4.8.0-37-generic N/A
 linux-backports-modules-4.8.0-37-generic N/A
 linux-firmware 1.161.1
SourcePackage: linux
Title: [Dell Inc. Latitude E5470] suspend/resume failure
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 12/22/2016
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.11.4
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.11.4:bd12/22/2016:svnDellInc.:pnLatitudeE5470:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E5470
dmi.sys.vendor: Dell Inc.

Jonathan Ganc (jonganc) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: removed: need-duplicate-check
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.10 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.10-rc7

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
Jonathan Ganc (jonganc) wrote :

So, a strange thing happened. In order to mitigate the problem, I decided to switch to having the computer hibernate instead of suspend (I outline below the steps I did to do that). And then, on a whim, I tried suspending again. And it stopped crashing, even after I switched back to suspend completely. I didn't do any software updates or, as far as I know, anything else in the interim. So right now, I have my computer set to suspend and it seems to work fine. I was waiting a few days to see if the problem reemered but right now, I can't reproduce it at all.

For your edification (and maybe for other people), here were the steps I followed:

$ gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'hibernate'
$ gsettings set org.gnome.settings-daemon.plugins.power \
      lid-close-ac-action 'hibernate' \
     && gsettings set org.gnome.settings-daemon.plugins.power \
      lid-close-battery-action 'hibernate'

- In /etc/systemd/logind.conf, make sure '#HandleLidSwitch=suspend' is commented out, and add HandleLidSwitch=hibernate

- And then I saved the attached file to /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

To switch back, I reran the shell commands with 'suspend' instead of hibernate and then removed the changes to the config files.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Jan Klesnil (klesnil) wrote :

I have received brand new Dell Latitude E7470 with preinstalled Windows. I have reinstalled the system with Ubuntu 16.04.2 from flash, formatting the entire hard drive along the way.

I have experienced the same problem. When suspended on power and waked up on power it worked. When I unplugged the power cable while suspended it rebooted. When suspended on battery it always rebooted.

I have enabled hibernate as described above. Hibernated several times by different means (lid, menu button, shell command) in different states (powered, on battery, plugged and unplugged cable while hibernated) and suspend works now.

Jonathan Ganc (jonganc) wrote :

Weird, right? I'm fairly content with my Dell but I think there are some Linux-related BIOS issues. I'm glad that 1) this fixed your suspend issues, 2) that I'm now sure that I'm not crazy.

Changed in linux (Ubuntu):
status: Expired → Confirmed
Bas Zoetekouw (baszoetekouw) wrote :

Recently, my Dell E7470 started showing the same symptoms: resume works fine, but when waking from resume, it reboots instead of waking up. pm_trace show only a hah match on ACPI device 0d, quite like it does for the original reporter.

The weird thing is, that all of this used to work fine. The problem started after I had hibernated and had the computer turned off for a few days. So it does seem there is some kind of link between hubernate and suspend issues here.

Bas Zoetekouw (baszoetekouw) wrote :

Ok, and like Jan, I managed to fixed things by one hibernation cycle with power plugged in, and one with no power connected.

So it almost sounds like some weird bug in the laptop's acpi or bios or so, and I don't think this is an issues with Linux or Ubuntu.

Jonathan Ganc (jonganc) wrote :

There are definitely at least *some* BIOS problems with the 5470. For example, it seems to have clock speed issues (where the CPU clock speed will stay between 400 MHz - 800 MHz) which I have to resolve using either `wrmsr -a 0x19a 0x0` or `cpupower frequency-set -g performance` or both.

Kai-Heng Feng (kaihengfeng) wrote :

Can you try mainline kernel in comment #3?

Jonathan Ganc (jonganc) wrote :

I will try when I get a chance but I am busy for at least a few days and this is my main computer so I can't afford to muck around with it too carelessly.

Sebastian Sardina (ssardina) wrote :

So, I have a Dell Lattitude E7470 that had the very same problem.

Running Linux Mint 18.1 with kernel linux-image-4.4.0-78-generic and BIOS 1.13.4

I installed kernel linux-image-4.11.0-041100-generic and still the problem is there.

However, after I upgraded to BIOS 1.15.4, I can suspend well with 4.11 kernel but NOT with 4.4.0 (which works sometimes and sometimes it does not).

Hope that helps. I ahve already suspended 5 times with the new BIOS and kernel 4.11 and all good. finger crossed.

See we are talking about different models and BIOS, but Jonathan may be right that there is something nasty wrt BIOS.

Marcin Szałowicz (lolek) wrote :

I can confirm that suspend works properly with Bios 1.15.4 but it's again broken with 1.17.3 :(

Jonathan Ganc (jonganc) wrote :

Which version of Ubuntu are you using? Did you try the magical incantation I listed in my initial post? I am currently using 16.04. There was a few days (maybe 2 or 3 weeks ago) when the problem reappeared but it disappeared again. I thought it might have been related to a new kernel version but I didn't get a chance to try the newest mainline kernel before it went away.
If my instructions don't help, I'd suggest trying the newest kernel to see if that helps.

affects: linux (Ubuntu) → dell-sputnik
Marcin Szałowicz (lolek) wrote :

Jonathan,
let me add more info.
The issue could be seen on kernels: 4.4, 4.11, 4.13.
Then I've tested your idea and in fact it heklped i.e. it works now.

What I've noticed also that the suspend was working fine when the laptop was in the docking station, as soon as I took it out, suspend wasn't working properly.

aularon (aularon) wrote :

I was able to resolve this by updating the ssd firmware (SK Hynix SC300 M.2) from here: https://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=754Y5
The update page states: **Fixes an issue which can cause the SSD to occasionally not wake up from low power mode**

I updated it few days ago and has been suspending and resuming normally since then (It happens that I upgraded kernel as well in my archlinux, but it is mostly the updated firmware)

Hope it resolves the issue for you as well

Kai-Heng Feng (kaihengfeng) wrote :

Do all affected users use SK Hynix SC300 M.2?

Jonathan Ganc (jonganc) wrote :

I have a Samsung 960 EVO MZ. So a different SSD, at least. I never thought to update the SSD firmware.

dewoller (dewoller) wrote :

This has affected me. I have a latitude e7470, and have found this exact suspend/resume problem with a range of kernels, currently 4.13.0-41-generic

bios version 1.18.5,
SSD LITEON CV3-8D512-11 SATA 512GB.

Dell mentions that this SSD has a similar problem "LiteOn CV3 Solid-State Drive (SSD) May Not Be Detected in Your System" (http://www.dell.com/support/article/au/en/audhs1/sln304028/liteon-cv3-solid-state-drive-ssd-may-not-be-detected-in-your-system?lang=en). The solution is to update firmware, to Firmware Revision: T89110D but my SSD already has this version.

kralisec (kralisec) wrote :

Exactly the same for me : E5470, with 4.15.0-30 and 3 month previous kernel
with lvm inside cryptsetup partition

Bios version: 1.18.6, EFI not secure mode, without legacy
latest intel ME update
SSD : Crucial MX100 CT512MX100SSD1 SATA 512GB with MU03 firmware

I discover this problem 3 month ago, it took me time before I link the problem to power cable,
suspend works only if power cable is not remove, even suspend battery only is not working.

I test 2 Dell idea: enable usb wake support and disable block sleep (C3 state) but no luck

I try post #4 solution: swap size is smaller than memory size so hibernate never works for me,
after removing all #4 change now suspend works without power cable

Thank you Jonathan

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers