Ubuntu frequently freezes

Bug #1167624 reported by beerfan on 2013-04-10
126
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Dell Sputnik
Undecided
Unassigned

Bug Description

I have a sputnik laptop running the OEM install of Ubuntu 12.04. I've only applied the normal Ubuntu package updates and have no changed anything significant that I can think of. I've had the laptop less than a week.

At least once a day Ubuntu will completely freeze. There doesn't seem to be much pattern for when it will happen. The display just freezes, along with the mouse pointer. Switching to another console doesn't work and the OS never responds.

I don't know how to troubleshoot this or what type of log output might be desired but can provide anything requested.

Kent Baxley (kentb) wrote :

If this is a factory-preloaded system I also suggest opening an issue with Dell. You should have had 1 year of ProSupport included with the system. Random freezes haven't been commonly reported with this system and you may have a hardware problem.

That said, I can also point you to a diagnostic tool that will capture everything about your system. You can attach that report here.

To install and run the tool, please do the following:

sudo add-apt-repository ppa:debugmonkeys/sosreport
sudo apt-get update
sudo apt-get install sos

Then run 'sudo sos' from the command line and follow the prompts.

Changed in dell-sputnik:
status: New → Incomplete
epervieror (epervieror) wrote :

I have exactly the same problem.

Kent Baxley (kentb) wrote :

If you are also experiencing the same problem then please also contact Dell ProSupport if your system has been preloaded, as freezes have (so far) not been widely reported and we cannot reproduce the problems with hardware in our labs.

Louis Bouchard (louis) wrote :

FYI the most recent version of sosreport with many plugins now enabled for Ubuntu/Debian can be found here :

sudo add-apt-repository ppa:canonical-support/support-tools
sudo apt-get update
sudo apt-get install sosreport

Please note the modification of the package name which is now sosreport to comply with Debian's Intent to Package (ITP)

beerfan (beerfan) wrote :

I ran the sosreport as suggested but then didn't experience any freezes for some time. Recently last 2 days it has started again. Once I was in Gimp and the next time I was just surfing with Chromium. I've upgraded to 12.10 last night so will see if the freezes continue to occur.

epervieror (epervieror) wrote :

@kentb Dell redirected me to Canonical..

These freezes are still present with kernel 3.2.0-40 (and below) and 3.5.0-28.

When freezing, I was listening music with Spotify in the browser and it didn't stop when the screen froze.

Audio still running, I suppose Wifi too.
With fn touch, I can turn on/off keyboard backlight and adjust luminosity for the screen.

And that's it.

@beerfan does it happen indifferently surfing with your mouse or with the trackpad ? (I have some doubt)

1 comments hidden view all 118 comments
epervieror (epervieror) wrote :

I have the "second" serie of this dell XPS 13 developer edition: L322X (the previous one was L321X)

Louis Bouchard (louis) wrote :

@epervieror

After looking at the sosreport output, it looks like you are one BIOS version behind :

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
        Vendor: Dell Inc.
        Version: A07
        Release Date: 01/22/2013

Here is the reference to the latest BIOS : http://goo.gl/iE1ep

This may not be a solution, but it might be better to upgrade to the latest BIOS before investigating any further

epervieror (epervieror) wrote :

Thanks, as this one was published recently (25/04/2013) I didn't saw it.

I'm doing the upgrade and will let you know if freezes are still present.

epervieror (epervieror) wrote :

After the upgrade to the BIOS A08, still freezing ...

$ sudo dmidecode | grep -A 20 BIOS\ Information

BIOS Information
 Vendor: Dell Inc.
 Version: A08
 Release Date: 04/18/2013
 Address: 0xE0000
 Runtime Size: 128 kB
 ROM Size: 6656 kB

epervieror (epervieror) on 2013-05-03
Changed in dell-sputnik:
status: Incomplete → Confirmed
1 comments hidden view all 118 comments
epervieror (epervieror) wrote :

Also when freezing, sometimes I am losing open files ...

Kent Baxley (kentb) wrote :

I still *cannot* reproduce any freezes on my system even with A08. I've been running it for several hours at a time doing various tasks (browsing, streaming video, etc.) and not had any problems. Is there any specific steps that seem to reproduce the problem for those affected?

@epervieror
Did Dell support give any specific reason as to referring you to launchpad?

Kent Baxley (kentb) wrote :

Also, does the freeze occur any time you run the Spotify client? I see that you have it installed, and there seem to be numerous reports out there of that software freezing desktops:

http://xeizo.com/blogg/?p=528
http://ubuntuforums.org/showthread.php?t=2104226
http://community.spotify.com/t5/Help-Desktop-Linux-Mac-and/Bug-Spotify-freezes-desktop-if-I-search-and-select-a-new-artist/td-p/87421/page/2

beerfan (beerfan) wrote :

I do not use spotify, for what it's worth. I also haven't noticed a pattern for reproducing the freeze.

epervieror (epervieror) wrote :

@Kent
About Dell, after calling and running all their diagnostics tests with success, they said me to call Canonical. And as there was already a similar bug opened I added me to it.
(By buying a Dell XPS with Linux I was thinking to have a Dell support for it ... but it appears this is not exactly how things work)

The freeze occur at any time (2-3/week) independently of the software running (I have always google chome running and also RubyMine most of the time, as I don't use often Spotify it never happened with it), anyways this is not a software freeze, this is more a "system" freeze. I can't confirm but it seems freeze occur often after at least 4-5 or more hours of running (laptop started at 10 a.m and freeze at 18 p.m) but this is not always the case.
The laptop is running almost 12h/day during the week.

I have a colleague with the same laptop and same freezes problem. He just updated to 13.04 so we will see in 1 week if freezes disappeared.

epervieror (epervieror) wrote :

@Kent is there a way to get debug information after this kind of freeze ?

epervieror (epervieror) wrote :
Eryn O'Neil (eryn-oneil) wrote :

I also experience these hard freezes, always have. I can't recreate them at will.

If it freezes while I'm watching video or listening to audio, the audio does NOT continue normally. It repeats and skips continually at the spot it left off at.

It might be related to heavy video card use; I feel like I see it more often when I'm watching Netflix or switching desktops (it freezes halfway between desktops sometimes).

I think it's only happened after the computer has been put to sleep and awoken at least once, but honestly, I fully shut down my computer so rarely that this might be coincidence.

Eryn O'Neil (eryn-oneil) wrote :

Should have said, I also have the Dell XPS 13, Project Sputnik, shipped with 12.04 (and still running it). Fully updated, but original BIOS (A02).

Daniel Naber (misc2006) wrote :

Same here, new edition (the one with the better display), BIOS A07, freezes about once a week, in one case the sound looped. No significant changes done to the default installation.

Kent Baxley (kentb) wrote :

Thanks everyone for their input. It sounds as if it can be reproduced when doing some multimedia activity (heavy video playback and / or audio). That's starting to look like a common denominator as of late.

I know it seems to be random for folks, but, does there appear to be any average amount of time or activity that seems to trigger this more than others (i.e. how long into listening to audio / watching video) does it happen? Does the CPU fan start revving up at all or does the system get warmer than usual when this happens? I'll also try to replicate this using suspend / resume, etc. The XPSes I have don't lock up on me (yet) after quite a bit of use, but, I'm willing to try and mimic some of you guys' behaviors to see if I can get the same things to happen.

@epervieror: If you have more than one system available, setting up a netconsole would be a good tool to try and catch something from the system: https://wiki.ubuntu.com/Kernel/Netconsole
The REISUB recommendation from the forums is also a good idea to try and un-wedge the system when it gets in this state.

I know at least one of you have run through hardware diags with Dell and not found anything, but, I'd also be curious to see what the following tests yield on some of your systems out there (run the CPU burn test at your own risk as I wouldn't want anyone to fry their machines): https://help.ubuntu.com/community/FaultyHardware

Thanks!

Daniel Naber (misc2006) wrote :

@kentb: actually most of the crashes I had so far did *not* involve sound or video, just normal websurfing/email/office activity. Some crashes happened after hours, others a few minutes after booting the system. The maximum time between crashes for me was about 10 days, i.e. it is really difficult to reproduce.

The memory test did not find an error. The disk test says "SMART overall-health self-assessment test result: PASSED" (let me know if you need the full output).

I don't know what might be different about my system that makes it unstable... just some facts: I never use suspend but always power down the system at night. I use an external keyboard, mouse, and monitor. I use wireless (no LAN over USB).

Eryn O'Neil (eryn-oneil) wrote :

I'm working from memory, but I know that during some freezes, the machine has been pretty hot and the fan has been running at full speed. It felt those times like the freeze happened at the same time the fan hit full speed, but I can't be sure.

I don't have to be watching video or listening to audio for it to happen, but it definitely seems to exacerbate it. I can go for weeks with no lockup, and then have it happen twice during the same Netflix binge session. (However, I frequently watch hours of streaming video without freezes, too.)

I haven't noticed a pattern about how long I have to be watching before it happens.

(If you want to mimic, this is how I'm watching Netflix: http://www.jeremymorgan.com/tutorials/linux/how-to-netflix-ubuntu-linux/)

Brendan Miller (brmiller) wrote :

Just received an XPS 13 Developer Edition 4 days ago and started experiencing random lockups as well. Unfortunately, I have installed/uninstalled quite a few packages from the factory Dell Ubuntu 12.04 load to support my workflow. This is used as a development machine, lots of heavy Java compiles, jetty servers, mysql servers, etc. Running IntelliJ most and chromium most of the time. My suspicion too was that it was getting taxed and locking up as a result of heat issues, but I have been attempting to reproduce tonight and cannot. I'll collect more data as I can, but wanted to communicate the "me too" facet. No audio/video playback involved in my workflows, either, btw.

Kent Baxley (kentb) wrote :

Thanks, all, for the information on what you're running into. I've got the FHD model for a few more days and I've also got the original HD model on a more permanent basis. I'll see if I can cause the systems to lock up at all. If anyone has the ability to remote into their systems via ssh (for example) and maybe fire up "top" and then perform some of the activity that seems to cause the system to seize up, then maybe we can get an idea of whether or not there's something eating up CPU, etc. Thanks, again.

Kent Baxley (kentb) wrote :

I'm currently putting an XPS 13 through various paces (stress CPU, memory, etc) as well as trying to reproduce with some of what you guys were doing when the system froze (streaming music, video, etc). So far nothing's frozen up on me. I'm also going to use this system as a 'daily driver' for a few days to see if any lockups occur.

Brendan Miller (brmiller) wrote :

Try building some huge Java project (hit me up if you need an example), perhaps through IntelliJ. This seems to be the one consistency for *my* lockups. Had another one this morning, spoke to Dell support, and updated BIOS to A08 as a result. Dell's Ubuntu team will be contacting me in the next day for further troubleshooting/diagnostics. The jury is still out.

Eryn O'Neil (eryn-oneil) wrote :

Experienced another lockup last night. Was watching Netflix for about 15 minutes, then paused it (leaving the window open) and worked in other windows for at least an hour. Was typing in a form on a webpage when the computer locked up.

Computer got hot really quickly while watching Netflix and never really cooled down. Was very warm and the fan was running loudly when it locked up.

Kent Baxley (kentb) wrote :

@Brendan, I'd be interested in trying your java build test. Please send me a info on that to my Canonical email (you'll find it in my launchpad profile) and I'll try and take a look at it this week. Thanks!

Dave Tapley (dukedave) wrote :

+1 on this, I see a running theme of Spotify mentions, and I'm also running it.
Since updating to the latest Spotify client I'm now getting a hard lock once every few hours :(

Jorge Danoz (jorge-danoz) wrote :

Hi

Same problem.

A07 BIOS.
Machine ordered about one month ago (L322X model).

BIOS info:

BIOS Information
 Vendor: Dell Inc.
 Version: A07
 Release Date: 01/22/2013
 Address: 0xE0000
 Runtime Size: 128 kB
 ROM Size: 6656 kB

Only the updates suggested via the Update Manager, no any other change to the SO.
I don't know what can be the cause, maybe a kernel upgrade.

The current kernel I have installed: 3.2.0-41-generic #66+kamal16~DellXPS

The mine got frozen using Chromium.
Today other freeze just 30 seconds after the startup (cold startup).

Regards

Jorge Danoz (jorge-danoz) wrote :

Hello,

I can discard a cpu hardware defect. I installed cpuburn (burnP6) and ran it for almost two or three minutes in the four cores at the same time (four processes running).

Fan started to go at max. speed.
No freezes.

So I discarded a cpu problem.

It should be a graphics problem (hardware or driver) or kernel a bug.

Regards

Jorge Danoz (jorge-danoz) wrote :

"or a kernel bug" (just a mistake typing).

epervieror (epervieror) wrote :

I tried ALT+PrtScr/Fn+PrtScr and REISUB/RSEINUB but nothing happened.

Kent Baxley (kentb) wrote :

Does anyone have capacity to set up a netconsole, especially if you are one of the unlucky ones where the system is freezing up pretty regularly? Plus, at the minimum, if anyone can also ssh in remotely from another system and have the following commands running in remote consoles:

top

tail -f /var/log/kern.log

tail -f /var/log/syslog

...that might help us try and nail any possible OS culprits.

Jorge Danoz (jorge-danoz) wrote :

I'm suspecting that is an overheat issue.

I'm not sure, but I suspect that the freezes are caused when you tap/cover the ventilation area under the system, specially the fan area.

I can't confirm. I only had two or three freezes. This week only one, but it happened when I started the system over my legs (and I think covering unintentionally the ventilation area.

Could anyone confirm/check this?

Regards

Jorge Danoz (jorge-danoz) wrote :

For more information about my case: the three freezes happened when I was using Chromium browser and watching music or viewing videos in YouTube.

Daniel Naber (misc2006) wrote :

@jorge-danoz I cannot confirm this. The system was on my desk with any of the freezes. Also, some freezes happen soon after boot, when there should not be much heat yet.

38 comments hidden view all 118 comments
Bill Scoby (co9olguy) wrote :

I just want to reiterate that I do not use Chrome/Chromium, but I am still getting this freezing bug (even once at the login screen!).

Like epervieror, I suspect it is probably a system bug and not (directly) related to any individual piece of software...

Brendan Miller (brmiller) wrote :

I'd like to "bump" the comment I made in #70 about upgrading to the 3.5 kernel series. I really think the bug may be in the special sputnik kernel (which is somewhat ironic). At least, if you do experience hangs, please include what kernel version (uname -r) you're using. This will help the kernel/Canonical people.

kernel change didn't help for me:
- Yesterday, I updated the kernel to use the linux-image-3.2.0-48-generic 3.2.0-48.74
- I WAS using the +kamal16~DellXPS
- just got a freeze with the new kernel.

I'm currently trying the BIOS update A09 (I was using the A07 previously).

I'll try the quantal kernel version if it doesn't work

Brendan Miller (brmiller) wrote :

Yes, try the linux-generic-lts-quantal package - that's the one that I enjoyed success with.

wroscoe (wroscoe) wrote :

Also having the same issue. Most often happens using Google hangout on chromium.

Kernal: 3.2.0-48-generic

linux-image-3.2.0-48-generic 3.2.0-48.74 + A09 bios update => Freeze

I've installed the linux-image-generic-lts-quantal package and have now this kernel version: linux-image-3.5.0-34-generic 3.5.0-34.55~precise1
2 days without any freeze so far,

Thanks for the tip

Flyte (o-launchpad-net) wrote :

I got my XPS Dev Edition 1080p yesterday and had two lockups. Both were while watching a streaming video on twitch.tv with Chrome and chatting on TeamSpeak. All four cores were sitting around 50% at the time (no hardware decoding of video streams?) so the fan was loud anyway.

The laptop was sitting on a laptop stand with about 7 inches of clear space beneath it (the stand consists of two 1.5" wide surfaces, so it doesn't block airflow).

I'm running BIOS version A09 and had the system fully apt-get upgraded.

Timo Ewalds (timo-ewalds) wrote :

I had crashing problems for months, with uptimes as short as a few minutes but never more than a couple days. I happened to be browsing the net most times, but there wasn't any good pattern. Based on suggestions above I upgraded my kernel to: 3.10.0-031000rc6-generic from http://kernel.ubuntu.com/~kernel-ppa/mainline/ , and have gone almost two weeks without a single crash. The only problem with this kernel is the backlight doesn't work properly out of the box, but can be fixed with: echo 0 > /sys/class/backlight/intel_backlight/brightness . This is annoying, but at least it no longer crashes. Does anyone know of a kernel version that works perfectly?

Timo: The suggestion was to use the standard 3.5 kernel version, not the 3.10

As far as i'm concerned, almost 2 weeks without any freeze :)

mattcole (mattcole3) wrote :

I'd like to chime in saying this happens to me, on a fully updated 12.04 system. It is a 2-3x per day occurrence at this point. I upgraded to the 3.5 kernel as suggested above and we'll see how this works.

Andrew Bradley (arbradley1967) wrote :

I've narrowed this down. All of the times that this happens for me is when I have Chrome open, and I receive an incoming "+1" in Google Plus. Not every "+1" triggers this, so I suspect that there is a secondary part to the trigger; possibly switching tabs.

Dave Tapley (dukedave) wrote :

Andrew: Hmm, well now you mention it do *always* have GMail open in another tab in Chromium.
So it certainly not impossible that's a cause.

... I'm done with this, I'm back up to multiple freezes per day, time to try the kernel change.

Andrew Bradley (arbradley1967) wrote :

I've had no freezes for a couple of weeks now. Changes to the Chrome Stable channel, Ubuntu updates, or coincidence? Time will tell.

Eryn O'Neil (eryn-oneil) wrote :

Back to report: I have had hard freezes happen when I wasn't running Chromium. I even had one happen within a minute of rebooting the machine. There may be something about Chromium that makes freezes more likely, but it's definitely not the only way to trigger them.

Dell replaced my motherboard with an A09 bios version (most updated Sputnik bios) a couple weeks ago, and I've had fewer hard freezes since-- but they still happen.

Eryn: Are you sure Chromium isn't running at all? (c.f. http://askubuntu.com/questions/125357/chrome-puts-itself-on-startup-applications)

Eryn O'Neil (eryn-oneil) wrote :

Daniel Jared Dominguez: Interesting, I did not know that. I did have the "background apps" setting checked. So I can't be sure that it wasn't running.

I'm still skeptical that we can be sure it's Chromium causing the freezes-- yes, we all have it installed and use it, but I think you'd be hard-pressed to find someone who uses Linux to the point that they post bugs on launchpad and DOESN'T have Chromium installed. If that's the criteria, we could just as easily say it's caused by X, or Firefox, or bash, or Compiz (well, it might reasonably be caused by Compiz), or anything else everyone is likely to have installed.

However, Chromium could certainly could be the cause. I'm just trying to be cautious before we stop thinking outside the box. I've unchecked the background apps option (as well as the hardware acceleration setting-- my freezes have correlated with high processor and/or graphic card use, so it seemed like a reasonable thing to try), and I'll report back about my experience.

Eryn: (By the way, you can call me Jared.) I agree that, even if the problem is caused by Chromium/Chrome, the end goal isn't to tell you to stop using that browser but only to triage so we can isolate the bug. Also, I've lost track, which kernel version are you running? Have you tried upgrading to either the linux-image-generic-lts-raring or linux-image-generic-lts-quantal kernels (assuming you're still running Ubuntu 12.04)?

hi all, I had no freeze for a month but recently, i got freezes again ... not as often as before, but still ...
Once I tried to switch to console tty by pressing ctrl alt f1 and got these messages (picture i took + tesseract + hand fixes)
couldn't go back to X and make other switch:

Ubuntu 12.04.3 LTS xps tty1

xps login: [30104.389129] BUG: soft lockup - CPU#1 stuck for 22s! [gnome—settings
[30104.403381] BUG: soft lockup - CPU#2 stuck for 22s! [gdu-notificatio:2581]
[30104.417515] BUG: soft lockup - CPU#3 stuck for 22s! [gnome—fallback-:2169]
[3D104.558466] BUG: soft lockup - CPU#0 stuck for 23s! [console-kit—dae:1340]
[3D132.352914] BUG: soft lockup - CPU#1 stuck for 22s! [gnome-settings-:2142]
[30132.387168] BUG: soft lockup - CPU#2 stuck for 22s! [gdu-notificatio:2581]
[30132.381302] BUG: soft lockup - CPU#3 stuck for 22s! [gnome—fallback-:2169]
[30132.522255] BUG: soft lockup - CPU#0 stuck for 23s! [console-kit—dae:1340]
[30140.228272] INFO: rcu_sched self-detected stall on CPU { 2} (t=15000 jiffies)
[30164.311528] BUG: soft lockup - CPU#1 stuck for 22s! [gnome-settings-:2142]
[30164.32578E] BUG: soft lockup - CPU#2 stuck for 22s! [gdu-notificatio:2581]
[30164.339918] BUG: soft lockup - CPU#3 stuck for 22s! [gnome—fallback-:2169]
[30164.480869] BUG: soft lockup - CPU#0 stuck for 22s! [console-kit—dae:1340]

Sun: What is your kernel version?

Linux xps 3.5.0-39-generic #60~precise1-Ubuntu SMP Wed Aug 14 15:38:41 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I'm currently downgrading, got freezed so far with:
- 3.5.0-39-generic
- 3.5.0-38-generic

Currently testing with 3.5.0-37-generic

No freeze with
 3.5.0-37-generic

1 comments hidden view all 118 comments
Krzysztof P (qreesp) wrote :

3.5.0-37-generic - also freezes.

I've noticed that running the new OpenGL Google Maps on Chromium or starting up Virtual Box seem to cause my XPS 13 to freeze on Ubuntu 13.04.

Has anybody else noticed the same thing?

No, Adam. I haven't noticed about that

It will be interesting to know how many sputnik's users we are, and how many of us got freezes. We've tried many kernels and others workarounds but we still don't know what is the cause of freezes. It's possible to think about a hardware issue. Graphic card, maybe or motherboard, I don't know.

My freezes haven't any pattern. Using chrome or not, developing or not, streaming or not, high or low CPU rate. Using the laptop for hours or seconds.

One question, how many of us have the SSD encrypted? Could be a possibility...

1 comments hidden view all 118 comments
Krzysztof P (qreesp) wrote :

Tested on:
3.2.0-53-generic #81-Ubuntu SMP Thu Aug 22 21:01:03 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

and not working.

Daniel Naber (misc2006) wrote :

Everything went fine (i.e. not a single crash) for two months with this kernel: 3.5.0-36-generic #57~precise1-Ubuntu SMP

Now the crashes are back (two crashes in two days), current kernel: 3.5.0-40-generic #62~precise1-Ubuntu SMP

@Daniel García: my SSD is encrypted

epervieror (epervieror) wrote :

4 month with kernel 3.8 and all is working.

Ryan Riegel (rriegs) wrote :

I just wanted to add my two cents regarding this problem. In summary, I suspect the problem at hand is caused by the device running out of video memory, which in my case may be caused by using an external monitor. This leads to X crashing with no pathway for recovery. I've reduced the resolution of my external monitor and the crash seems to have been resolved. My observations are as follows:

I started experiencing crashes shortly after obtaining my XPS 13. I do not use nor have I installed Chrome/Chromium or Spotify, which seem to be the leading culprits above, but I do have an external monitor with equal resolution to the built-in screen (1920x1080). Otherwise, I have current updates, both 64-bit and 32-bit versions of both openjdk-6 and 7, and a handful of other tools I use for development such as emacs. I have not installed a more recent kernel (currently 3.2.0-53), nor have I updated the BIOS (though dmidecode reports it as A09).

The context of the first crashes I saw were situations where I ran out of *system* memory. While failure in this circumstance is understandable, the failure was complete: the mouse wouldn't move, I couldn't switch to other ttys, etc. Later, however, I noticed crashes occuring when the system shouldn't have been burdened. I installed indicator-multiload to keep an eye on my system memory and observed a crash (which conveniently froze the system monitor history) that occured at a time of minimal CPU usage, normal memory load, and no noticeable disk activity (at the time, I wasn't monitoring network, swap space, or "system load").

I observed several further similar crashes, some of which occured even when I was AFK, with no activity other than running remote tasks via ssh (and thankfully a remote screen). I mentioned the problem to my resident hardware expert and, after noticing X failures in my system log, his instinct was that I was running out of video memory. I don't have a means of monitoring video memory (any recommendations?), though with two 1920x1080 displays plus compiz (default installation plus compizconfig-settings-manager, with a few tweaks), firefox, and half a dozen terminal/emacs/etc. windows open this seemed at least plausible.

I've since reduced the resolution of my external monitor to 1440x900, and I've seen no further crashes. I would *like* to instead reduce the resolution of my laptop monitor, but it seems I cannot, at least not through Ubuntu system settings. Alternately, I wouldn't mind increasing the amount of system memory allocated to my Intel HD Graphics processor, but I cannot find any way to do so through the BIOS or otherwise. Right now it seems to be using around half a gigabyte (my system reports 640MB less than the 8GB it actually has); I'd be happy to let it use twice as much if it means I can run my external monitor at its full resolution.

Krzysztof P (qreesp) wrote :

Well, I experienced the crashes without attaching secondary monitor and there were no X errors in logs in my so i thinks it's not related to X server.

You can reduce laptop resolution this way (to 1600x900):

    # gtf 1600 900 60
   xrandr --newmode "1600x900" 119.00 1600 1696 1864 2128 900 901 904 932 -HSync +Vsync
   xrandr --addmode eDP1 1600x900
   xrandr --output eDP1 --mode 1600x900

But this solution is not permanent.

Anyway, currently testing kernel:

3.5.0-36-generic #57~precise1-Ubuntu SMP Thu Jun 20 18:21:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

No crashes for over a week.

Hi all,
Testing with Linux xps 3.5.0-41-generic -> no freeze so far

So to summarise my experience
OK 3.5.0-38-generic
KO 3.5.0-38-generic
KO 3.5.0-39-generic
OK 3.5.0-41-generic

sorry this is the right one:

OK 3.5.0-37-generic
KO 3.5.0-38-generic
KO 3.5.0-39-generic
OK 3.5.0-41-generic

Marcos (golodhros) wrote :

Hi there!

Thanks all for the support! I have suffered this bug for quite a while, but now everything works fine with:

3.8.0-31-generic #46~precise1-Ubuntu SMP Wed Sep 11 18:21:16 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Bill Scoby (co9olguy) wrote :

Got this freeze again today, but in a new twist, the hardware power switch was also completely unresponsive. The fan was going crazy, but I couldn't get the unit to shut off. I could still adjust the keyboard backlight and check the battery level using the external control, but otherwise the unit did not respond.

All I could do was unplug it and wait for the battery to run out. Once that happened, I plugged it back in and it started up again as if nothing was wrong (the external power switch works again).

If it helps a diagnosis, I had put the unit in suspend while I went to lunch. Not sure exactly when it happened, but it was frozen when I came back 30 mins later.

I get occasional crashes - every couple of weeks or so I guess

power button reset works for me

I use chromium and an external monitor

sean@sputnick:~$ xrandr
Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
eDP1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 294mm x 165mm
   1920x1080 60.0*+ 40.0
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080 60.0*+

The problem is that absolutely nothing gets logged, the system just crashes hard

The screen freezes continuing to show what was displayed before and the fan goes on full speed.

I have upgraded to a newer kernel

3.8.0-34-generic #49~precise1-Ubuntu SMP Wed Nov 13 18:05:00 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

and have not suffered a crash for a week

Ryan Riegel (rriegs) wrote :

I want to ammend my previous comment (#109) to add that I ultimately upgraded to the 3.8.0 kernel and, more recently, to the 3.11.0 kernel available in the Ubuntu 12.04 repositories. I have not seen the crash since upgrading (months ago), even with my external monitor at full resolution (and, indeed, I did still see some crashes in 3.2.0 when not at full resolution), so it seems that upgrading the kernel is the real workarround for this problem.

Felix Griewald (tiiunder) wrote :

I still have this problem with newest kernel 3.16 on Ubuntu 14.04.1

Looks like it only crashes if an external monitor is connected. Sometimes it helps to restart compiz using command line.

I also tried the official Intel drivers (Intel Graphics installer) and newest open source drivers. Same problem here.

Displaying first 40 and last 40 comments. View all 118 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers