backlight not adjustable after screen turns off and then back on

Reported by Daniel Jared Dominguez on 2013-03-29
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Dell Sputnik
Medium
Kamal Mostafa
linux (Ubuntu)
Medium
Kamal Mostafa
Precise
Undecided
Kamal Mostafa
Raring
Medium
Kamal Mostafa

Bug Description

On both versions of the XPS 13 (L322X and L321X) running Ubuntu Raring with the latest 3.8 kernel, letting the screen turn off and then back on causes the backlight to go to maximum brightness and become not adjustable. This behavior is not seen with suspend/resume or at boot (such as with LP #954661). However, like with those issues, "/bin/echo 0 > /sys/class/backlight/intel_backlight/brightness" allows the backlight to become adjustable again. I have verified this behavior on two systems. The backlight behaved correctly on both with Precise running Kamal's special kernel build.
---
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/hwC0D3', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D3p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-precise-amd64-20120703-2
DistroRelease: Ubuntu 13.04
HibernationDevice: RESUME=UUID=2827209a-01af-48d1-82e8-472354ab65a7
InstallationDate: Installed on 2013-03-26 (3 days ago)
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
MachineType: Dell Inc. Dell System XPS L322X
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-15-generic root=UUID=5c924dca-ecf4-4d3d-a7d2-34780269b9c5 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-15.25-generic 3.8.4
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-15-generic N/A
 linux-backports-modules-3.8.0-15-generic N/A
 linux-firmware 1.104
Tags: raring
Uname: Linux 3.8.0-15-generic x86_64
UpgradeStatus: Upgraded to raring on 2013-03-29 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 02/21/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: B40
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrB40:bd02/21/2013:svnDellInc.:pnDellSystemXPSL322X:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L322X
dmi.sys.vendor: Dell Inc.

apport information

tags: added: apport-collected raring
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

I've tested with the latest upstream kernel.

test@test-Dell-System-XPS-L322X:~$ uname -a
Linux test-Dell-System-XPS-L322X 3.9.0-030900rc4-generic #201303232035 SMP Sun Mar 24 00:36:21 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

tags: added: kernel-bug-exists-upstream
description: updated
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Joseph Salisbury (jsalisbury) wrote :

Also, was there a prior kernel version that did not exhibit this bug?

Yes, Ubuntu 12.04 does not have this issue.

Actually, I see that 3.9-rc5 was released yesterday, and it contains this change:
Revert "drm/i915: write backlight harder"
http://permalink.gmane.org/gmane.linux.kernel.commits.head/372554

Right now, someone else is using the L322X I was testing with, so I can't check rc5 at the moment.

Joseph Salisbury (jsalisbury) wrote :

It would be great if you could test rc5[0] and post the results.

Thanks in advance!

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc5-raring/

Changed in linux (Ubuntu):
assignee: nobody → Kamal Mostafa (kamalmostafa)
Changed in dell-sputnik:
assignee: nobody → Kamal Mostafa (kamalmostafa)
Joseph Salisbury (jsalisbury) wrote :

If the bug still exists in 3.9-rc5, we can perform a bisect to identify the commit that introduced this regression.

Kamal Mostafa (kamalmostafa) wrote :

@jsalisbury, I think I know the code that's causing the trouble, and will look into the issue here; no bisect is necessary.

Changed in linux (Ubuntu):
status: Triaged → In Progress
Tim Gardner (timg-tpi) on 2013-04-09
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Kent Baxley (kentb) on 2013-04-11
Changed in dell-sputnik:
status: New → Fix Committed
importance: Undecided → Medium
Kent Baxley (kentb) wrote :

Tested the kernel in raring-proposed today and things are much better. After letting the screen turn off and then back on I no longer lose the ability to adjust screen brightness. I can still adjust screen brightness after suspend / resume, too. This is on an L322X.

Kamal Mostafa (kamalmostafa) wrote :

Thanks for the confirmation, Kent.

This problem is fixed (for the old and new Dell XPS 13 models) in the next Raring kernel (3.8.0-18.28), which is available now in raring-proposed (see https://wiki.ubuntu.com/Testing/EnableProposed ).

Launchpad Janitor (janitor) wrote :
Download full text (4.5 KiB)

This bug was fixed in the package linux - 3.8.0-18.28

---------------
linux (3.8.0-18.28) raring; urgency=low

  [ Andy Whitcroft ]

  * (debian) fix internal linkage for separated header packages
    - LP: #1165259

  [ Gavin Guo ]

  * SAUCE: Bluetooth: Add support for Broadcom 413c:8143
    - LP: #1166113

  [ John Johansen ]

  * SAUCE: (no-up) apparmor: Fix quieting of audit messages for network
    mediation
    - LP: #1163259

  [ Kamal Mostafa ]

  * SAUCE: (no-up) drm/i915: quirk no PCH_PWM_ENABLE for Dell XPS13
    backlight
    - LP: #1162026, #1163720

  [ Leann Ogasawara ]

  * [Config] Disable CONFIG_PARPORT_PC_FIFO
    - LP: #339752

  [ Martin Pitt ]

  * SAUCE: (no-up) mac80211_hwsim: Register and bind to driver
    - LP: #1166250

  [ Paolo Pisati ]

  * [Config] RTC_DRV_PL031=y

  [ Stefan Bader ]

  * (debian) Abort build on unresolved symbols
    - LP: #1166197

  [ Tim Gardner ]

  * [Config] Add libceph to inclusion list
  * [Config] Drop all inclusion list modules with unsatisfied dependencies
  * SAUCE: (no-up) Remove emi62 files duplicated in linux-firmware
  * SAUCE: (no-up) Remove emi26 files duplicated in linux-firmware
  * SAUCE: (no-up) Remove whiteheat files duplicated in linux-firmware
  * Release Tracking Bug
    - LP: #1168040

  [ Upstream Kernel Changes ]

  * TTY: do not update atime/mtime on read/write
    - LP: #1097680
    - CVE-2013-0160
  * KVM: x86: Convert MSR_KVM_SYSTEM_TIME to use gfn_to_hva_cache functions
    (CVE-2013-1797)
    - LP: #1158258
    - CVE-2013-1797
  * KVM: Fix bounds checking in ioapic indirect register reads
    (CVE-2013-1798)
    - LP: #1158262
    - CVE-2013-1798
  * drm/i915: HDMI/DP - ELD info refresh support for Haswell
    - LP: #1011438
  * ALSA - HDA: New PCI ID for Haswell ULT
    - LP: #1011438
  * ALSA: hda - Support rereading widgets under the function group
    - LP: #1011438
  * ALSA: hda - Add fixup for Haswell to enable all pin and convertor
    widgets
    - LP: #1011438
  * libata: fix DMA to stack in reading devslp_timing parameters
    - LP: #1031173
  * dmaengine: dw_dmac: remove CLK dependency
    - LP: #1031163
  * dmaengine: dw_dmac: Enhance device tree support
    - LP: #1031163
  * dmaengine: dw_dmac: amend description and indentation
    - LP: #1031163
  * dw_dmac: change dev_printk() to corresponding macros
    - LP: #1031163
  * dw_dmac: don't call platform_get_drvdata twice
    - LP: #1031163
  * dw_dmac: change dev_crit to dev_WARN in dwc_handle_error
    - LP: #1031163
  * dw_dmac: introduce to_dw_desc() macro
    - LP: #1031163
  * dw_dmac: absence of pdata isn't critical when autocfg is set
    - LP: #1031163
  * dw_dmac: check for mapping errors
    - LP: #1031163
  * dw_dmac: remove redundant check
    - LP: #1031163
  * dw_dmac: update tx_node_active in dwc_do_single_block
    - LP: #1031163
  * dma: dw_dmac: add dwc_chan_pause and dwc_chan_resume
    - LP: #1031163
  * dmaengine: introduce is_slave_direction function
    - LP: #1031163
  * dmaengine: add possibility for cyclic transfers
    - LP: #1031163
  * dma: dw_dmac: check direction properly in dw_dma_cyclic_prep
    - LP: #1031163
  * dma: ep93xx_dma: reuse is_slave_direction helpe...

Read more...

Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
Changed in dell-sputnik:
status: Fix Committed → Fix Released
Marco (marco89-7) wrote :

With 3.8.0-18 kernel, brightness control is not working on my XPS13 with raring. Blacklight is on but at minimum, brightness keys do nothin.
Blacklight is perfectly working with kernel 3.8.0-17 and maybe before: on waking from suspend, brightness is restored as before suspending and is adjustable.
So this fix seems to solve the bug for someone, but introduced a new bug for me that I had no problems before.
My laptop is an XPS 13 last model, with full-hd display. I installed raring from scratch and it is booting with uefi.

Kamal Mostafa (kamalmostafa) wrote :

@Marco, thanks for reporting this. Could I ask you to file a new Launchpad bug against linux 3.8.0-18 for this, so that we can capture the hardware profile for that XPS13 model? Please assign the new bug to me.

Kamal Mostafa (kamalmostafa) wrote :

@Marco, actually this existing bug matches the problem: LP: #1169376. We'll track the problem there.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
tags: added: verification-needed-raring
Kamal Mostafa (kamalmostafa) wrote :

Re-verified:
Quantal 3.5.0-40.62
Raring 3.8.0-30.44

tags: added: verification-done-quantal verification-done-raring
removed: verification-needed-quantal verification-needed-raring
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Kamal Mostafa (kamalmostafa) wrote :

Verified fixed:
Precise 3.2.0-55.85

Changed in linux (Ubuntu Precise):
status: New → Fix Released
assignee: nobody → Kamal Mostafa (kamalmostafa)
tags: added: verification-done-precise
removed: verification-needed-precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers