dell-recovery throws traceback when creating recovery image or media

Bug #1173688 reported by lpatas_dilliers on 2013-04-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Dell Recovery
Undecided
Unassigned
Dell Sputnik
High
Unassigned

Bug Description

I put a USB key in the USB port and called dell-recovery. An error message appeared "Exception"

Full steps to reproduce:
1) Start up Dell-Recovery
2) Click Build OS Media
3) Select either USB Flash Drive or No media, create image.
4) Click continue
5) Click apply

Actual results: Traceback in attached screenshot
Expected results: Should be able to create recovery iso or bootable media.

Notes: This seems to happen with the new version of dell-recovery pushed out a few weeks ago. The original dell-recovery on the installed system 1.24.1~precise8 didn't have any problems with steps 1-5.

Kent Baxley (kentb) wrote :

Hello,

Which version of dell-recovery? Also, if not done already, please run the following commands to make sure dell-recovery is at the latest version:

sudo apt-get update
sudo apt-get install dell-recovery

Changed in dell-sputnik:
status: New → Incomplete
Ville Pätsi (sanguivor) wrote :

I get the exact same error. Happens after choosing apply in 'Confirm Selections' with both media types that are available: USB and create image.

System is factory installed sputnik Ubuntu 12.04 with all updates. dell-recovery version is 1.24.2~precise12, which is the latest that is available.

Kent Baxley (kentb) wrote :

Thanks. I've also been able to cause the same traceback. We'll get someone to look at it.

summary: - dell-recovery doesn't work
+ dell-recovery throws traceback when creating media
summary: - dell-recovery throws traceback when creating media
+ dell-recovery throws traceback when creating recovery image or media
Changed in dell-sputnik:
status: Incomplete → Confirmed
importance: Undecided → High
Kent Baxley (kentb) on 2013-05-02
description: updated
Kent Baxley (kentb) on 2013-05-02
description: updated
Kent Baxley (kentb) wrote :

A fix has been put together and tested for this problem. We are in the process of getting the packages put into the dell archive and we should have something available to the users very soon.

Kent Baxley (kentb) on 2013-05-06
Changed in dell-sputnik:
status: Confirmed → Fix Committed
Bofu Chen (bafu) on 2013-05-08
Changed in dell:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Bofu Chen (bafu)
Sergio Rus (srus) wrote :

Hello, dell-recovery doesn't work for me neither. I can't create USB images nor ISO images. It crashes after clicking "apply" button ("aplicar" in Spanish). This is the error log:

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/Dell/recovery_basic_gtk.py", line 130, in wizard_complete
    self.dbus_exception_handler(msg, parent)
  File "/usr/lib/python2.7/dist-packages/Dell/recovery_gtk.py", line 118, in dbus_exception_handler
    self.show_alert(Gtk.MessageType.ERROR, _("Exception"), text, parent)
  File "/usr/lib/python2.7/dist-packages/Dell/recovery_gtk.py", line 234, in show_alert
    message = "%s\n\n%s" % (message, body)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 15: ordinal not in range(128)

Kent Baxley (kentb) wrote :

Hi Sergio,

A fix has been committed and we're waiting to push this out to the users. I'll update the bug when it's ready.

Sergio Rus (srus) wrote :

Thanks! now it works perfect.

Kent Baxley (kentb) wrote :

Seems to work for me now as well.

Changed in dell-sputnik:
status: Fix Committed → Fix Released
Bofu Chen (bafu) wrote :

Hi everyone,

As Sergio and Kent said, the latest dell-recovery has been pushed to precise-dell archive. Thank you for your reports/comments to make things better.

Changed in dell:
status: In Progress → Fix Released
assignee: Bofu Chen (bafu) → nobody
Changed in somerville:
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306007

no longer affects: somerville
Changed in dell-recovery:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers