Dell Mini9 :Broadcom WL, wpa_supplicant fails to associate with driver

Bug #310390 reported by Matthew Lye
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Dell Mini Project
Confirmed
Undecided
Unassigned
linux (Ubuntu)
Fix Released
Undecided
Unassigned
network-manager-applet (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Ive found an issue for anyone using Enterprise WPA/WPA2 using the Broadcom STA wireless driver on 8.10.
This will affect anyone using a mini 9 (my pc) and should affect other new dell laptops using the Broadcom driver.

The network manager fails to connect to networks under WPA/WPA2 Enterprise using TTLS&PAP (i have also heard it occurring under every other configuration but have not been able to test). This could (but unlikely) be related to: https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/284211

After a little checking I found a problem that is likely causing it:

ps ax | grep wpa
 5064 ? S 0:08 /sbin/wpa_supplicant -u -f /var/log/wpa_supplicant.log
13286 pts/0 R+ 0:00 grep wpa

tail -f /var/log/wpa_supplicant.log
Trying to associate with 00:0e:38:b8:ea:xx (SSID='XYZ' freq=2437 MHz)
Association request to the driver failed
Associated with 00:0e:38:b8:ea:xx

And then we find:
wpa_cli v0.6.4
Copyright (c) 2004-2008, Jouni Malinen <email address hidden> and contributors

This program is free software. You can distribute it and/or modify it
under the terms of the GNU General Public License version 2.

Alternatively, this software may be distributed under the terms of the
BSD license. See README and COPYING for more details.

Could not connect to wpa_supplicant - re-trying

Im guessing that there is a configuration error that is preventing WPA Enterprise from using the wpa_supplicant which is causing the problems.

Revision history for this message
Matthew Lye (matthew.lye) wrote :

The connection being attempted is enterprise wpa2 EAP-TTLS/PAP
The chipset is Broadcom Corporation BCM4312 802.11b/g (rev 01) using the restricted Broadcom STA wireless driver.

I have tested and had no problems connecting to open, WPA PSK, and WPA2 PSK networks.

Revision history for this message
anjilslaire (anjilslaire) wrote :

I had trhis problem as well, until this morning. I switched from WPA Personal to WPA2 Personal with AES, and it started working. My specs are:

wpasupplicant 0.6.4-2, network-manager 0.7-0ubuntu1~nm1~intrepid1

 wireless driver is the latest Broadcom STA wireless driver offered by the Hardware Drivers applet, and my kernel is 2.6.27-9-generic, running on vanilla Ubuntu 8.10 i386

More details can be found here:
http://ubuntuforums.org/showthread.php?t=1019121&page=2

starting in post# 20

Revision history for this message
Matthew Lye (matthew.lye) wrote :

 anjilslaire wrote:
I had trhis problem as well, until this morning. I switched from WPA Personal to WPA2 Personal with AES, and it started working. My specs are: wpasupplicant 0.6.4-2, network-manager 0.7-0ubuntu1~nm1~intrepid1

Thanks for your post but the WPAsupplicant as I understand it should not be used in WPA Personal networks at all. The supplicant handles the authentication for Enterprise wireless connections. Regardless as stated I have had no problems connecting to any configuration of WPA/WPA2 Personal wireless networks.

Revision history for this message
nickl (nick-lothian) wrote :

I'm having the same problem. I can connect to WEP access points fine, but no luck with WPA.

Revision history for this message
Matthew Lye (matthew.lye) wrote :

Confirmed on an additional two Mini 9's

Changed in dell-mini:
status: New → Confirmed
Revision history for this message
russo.1 (russo091) wrote :

Same problem on a Lenovo S10.

Meanwhile try to use ndiswrapper, i got this to work, unfortunately i need to reload ndiswrapper occasionally after sleeping the notebook.

Revision history for this message
Matthew Lye (matthew.lye) wrote :

Confirmed on Dell and Lenovo machines now. I know ndiswrappers will work, but thats a horrible solution for a wireless nic that has a existing native driver. Problem is identifying if the fault is in wpasupplicant or the driver. Should be reported to Broadcom as well.

Changed in wpasupplicant:
status: New → Confirmed
Revision history for this message
russo.1 (russo091) wrote :

I mentioned ndiswrapper, because i think the fact ndiswrapper works, makes me think its a driver problem, and not one with wpa_supplicant or the card.

Revision history for this message
Matthew Lye (matthew.lye) wrote :

Not related to supplicant as ndis wrapper works.

90% chance related to manufactures driver. Should not be listed as working by Ubuntu Devs. Broadcom should be informed of the fault.

Changed in wpasupplicant:
status: Confirmed → New
Revision history for this message
Ivan Gualandri (ivang) wrote :

I have the same problem with my hp 6735s.
Now i noticed one thing, if i launch first Windows with wi-fi authenticated to the AP, and then i restart the pc and i launch linux, then the wi-fi will work, sometimes for hours, and sometimes for few minutes.

I use wpa-psk.
And another strange thing, with network manager, when i insert a WPA-PSK key, after it try to authenticate to the Access Point (without success) if i check "Show Password" then the password is corrupted. It is normal?

Revision history for this message
Alexander Sack (asac) wrote :

are you on jaunty? wonder if wl drivers have improved there.

Changed in network-manager-applet:
status: New → Invalid
Revision history for this message
Alexander Sack (asac) wrote :

lets triage this from the triage side. if you have indications that this is really a wpasupplicant bug, please reassign back to that package. Thanks.

Revision history for this message
nickl (nick-lothian) wrote :

>And another strange thing, with network manager, when i insert a WPA-PSK key, after it try to authenticate to the Access Point (without success) if i check "Show Password" then the password is corrupted. It is normal?

I believe so - it happens to me (on a working connection) too, anyway.

> lets triage this from the triage side. if you have indications that this is really a wpasupplicant bug, please reassign back to that package

How would I got about determining that?

Revision history for this message
Matthew Lye (matthew.lye) wrote :

The bug appears to be caused by the driver because if you use the NDIS wrapper the windows driver will work.

Ill be testing with Jaunty as soon as it hits beta. I don't want to deploy the apha to a production machine and I don't have a test model in the office at this time.

Revision history for this message
Urschl (bigurschl) wrote :

I have jaunty alpha 5 and can not connect to my uni wlan which is ttls, pap, wpa2 enterprise.
An attempt completly freezes my laptop. the card is bcm4312. the driver is 5.10.27.11.

Revision history for this message
Urschl (bigurschl) wrote :

with wpa2 pre-shared key it works without problems.

Could someone please integrate to newest driver version 5.10.79.10 into jaunty?

Revision history for this message
Jérémy Subtil (bigmadwolf) wrote :

Hi Urschi, you should have a look at bug 292450.

Revision history for this message
Matthew Lye (matthew.lye) wrote :

 Urschl wrote on 2009-03-13:
with wpa2 pre-shared key it works without problems.

This issue only occurs with WPA Enterprise. The driver fails to bind with the WPA supplicant which is the applications that handles the continual authentication that occurs. Unlike preshared key it authenticates continually based on your login details in comparison to a database at the back end.

Revision history for this message
^_Pepe_^ (jose-angel-fernandez-freire) wrote :

This bug was reported a while ago and there hasn't been any activity in
it recently. We were wondering if this is still an issue? Can you try
with the latest Karmic 9.10 release of Ubuntu? ISO CD images are
available from http://cdimage.ubuntu.com/releases/ .

If the issue remains, could you run the following command from a
Terminal (Applications->Accessories->Terminal) while running Karmic. It
will automatically gather and attach updated debug information to this
report.

apport-collect -p linux 310390

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Matthew Lye (matthew.lye) wrote :

Fixed in 9.10

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Joachim Breitner (nomeata) wrote :

This says fixed in 9.10. Could you please be more specific: What package had to be updated to what version to make this work?

Thanks, Joachim

Revision history for this message
Matthew Lye (matthew.lye) wrote :

No idea what was updated to make it work, it might just be a new version of the driver, or a newer version of the supplicant.

Revision history for this message
Pablo López Martín (mr-bible2001) wrote :

I'm having the same problem on a Dell Latitude E5400, with Ubuntu 9.10 - Karmic Koala. This hasn't been fixed.

Revision history for this message
Pablo López Martín (mr-bible2001) wrote :
Revision history for this message
^_Pepe_^ (jose-angel-fernandez-freire) wrote :

@Pablo: I'd encourage you to open a new bug, without any other implication, with your hardware details and your sympthoms.

Thanks in advance

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers