Dell Inspiron Mini with Custom Dell UI

Kernel 2.6.24-19-lpia (dell mini 9) does not see more than 1GB RAM

Reported by Nicola Ferralis on 2008-10-20
58
This bug affects 3 people
Affects Status Importance Assigned to Milestone
The Dell Mini Project
High
Pat McGowan
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Running kernel 2.6.24-19-lpia from the customized repos for the Dell mini 9. Although the system has more than 2GB RAM (as visible through the BIOS), Ubuntu actually sees only 1GB (883MB, actually).

To test type "free -m".

More details here:
http://ubuntuforums.org/showpost.php?p=5992307&postcount=477

Changed in dell-mini:
assignee: nobody → pat-mcgowan
importance: Undecided → High
status: New → Triaged
Michael Frey (mfrey) wrote :

There will be an update to the kernel that enables HIGHMEM support. The current kernel does not support this.

Changed in dell-mini:
status: Triaged → In Progress
Kevin (kevin-matson) wrote :

Any word on when this will happen? Days, weeks, months? Something to help set expectations would be greatly appreciated, and we understand that setting firm dates is probably impossible.

Thanks for the help for this.

Art Vandelay (gabriel-leake) wrote :

When will this update arrive? The update to the kernel should have happened BEFORE the mini 9 went on sale. I just got mine and now I have a project on my hands - compile my own kernel - switch to XP - or install the full version of ubuntu 8.10.

How about instead of releasing garbage that doesn't support 2gigs, you people stop ****ing over the linux community and doing stupid things to make us have to use windoze.

Nicola Ferralis (feranick) wrote :

Unless you have something useful to say that could help resolving the bug, please refrain from using launchpad for personal rants, support questions, etc. Ranting on a bug tracking system doesn't do any good to anybody, in fact it only wastes everybody's time.

Nicola Ferralis (feranick) wrote :

The mini9 (Ubuntu 8.04.1) now ships with an available 2GB of RAM, I wonder if it ships with the same kernel available in the repos, which is currently limited to 1GB. If so, users who invest in extra RAM can only use half of it...

Nicola Ferralis (feranick) wrote :

The latest kernel update seem to have fixed this bug. Now the system seem to see the full 1GB.

output from 'free -m'

  total used free shared buffers cached
Mem: 1000 479 521 0 13 212
-/+ buffers/cache: 254 746
Swap: 0 0 0

People that have more than 1GB installed should test the new kernel, before closing this bug.

Changed in dell-mini:
status: In Progress → Fix Committed
Art Vandelay (gabriel-leake) wrote :

The bug was that it could not see >1gb of ram, it always saw at least 1gb.

Nicola Ferralis (feranick) wrote :

No, the max it could see before was 883MB (see bug description). Now it can see 1GB. We need someone to test it with >1GB.

Digalante (digalante) wrote :

I can confirm the update allowed my mini 9 to see all installed 2GB

$ uname -a ; free -m
Linux wintermute 2.6.24-19-lpia #1 SMP Mon Nov 3 15:25:26 UTC 2008 i686 GNU/Linux
             total used free shared buffers cached
Mem: 2016 487 1529 0 14 243
-/+ buffers/cache: 229 1787
Swap: 0 0 0

Thank you!

Nicola Ferralis (feranick) wrote :

Closing this bug, since the latest kernel update fixes it.

Changed in dell-mini:
status: Fix Committed → Fix Released
Changed in linux:
status: New → Invalid
dyoakum (dyoakum) wrote :

I also have a Mini 9 and just installed Ubuntu 9.2 and this is what's displayed when I run "free -m"

dyoakum@Y-MOBILE1:~$ free -m
             total used free shared buffers cached
Mem: 2004 401 1603 0 14 181
-/+ buffers/cache: 206 1798
Swap: 2439 0 2439

I hope this helps.

Regards
dyoakum

Nicola Ferralis (feranick) wrote :

This bug was fixed long ago for hardy 8.04. This bug is limited to the kernel of this distribution.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers