Déjà Dup Backup Tool

nautilus crashed with SIGSEGV in g_main_context_dispatch()

Reported by Rizal Atan on 2011-10-07
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Déjà Dup
Critical
Unassigned
20
Critical
Unassigned
deja-dup (Ubuntu)
Medium
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

random crash after fresh installation

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: deja-dup 20.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Fri Oct 7 12:42:52 2011
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
ProcCmdline: nautilus
ProcEnviron:
 PATH=(custom, no user)
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x6f5707a: mov (%edx),%eax
 PC (0x06f5707a) ok
 source "(%edx)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: deja-dup
StacktraceTop:
 ?? () from /usr/lib/nautilus/extensions-3.0/libdeja-dup.so
 ?? () from /usr/lib/nautilus/extensions-3.0/libdeja-dup.so
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: nautilus crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Rizal Atan (sprint-1) wrote :
visibility: private → public

StacktraceTop:
 update_include_excludes () at NautilusExtension.c:66
 update_include_excludes_idle_cb () at NautilusExtension.c:89
 g_idle_dispatch (source=0x8cb55c0, callback=0x6f57180 <update_include_excludes_idle_cb>, user_data=0x0) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:4801
 g_main_dispatch (context=0x8c2feb0) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:2441
 g_main_context_dispatch (context=0x8c2feb0) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3011

affects: ubuntu → deja-dup (Ubuntu)
Changed in deja-dup (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Michael Terry (mterry) wrote :

This was because we assumed gsettings would never return NULL in a certain spot, which is true as long as our gsettings schema is installed correctly. Not sure why it wasn't here (though Ubuntu 11.10 has had a few bugs with that). Regardless, it's simple enough to guard against.

Changed in deja-dup:
importance: Undecided → Critical
milestone: none → 21.1
status: New → Fix Committed
Rizal Atan (sprint-1) wrote :

Thank you :-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 20.1-0ubuntu1

---------------
deja-dup (20.1-0ubuntu1) precise; urgency=low

  * New upstream bug fix release
    - Correctly backup or exclude folders with [, ], ?, and * in their
      names (LP: #859884, but previously fixed in Ubuntu)
    - Fix translation of some strings when used in control center panel
      mode (LP: #869891)
    - Fix a nautilus crash if the gsettings schema isn't installed
      correctly (LP: #869933)
    - Allow LUKS encrypted volumes to appear in backup location list
      (LP: #871418)
  * debian/patches/escape_globs.patch:
    - Dropped, applied upstream
 -- Michael Terry <email address hidden> Mon, 17 Oct 2011 14:39:06 -0400

Changed in deja-dup (Ubuntu):
status: New → Fix Released
Michael Terry (mterry) wrote :

I've uploaded 20.1 to oneiric-proposed with this fix. I do not know how to reproduce it however to test the fix. :-/

Hello Rizal, or anyone else affected,

Accepted deja-dup into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in deja-dup (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Rizal Atan (sprint-1) wrote :

@mterry - I supposed the only way of reproducing it is by doing fresh installation then wait for the crash to happen.

I did clean install of the beta2 every time there was an error - altogether 7 clean installations before I decided to have it reported here. However the last clean install was fine. A clean install on another machine was fine too.

Many thanks guys.

Michael Terry (mterry) on 2011-10-24
Changed in deja-dup:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 20.1-0ubuntu0.1

---------------
deja-dup (20.1-0ubuntu0.1) oneiric-proposed; urgency=low

  * New upstream bug fix release
    - Correctly backup or exclude folders with [, ], ?, and * in their
      names (LP: #859884, but previously fixed in Ubuntu)
    - Fix translation of some strings when used in control center panel
      mode (LP: #869891)
    - Fix a nautilus crash if the gsettings schema isn't installed
      correctly (LP: #869933)
    - Allow LUKS encrypted volumes to appear in backup location list
      (LP: #871418)
  * debian/patches/escape_globs.patch:
    - Dropped, applied upstream
 -- Michael Terry <email address hidden> Tue, 18 Oct 2011 12:01:21 -0400

Changed in deja-dup (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers