Deja-dup should detect that another instance is already running for the same user.

Bug #891797 reported by Grigory Rechistov on 2011-11-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Undecided
Unassigned
deja-dup (Ubuntu)
Undecided
Unassigned

Bug Description

I mananged to add two *.desktop links to autostart folders that start up deja-dup-monitor process. Now when it's time to back up one of them informs me with a window that "another backup is in progress".

I think that it would be good if during startup deja-dup-monitor would check if another instance for the user has been already started (e.g. by trying to lock a file) and if it's so t shoudl just exit.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: deja-dup 20.1-0ubuntu0.2
Uname: Linux 3.2.0-rc1-aspm-fix x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Fri Nov 18 00:21:24 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: deja-dup
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Grigory Rechistov (atakua) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in deja-dup (Ubuntu):
status: New → Confirmed
Michael Terry (mterry) on 2012-09-18
Changed in deja-dup:
milestone: none → 23.92
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 23.92-0ubuntu1

---------------
deja-dup (23.92-0ubuntu1) quantal; urgency=low

  * New upstream release
    - Only allow one deja-dup-monitor process at a time (LP: #891797,
      LP: #1051811)
 -- Michael Terry <email address hidden> Tue, 18 Sep 2012 13:15:04 -0400

Changed in deja-dup (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers