unable to use rsync.net service

Bug #889895 reported by Peter Petrakis on 2011-11-13
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Undecided
Unassigned

Bug Description

http://www.rsync.net/resources/overview.html

I'm able to login and use the service just fine. A separate pair
of ssh key's exist. I fill out the ssh method with everything
except port and folder. This is where I believe the problem
lies. No matter what I try, even when I try to specify a directory,
deja-dup automatically prepends a "/", which I don't have access to.

I believe this causes the program to exist prematurely. Using a custom
location via sftp produces the same results. deja-dup insists on
assuming I have access to root on the destination host which
is not true here.

Logs and config (sanitized) attached.

Peter Petrakis (peter-petrakis) wrote :
Gerv (gerv-launchpad) wrote :

Hi,

This affects me too. With the shutdown of U1 I'd like to switch to using my rsync.net account for my wife's simple backups, which use Deja Dup, but can't.

This bug seems like it wouldn't be hard to fix by changing the behaviour to not add the "/", but the problem is that it's not at all clear what the consequences of fixing it would be (i.e. what else would break). Could one of the Deja Dup developers chime in with a suggestion about how best this problem could be handled?

Gerv

On Sat, 2014-04-12 at 18:56 +0000, Gerv wrote:
> This bug seems like it wouldn't be hard to fix by changing the behaviour
> to not add the "/", but the problem is that it's not at all clear what
> the consequences of fixing it would be (i.e. what else would break).
> Could one of the Deja Dup developers chime in with a suggestion about
> how best this problem could be handled?

I took a look through and attempted to make a patch, but my
unfamiliarity with either the language, codebase or both kept me from
solving it.

I do have a workaround, though, that might tide you over until you can
get it solved. If you email the rsync.net engineers and tell them you
are using Deja Dup and need an absolute path to your home folder, they
will give you one that you can plug in as the path.

Deja Dup seems to work just fine after you do that.

Hope this helps!

Sincerely,
--
Harlan Lieberman-Berg
~hlieberman

Gerv (gerv-launchpad) wrote :

Here's how I solved it - I found out the absolute path on my server and used that:
http://blog.gerv.net/2014/04/using-deja-dup-ubuntu-built-in-backup-with-rsync-net/

Gerv

Michael Terry (mterry) wrote :

This should be fixed in git master now. We ask gvfs for the 'default location' of a remote mount, which is your home directory for ssh.

Changed in deja-dup:
status: New → Fix Committed
Michael Terry (mterry) on 2017-08-18
Changed in deja-dup:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers