resuming a backup should be obvious in the UI

Bug #781365 reported by Rahul Sundaram on 2011-05-11
56
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Low
Unassigned
deja-dup (Fedora)
New
Undecided
Unassigned

Bug Description

Currently, Deja-dup is supposed to resume a backup from where it left off if I can cancel it but the progress bar doesn't indicate that and hence it appears the whole process is being started fresh. In the absence of any detailed info like a log file to view from the UI, a progress bar that resumes from the point where it was cancelled would be useful. A log is useful for advanced users as well.

Michael Terry (mterry) wrote :

Hmm, yeah. I'll have to see if duplicity lets us know that it's a resumed backup via its logging interface. If so, this should be easy to do.

Changed in deja-dup:
importance: Undecided → Low
status: New → Confirmed

This bug is actually quite important since there currently is no good way to judge whether Deja-dup is working. I have been trying for more than a month now to get a single working backup of ~40GB of data to Ubuntu One without success.

The main issue I want to address is not that the backup are failing but that they are failing silently. A backup will be running as the OP says and when it is interrupted for instance from loosing connection or suspending the machine (both of which throws an exception) or just hitting resume then deja-dup will say that in it's status window that a backup was performed today. This is a very unresponsible thing to write when it is definitely NOT true. Since pressing the back-up now button does not indicate in any way whether the backup is actually being resumed or not there is no way to tell whether the backup was successful. If you try to check by pressing restore now it will (sometimes) tell you that there is a backup from the relevant date, but that is not the case which is plain to see from the file size (it only takes up 1% of the total 40 gb files).

All in all deja-dup desperately need a reliable way to inform you whether a backup is present or not.

Ayke (ayke) wrote :

bug #907849 seems to be related to this bug (is it a duplicate?)

Michael Terry (mterry) wrote :

This is an old bug. These days we do show that the process hasn't started fresh by setting the progress bar appropriately after duplicity tells us (after the first chunk is uploaded).

Changed in deja-dup:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers