Déjà Dup Backup Tool

Preferences aren't saved

Reported by Paolo Stivanin on 2011-05-01
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Déjà Dup
High
Unassigned
18
High
Unassigned
deja-dup (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

=== SRU Justification ===

This is a bad regression with external drives and Deja Dup. It has the ability to reset the user's backup settings for users backing up to external drives.

=========================

Reproduction Steps:
 * Plug in an external drive
 * Run deja-dup-preferences
 * Select the external drive from the drop down and close the dialog
 * Run deja-dup-preferences again

You'll see that your selection has been reset to Amazon S3. It should remain as your external drive.

Michael Terry (mterry) wrote :

That seems bad! Is it just your SSH information that doesn't get saved? Like, does your list of includes/excludes and whether you want encryption and such saved?

Can you provide the file /tmp/deja-dup.settings after running the following:
gsettings list-recursively org.gnome.DejaDup > /tmp/deja-dup.settings

Changed in deja-dup:
status: New → Incomplete
Paolo Stivanin (polslinux) wrote :

I am outside home until next monday so i can't test with Debian!
But now i am on Ubuntu 10.10 with duplicity 0.6.10 & Deja-dup 16.1.1 and it is all ok, preferences are saved!
I can't test with Deja-Dup 18.1.1 because there isn't a deb package and some deps (like libnotify) aren't updated on Ubuntu so it take me long time if i want to compile it! (sorry but this week i am very busy!)

@Michael: no, not only SSH preferences but all preferences! I've tried with SSH, FTP and Local folder!
I'll try what you wrote me when I return home!

IKT (ikt) on 2011-05-12
Changed in ubuntu:
status: New → Invalid
Sebastián Veggiani (sveggiani) wrote :

Hi, I'm having the same issue with my Ubuntu 11.04 intallation.

Storage settings appear to be saved but every time I access Preferences or the scheduled backup dialog appears asks for S3 settings.

In preferences, if I switch to my external drive again the folder and other options are there and I can run the backup. But in the scheduled backup dialog this is not possible, only asks for S3 account.

I've attached the results of running "gsettings list-recursively org.gnome.DejaDup".

PS: Excuse my poor english please.

I experience a similar behavior. I've setup Deja Dup to backup daily on an external drive (no data encryption). The scheduled backup often fails. When I check the preferences I can see that the destination folder has been reset to Amazon S3. Other preferences are saved (encryption, schedule).
This on 11.04 with Deja Dup 18.1.1

Michael Terry (mterry) wrote :

Well, that's three separate people that have found their way here. Definitely confirmed. I'm still not sure why it's happening. Will look into it.

Changed in deja-dup:
importance: Undecided → High
status: Incomplete → Confirmed
Sebastián Veggiani (sveggiani) wrote :

Something weird happened. I don't know why but after many tries to get the "backup location" preferences saved now they are saved OK and everything is working Ok now.

I have not tried any additional way to solve this problem so I guess that any of my attemps did the trick.

I have/had the same problem - and think I figured out the problem, as well as identified another crash-bug:

The settings *are* saved... there's just a bad bug in the code that parses the backend settings. Notice that the schedule, encryption, files, and whether or not you've turned it on/off are saved properly. Only the backend resets to AmazonS3 (the first one in the list), when you re-enter the dialog.

The reason is: It doesn't set the dialog correctly if the file type is 'volume' instead of 'normal'.

In my case, I was trying to change it to use a folder on a locally mounted drive 'consus'. In the 'Backup Location' dropdown list, my mountpoint showed as one of the options, and I was selecting it there. My dropdown list looked something like this:

   AmazonS3
   Rackspace cloud Files
   -----------
   FTP
   SSH
   WebDAV
   Windows Share
   Custom Location
   ------------
   consus
   System Reserved
   ------------
   Local Folder

But,l after consus (and picking a folder on that drive), exiting and re-entering Backup would show AmazonS3 as the selection again.

So next I tried selecting 'Local Folder'. Which made the dialog immediately crash.

The reason it crashes here is because it's trying to do something with the folder path, but it doesn't default to a valid path (it's null).

When a user does this, they'll find they can't go back in and fix it - it crashes immediately after selecting 'Backup' from the control center::

   evil@saturn:/$ gnome-control-center
   (gnome-control-center:9712): Gtk-WARNING **: /build/buildd/gtk+3.0-3.0.9/./gtk/gtkwidget.c:6786: widget not within a GtkWindow
   Segmentation fault

The solution is to run dconf-editor and changed the org.gnome.deja-dup.file path to a real path ('/'). This fixes the crash.

Now... the WORKAROUND for the original problem everyone was having: Choose 'Custom Location', then put something in the Folder field, then switch to 'Local Folder'. Do *not* exit the Folder field if it is blank when you have Custom Location set, or you will end up with the same crash bug I outline above.

Michael Terry (mterry) wrote :

3vi1, thanks so much for your detailed analysis. It led me to the bug. I've got a fix for this in trunk (and I fixed the crash there too -- the crash didn't affect 18.x) and a fix in the stable 18.x branch.

Changed in deja-dup:
status: Confirmed → Fix Committed

No problem at all Michael. Thanks for fixing it so quickly, and keep up the good work!

typo (gnomeuser8) wrote :

deja-dup package in Ubuntu 11.04 is still affected

Changed in ubuntu:
status: Invalid → New
affects: ubuntu → deja-dup (Ubuntu)
Michael Terry (mterry) on 2011-06-09
Changed in deja-dup:
milestone: none → 19.2
Michael Terry (mterry) wrote :

Here's the debdiff to update to 18.2 for Ubuntu 11.04. Note that it is quite large, but that's all translation updates. The bugfix itself is in the last few lines of the diff.

I've already uploaded a fix in natty-proposed. Please test!

description: updated
Michael Terry (mterry) on 2011-06-09
Changed in deja-dup (Ubuntu Natty):
status: New → Fix Committed
Changed in deja-dup (Ubuntu):
status: New → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Michael, the diff includes some non translation changes in the upstream portions.. such as the diff I've pasted below.

I looked at the diff and this does seem to be the only unrelated/non-translation change. I think this should be rejected and re-submitted unless you can explain how this will not affect users. :)

diff -Nru deja-dup-18.1.1/data/deja-dup-monitor.desktop deja-dup-18.2/data/deja-dup-monitor.desktop
--- deja-dup-18.1.1/data/deja-dup-monitor.desktop 2011-04-15 18:00:46.000000000 +0000
+++ deja-dup-18.2/data/deja-dup-monitor.desktop 2011-06-09 17:24:50.000000000 +0000
@@ -69,8 +69,8 @@
 Comment[zh_TW]=定時備份

 Icon=deja-dup
-TryExec=/usr/lib/deja-dup/deja-dup-monitor
-Exec=/usr/lib/deja-dup/deja-dup-monitor
+TryExec=/usr/local/lib/deja-dup/deja-dup-monitor
+Exec=/usr/local/lib/deja-dup/deja-dup-monitor

 StartupNotify=false

Michael Terry (mterry) wrote :

Clint, that is harmless. deja-dup-monitor.desktop is a generated file whose path to the executable gets decided at configure time based on the prefix. So that change will get overwritten. That file is defined as DISTCLEANFILES, but it should just be CLEANFILES so that it's not in the tarball.

However, I did notice when looking at the debdiff that the translation changes are wrong! They seem to be undoing the translation of all the help documentation! I'm looking into that.

Michael Terry (mterry) wrote :

OK, try this. A new upstream release (18.2.1) fixes the non-translated-help issue. This debdiff now includes some extra autotools noise because I made the upstream tarball on oneiric with a newer version of the autotool suite.

But still, the only functional difference is new translations and this bug fix.

I've also uploaded this to natty-proposed.

Michael Terry (mterry) on 2011-06-13
Changed in deja-dup:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 19.2.1-0ubuntu1

---------------
deja-dup (19.2.1-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - Provides Ubuntu One support
    - Fixes "Preferences aren't saved" (LP: #774897)
  * debian/control:
    - Add Recommends for python modules needed for Ubuntu One
    - Move other cloud python modules to Suggests
  * debian/patches/enable-u1.patch:
    - Unconditionally enable U1. deja-dup normally checks for the version
      of duplicity, but since I backported U1 support, just assume it is
      supported.
 -- Michael Terry <email address hidden> Mon, 13 Jun 2011 12:15:00 -0400

Changed in deja-dup (Ubuntu):
status: Fix Committed → Fix Released

Just installed Deja on xubuntu via 'Software Center'. Same problem - won't store preferences. Loses settings to backup to second disk on same machine.

Michael Terry (mterry) wrote :

technoboi, there is a fix in the pipeline, but it hasn't landed as an update yet until it can be verified to fix the bug.

So please, enable the natty-proposed repository as described here (https://wiki.ubuntu.com/Testing/EnableProposed) and let us know if that fixes it for you.

tags: added: verification-needed
Martin Pitt (pitti) wrote :

I just reviewed the deja-dup upload in the natty-proposed queue. It seems the new upstream version reverts pretty much all the Help translations? E. g.

--- deja-dup-18.1.1/help/tr/backup-auto.page 2011-04-15 18:08:59.000000000 +0000
+++ deja-dup-18.2.1/help/tr/backup-auto.page 2011-06-10 14:11:14.000000000 +0000
-<title>Otomatik yedekler</title>
+<title>Automatic Backups</title>

and similar for all languages and help pages.

Michael Terry (mterry) wrote :

OK, third time's the charm. Let's try the simplest possible patch, no translation changes.

Accepted deja-dup into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Preferences now seem to work here with natty-proposed. Are correctly retrieved on launching dejadup settings.

Martin Pitt (pitti) on 2011-06-21
tags: added: verification-done
removed: verification-needed
Jonathan Rogers (jonner) wrote :

natty-proposed package also fixes the reversion from "file" to "s3" backend for me.

Starkid (ladyquelambe) wrote :

I just downloaded this. Nothing seems to have changed. None of my preferences are being saved, not just the backup drive.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 18.1.1-0ubuntu1.1

---------------
deja-dup (18.1.1-0ubuntu1.1) natty-proposed; urgency=low

  * debian/patches/stop-forgetting-external-drives.patch:
    - Fix "Preferences aren't saved" (LP: #774897)
 -- Michael Terry <email address hidden> Fri, 17 Jun 2011 10:36:34 -0400

Changed in deja-dup (Ubuntu Natty):
status: Fix Committed → Fix Released
Rafael Vega (email-rafa) wrote :

I have 18.1.1 from and I still see this problem, I enabled -proposed but deja-dup is not in the updates list. Should I manually install a newer version? How?

Pietro Battiston (toobaz) wrote :

Michael, do you think the following bug could be related?

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644700

As I wrote, applying the patch apparently didn't work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.