Deja Dup won't run without Network Manager loaded

Bug #599632 reported by Lee Rosen on 2010-06-29
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Medium
Michael Terry

Bug Description

Deja Dup gives me a "Paused (no network)" message even though I have a perfectly good, static IP gigabit network connection. In order to accommodate network bridging for VM's running under KVM, I don't run Network Manager (it messes up the bridging configuration by overwriting the network configurations), but Deja Dup seems to have recently acquired a total dependency on that particular module along with some recent fixes that went in. My weekly backups had been working fine under earlier versions, but ceased with the application of updates and/or Ubuntu version upgrade about a month ago.

FWIW -- I have also run into similar Network Manager dependencies in recent versions of Pidgin and Empathy.

The log shows the following:
** (deja-dup:17224): DEBUG: DuplicityInstance.vala:199: Running the following duplicity (17229) command: duplicity collection-status --include=/data/photos --include=/data/music --include=/data/documents --exclude=/home/lfr/.local/share/Trash --exclude=/home/lfr/.Private --exclude=/home/lfr/.recent-applications.xbel --exclude=/home/lfr/.recently-used.xbel --exclude=/home/lfr/.xsession-errors --exclude=/home/lfr/.gvfs --exclude=/home/lfr/.thumbnails --exclude=/home/lfr/.cache --include=/home/lfr --exclude=/sys --exclude=/proc --exclude=/tmp --exclude=** --gio smb://naz/backup-1/ --verbosity=9 --gpg-options= --archive-dir=/home/lfr/.cache/deja-dup --log-file=/tmp/deja-dup-5R6WEV

** (deja-dup:17224): DEBUG: Duplicity.vala:165: No connection found. Postponing the backup.

The error message I get (repeatedly) on stderr is:
** (deja-dup:17224): CRITICAL **: deja_dup_duplicity_cmp_prefix: assertion `b != NULL' failed

I am running:
deja-dup 14.1-0ubuntu0.1
duplicity 0.6.08b-0ubuntu2
Ubuntu 10.04 LTS

Michael Terry (mterry) wrote :

So Deja Dup will only try to use NM if it's available on DBus. Are you sure that NM isn't available without you knowing it? For example, install d-feet, run it, File->Connect to System Bus, and see if org.freedesktop.NetworkManager is available.

Changed in deja-dup:
status: New → Incomplete

Hi Michael,

I have the same setup and situation here. Tried what you suggested: No NetworkManager running, not reachable via DBus, not even the package installed and still, Deja-Dup complains about no connection.

Please write, if we can provide you with more detailed information to solve the problem.

Kind regards,

Sebastian Busch

thing (stp-things) wrote :

I use WICD instead of NetworkManager because NM doesn't work well on a desktop with multiple users. Unfortunately, since NM is not installed, Deja Dup hangs at "Paused (no network)".

Please remove subtle dependency to NM. Why not ping the relevant server directly instead?

Michael Terry (mterry) wrote :

Fixed in trunk. Thanks!

Changed in deja-dup:
assignee: nobody → Michael Terry (mterry)
importance: Undecided → Medium
status: Incomplete → Fix Committed
Michael Terry (mterry) on 2010-09-11
Changed in deja-dup:
milestone: none → 15.92
Michael Terry (mterry) on 2010-09-11
Changed in deja-dup:
status: Fix Committed → Fix Released
Lee Rosen (lfr1138) wrote :

I just upgraded to Ubuntu Maverick, in part to get a newer version with the fix for this in it, only to find the behavior for v16.0 unchanged for a system without Network Manager installed. My info is essentially unchanged from the original report except for the Ubuntu 10.10 OS.

Changed in deja-dup:
status: Fix Released → Incomplete
Michael Terry (mterry) wrote :

Ack! OK, I will look at this again....

Michael Terry (mterry) wrote :

If I do fix it for real in 18.0, it will be available in the maverick stable release PPA for you at least.

Michael Terry (mterry) wrote :

BTW, I looked at this, and still couldn't reproduce. I made sure neither NetworkManager nor ConnMan was running. Deja Dup assumed a valid connection.

Michael Terry (mterry) on 2011-06-17
Changed in deja-dup:
status: Incomplete → Fix Released
Shrijit Nair (shrijith1) wrote :

Hello Michael,

I still the same issue on LM 14 (Ubuntu 12.10 based). Deja-dup 24.0

Steps to reproduce:
1) Try a backup to a local server when you are on the same network - No issues here.
2) Connect to a VPN, so that you are on a different network. Deja-dup says - Waiting for network location.

I would be happy to assist you in this.

barnaba (barnabaturek) wrote :

As network manager comes installed by default in ubuntu and doesn't interfere, it's still rather tricky to find the correct solution (which was to purge the network-manager package). As someone who just spent 30 minutes looking for a solution (despite the bug being fixed) I feel like just trying the server would be a better choice. The logic could look like this:

if there is nm
  see if nm thinks we are connected
  if not
    try backing up anyway
    if worked
      just do a backup and ignore network manager
    else
      wait for nm to say we are connected and retry
  else
    just do a backup and ignore network manager
else
  just do a backup and ignore network manager

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers