Restoring from local hard drive does not work

Bug #563062 reported by Tommy He on 2010-04-14
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Critical
Michael Terry
deja-dup (Fedora)
Fix Released
Undecided
Unassigned
deja-dup (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

It is my first time to use Deja DUp.

Tommy He (tommy-he) wrote :
Tommy He (tommy-he) wrote :

Oops, press the enter button accidentally.

This is my first time to use Deja. I came to this backup tool in Fedora 13 Beta.

What I did is trying to create a backup for my game profiles. I selected the Desktop folder as destination in order to copy the achieve to my external hard drive once verified.

The create backup process went fine, but the testing restoring process always complained about the file already exists, no matter whatever restoring destination I chose. So I can not restore the achieve at all.

Hope it would be fix soon.

Cheers,

kwgoodman (kwgoodman) wrote :

I'm also new to Deja-dup. And I see the same thing:

~/tmp$ mkdir documents
~/tmp$ touch documents/file
~/tmp$ mkdir backup

I then backup the documents folder to the backup folder. When I try to restore to the original location I get an error: "Restore destination directory / already exists. Will not overwrite." So I remove the documents folder:

~/tmp$ rm -r documents/

and try again. Same error.

I'm on Ubuntu 9.10 using deja-dup 14.0.1 from your ppa.

Tommy He (tommy-he) wrote :

Oops, I forget the version number.

I used the deja-dup 14.0.2 in Fedora repo.

Michael Terry (mterry) wrote :

Looks to me like a workaround is to restore to an empty directory. This will let you get your data at least. Am looking into why it happens.

Changed in deja-dup:
importance: Undecided → Critical
status: New → Confirmed
Michael Terry (mterry) wrote :

OK, fix committed. Will release 14.0.3 this weekend. During 13.x development, restore directory handling was changed, but my test suite always restored to an empty directory unfortunately, and this case wasn't tested. :(

Fix is to use duplicity's --force argument to skip the empty-directory check.

Changed in deja-dup:
assignee: nobody → Michael Terry (mterry)
status: Confirmed → Fix Committed
Michael Terry (mterry) on 2010-04-18
Changed in deja-dup:
milestone: none → 14.0.3
Michael Terry (mterry) on 2010-04-18
Changed in deja-dup:
status: Fix Committed → Fix Released
Changed in deja-dup (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 14.0.3-0ubuntu1

---------------
deja-dup (14.0.3-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Fixes restoring into non-empty directories (including to original
      locations). LP: #563062
 -- Michael Terry <email address hidden> Sun, 18 Apr 2010 10:22:47 -0400

Changed in deja-dup (Ubuntu):
status: Fix Committed → Fix Released
moixs (steven-moix) wrote :

The bug still persists in Fedora 13, here is the simple procedure to reproduce it with "deja-dup-14.0.3-1.fc13.i686":

We create some dummy files to backup in a folder on the desktop:
[Steven@dx5150 ~]$ mkdir ~/Desktop/source-folder
[Steven@dx5150 ~]$ touch ~/Desktop/source-folder/file1.txt
[Steven@dx5150 ~]$ touch ~/Desktop/source-folder/file2.txt
[Steven@dx5150 ~]$ mkdir ~/Desktop/destination-folder

We run the backup and control that everything went fine:
Run version 14.0.3 with encryption:
- Encrypt backup files
- Set encryption password
- Remember password
[Steven@dx5150 ~]$ ls ~/Desktop/destination-folder
duplicity-full.20100424T121103Z.manifest.gpg
duplicity-full.20100424T121103Z.vol1.difftar.gpg
duplicity-full-signatures.20100424T121103Z.sigtar.gpg

We remove one of the files from the source directory:
rm ~/Desktop/source-folder/file1.txt

We right-click on the source directory, and select "Revert to previous version". I'm expecting file1.txt to be restored, instead I'm getting an error: "Error creating directory: File exists"

moixs (steven-moix) wrote :

Some mote notes...

The problem only seems to appear when you use the contextual menu on a folder in Gnome. If you directly launch Déjà Dup, select Restore and then "Restore files to original location" it works. But that's useless in most cases IMO, an end-user probably wants to restore files to a specific directory using Gnome's contextual menu and not restore a whole backup.

Changed in deja-dup:
status: Fix Released → New
Michael Terry (mterry) wrote :

Fixed in trunk. Thanks for the detailed reproduction steps! It was a simple error of not ignoring 'directory already exists' errors when trying to create the directory. Will release 14.1 with the fix before next week.

Changed in deja-dup (Ubuntu):
status: Fix Released → Confirmed
Changed in deja-dup:
milestone: 14.0.3 → 14.1
status: New → Fix Committed
Michael Terry (mterry) on 2010-05-01
Changed in deja-dup:
status: Fix Committed → Fix Released
Rahul Sundaram (metherid) wrote :
Changed in deja-dup (Fedora):
status: New → Fix Released
Tommy He (tommy-he) wrote :

deja-dup-14.1-1.fc13 tests successfully.

Accepted deja-dup into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in deja-dup (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
fx5 (packaging) wrote :

The lucid-proposed version works for me. Thank you.

Martin Pitt (pitti) wrote :

Should be fixed in maverick.

tags: added: verification-done
removed: verification-needed
Changed in deja-dup (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 14.1-0ubuntu0.1

---------------
deja-dup (14.1-0ubuntu0.1) lucid-proposed; urgency=low

  * New upstream release
    - Fix restoring a single directory that already exists (LP: #563062)
    - Fix backing up to an external disk (LP: #569418)
 -- Michael Terry <email address hidden> Sun, 02 May 2010 09:20:49 -0400

Changed in deja-dup (Ubuntu Lucid):
status: Fix Committed → Fix Released

I just got the bug in Fedora 15 beta.

Michael Terry (mterry) wrote :

David, hmm... Can you file a new bug with a log and such (the bug form tells you how to gather a log).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers