Ignores include directories with a symlink in the path

Bug #486662 reported by Ben Monnahan on 2009-11-22
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Déjà Dup
High
Unassigned

Bug Description

Ubuntu 9.10
deja-dup 11.1-0ubuntu0karmic1
duplicity 0.6.06-0ubuntu0karmic1

I have a symlink /files -> /home/files. I added /files/Photos to the directories to be backed up. I noticed that it hadn't backed up the Photos dir. Then I change it to /home/files/Photos and it does back it up. I'm backing up to S3 in case that makes any difference.

Let me know if you have any problems reproducing it or need any more info from me.

Related branches

Michael Terry (mterry) on 2010-02-21
Changed in deja-dup:
importance: Undecided → Low
status: New → Confirmed
Michael Terry (mterry) on 2010-05-29
Changed in deja-dup:
assignee: nobody → Michael Vogt (mvo)
milestone: none → 15.3
status: Confirmed → Fix Committed
Michael Terry (mterry) on 2010-06-05
Changed in deja-dup:
status: Fix Committed → Fix Released
Michael Terry (mterry) wrote :

Reopening this. The previous fix only applies to symlinks that are actually used in the include/exclude list. But paths with symlinks higher up in the path (like this original report) only backup up to the symlink!

Working on a fix.

Changed in deja-dup:
assignee: Michael Vogt (mvo) → nobody
importance: Low → High
milestone: 15.3 → 17.6
status: Fix Released → New
Michael Terry (mterry) on 2011-01-17
Changed in deja-dup:
status: New → Fix Committed
Michael Terry (mterry) on 2011-02-05
Changed in deja-dup:
status: Fix Committed → Fix Released
Pasi Tarhonen (pasi-tarhonen) wrote :

I do not know should this fix work still with 11.10, but I have noticed with that Ubuntu version (fully ugraded) that the deja-dup is not following symlinks. Unfortunately, I found that out in a hard way by I losting some files that were not properly backed up due this bug...

I have setup my home folder (EXT4 fs) to contain symlinks to another partition which is shared between Ubuntu and Windows (EXT3 fs). Deja-dup seems not to follow symlinks e.g. my home folder contains ~/Documents that points to /media/DATA/Documents folder, but the content of Documents folder are not included to the backup.

I have just defined my home folder to be backed up and the backup contains only files that are not symlinked. I think that I should I include explicity the /media/DATA with subfolders (which are symlinked to my home folder) to the backup definition.

If I include the symlinked folders to my deja-dup configuration then the symlinked folder are properly backed up. So I need to explicity define ~/Documents folder and also another symlinked folders.

David Tucker (dmtucker) wrote :

It seems like this is not fixed?

I'm running 40.6 and trying to back up KBFS (Keybase) which is at /keybase/private/dmtucker. Both /keybase and /keybase/private are symlinks. My backups include /keybase/private but nothing under it.

Michael Terry (mterry) wrote :

@dmtucker - /keybase/private/dmtucker is in your include list? I just tried a similar setup and it seemed to work for me.

David Tucker (dmtucker) wrote :

@mterry, sorry, I explained that incorrectly...

/run/user/$UID/keybase/kbfs is a mountpoint
/keybase is a mountpoint
/keybase/private is a symlink -> /run/user/$UID/keybase/kbfs/private

I currently have /keybase in my include list, but only these show up in list-current-files:

Tue Jun 23 08:39:25 2020 keybase
Tue Jun 23 08:39:25 2020 keybase/private
Tue Jun 23 08:39:25 2020 keybase/public
Tue Jun 23 08:39:25 2020 keybase/team

(public and team are also symlinks.)

If I add /keybase/private/dmtucker, nothing changes.
Perhaps the issue is that the symlink reaches across filesystems?

I have been able to get the data that matters backed up by adding /run/user/$UID/keybase/kbfs to my include list, but that seems less than ideal long-term.

Michael Terry (mterry) wrote :

@dmtucker Ah yeah, that's intentional. Symlinks down the file tree aren't followed -- only symlinks explicitly added to the include list are followed (per this original bug).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers